TUTORIAL SERIES FOR
Mastercam. ,{

TUTORIAL 14
DRAFT, SWEEP, REVOLVE AND FILLET SURFACES, HIGH
SPEED TOOLPATHS: CORE ROUGHING, HORIZONTAL
AREA, WATERLINE & SCALLOP REST PASSES.




Mill X? TUTORIAL 14

Objectives:

The Student will design a 3-dimensional drawing by:

> Creating the 3D wireframe in different construction planes.

» Creating draft surfaces at a height of 2" with a draft angle of 5 degrees.

> Creating a sweep surface.

» Creating fillet surfaces at the top of the part.

> Creating revolved surfaces.

» Creating fillet surfaces between the draft surfaces and the revolved surfaces.

The Student will create a 3-dimensional milling toolpath consisting of:

> High Speed Core Roughing toolpath.

» High Speed Horizontal finish toolpath.

> High Speed Waterline finish toolpath.

» High Speed Scallop rest passes finish toolpath to clean areas where previous tool did not fit.

The Student will check the toolpath using Mastercam’s Verify module by:
> Defining a 3-dimensional block, the size of the workpiece.

» Running the Verify program to create an intermediate stock.

> Running the Verify program to machine the part on the screen.
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GEOMETRY CREATION

Setting the toolbar states:

é* Before starting the geometry creation we should customize the toolbars to see the toolbars
required to create the geometry and machine a 2D part. See Getting started page A-5 in
the User Notes.

& Toolpaths/Solids operations manager to the left of the screen can be hidden to gain more
space in the graphic area for design. Press Alt + O to remove it.

6" Before starting the geometry make sure that the Grid is enabled. It will show you at each
moment where the part origin is. See Getting started page A-5 for details.

STEP 1:
CREATE THE 3D WIREFRAME IN DIFFERENT
CONSTRUCTION PLANES.

1.1 Create polar lines.

Create
» Line
» Create Line Endpoint

> [ Specify the first endpoint ]: Select the Fast Point icon. &
> Enter the coordinates: -1.0, -1.5 (Enter).

o
» Enter the line Length _ 2.0 (Tab).
6" To set the other parameters of the line use the Tah key.

» Enter the Angle in degrees #g 90 (Enter).

» To keep the same length and angle for the next line click on the Length icon and on the
Angle icon

¢ The values will be highlighted in red. ] £ @

> Select the Apply button. ﬁ

> [ Specify the first endpoint ]: Select the Fast Point icon. &
» Enter the coordinates: 1.0, -1.5 (Enter).

> Select the OK button to exit. &
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1.2 Create the arcs knowing the endpoints and the radius.

Create
> Arc
> Create Arc Endpoints

> Enter the Radius ki 1.Q (Enter).
> [ Enter the first point ]: Select Endpoint A.

> [ Enter the second point ]: Select Endpoint B.

Endpoint B

Trdy

! Endpoint A -\‘ T
6" To select the points move the cursor on the entity until the small !

™y
square appearsﬂ_ , and then click on the point. Using the autocursor
option you can select endpoints, midpoints, center points, quadrants, etc.

> [ Select an arc ]: Select the arc as shown.

> Select the Apply button to continue.
» Use the Fit icon to fit the drawing to the screen.

> Enter the Radius <, 5.0 (Enter).
> [ Enter the first point ]: Select Endpoint C.
> [ Enter the second point ]: Select Endpoint D.

» Use the Fit icon to fit the drawing to the screen.

> [ Select an arc ]: Select the lower arc.

W 3

» Select the OK button to exit.

1.3 Create the fillets with radius 0.25".

Create

> Fillet
> Fillet Entities

> Enter the fillet Radius &2 0.25.
> [ Select an entity ]: Select Entity A.
> [ Select another entity ]: Select Entity B.

% b4
'\ /
2ol o

Select this arc

Endpoint C

Endpoint D

Selectthe |\
arc here

Select Entity A \
here

J

Select Entity ™
C here

Select Entity B
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6" Note that a fillet option will be automatically drawn depending on where you move the cursor
around the entities.

> [ Select an entity ]: Select Entity B.

> [ Select another entity ]: Select Entity C.

> Select the OK button to exit. B

» Change the Graphic view to Isometric. } D ﬁ@

» Use the Fit icon to fit the drawing to the screen.

> Set plane to Front L

1.4 Create a line knowing the first endpoint, the length and the angle.

Create

» Line

» Create Line Endpoints

" Note that the Length and the Angle are locked. (highlighted in red)

> [ Specify the first endpoint ]: Select the Fast Point icon. &2
> Enter the coordinates: 0, -1.Q (Enter).

> Select the Apply button.

> [ Specify the first endpoint ]: Select the Fast Point icon
» Enter the coordinates: 0, Q (Enter).

=
» Enter the line Length 2.25 (Tab).
F’ 1
> Enter the Angle in degrees -—‘-‘-? 0 (Enter).
» Select the Apply button.
& Leave the values locked. (highlighted in red)

> [ Specify the first endpoint ]: Select the Fast Point icon.
> Enter the coordinates: 0, -1.Q (Enter).

(=
» Enter the line Length 2.5 (Enter).

> Use the Fit icon to fit the drawing to the screen. @

» Select the OK button to exit. t£.

> The geometry should look as shown to the right.
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1.5 Create the arc with radius 5.

Srats Select
> Arc Endpoint A Select
> Create Arc Endpoints this arc
> Enter the Radius &2 5.0 (Enter).
> [ Enter the first point ]: Select Point A.
> [ Enter the second point ]: Select Point B.
> [ Select an arc ]: Select the arc as shown.
7 Select
> Select the OK button to exit. f&J Endpoint B

1.6 Create a line knowing the endpoints.

Create

» Line

» Create Line Endpoints

é* Unlock the length and the angle values by selecting the icons in front of them.

> [ Specify the first endpoint ]: Select Endpoint A.
> [ Specify the second endpoint ]: Select Endpoint B.

Select Endpoint A o ‘

Select Endpoint B =

X

» Select the OK button to

1.7 DELETING TWO CONSTRUCTION LINES.

exit. &

> Select the horizontal lines as shown to the right.

> Select the Delete entity icon.

Select
these lines
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1.8 Create the fillets with radius 0.1”.

Create

> Fillet Select Entity A
> Fillet Entities

> Enter the fillet Radius @ 0.1.

> [ Select an entity ]: Select Entity A. Select Entity B

> [ Select another entity ]: Select Entity B.

le-e-|
Top (WCS)
Front (WCS}

> Set planes to Right side.' N i

1.9 Create the arc with radius 5”.

Create
> Arc
» Create Arc Endpoints

> [ Specify the first endpoint ]: Select the Fast Point icon. &2
> Enter the coordinates: 3, -0.221 (Enter).

> [ Enter the second point ]: Select the Fast Point icon. &2
> Enter the coordinates: -3, 2 (Enter).

» Enter the Radius @ 10.0Q (Enter).
> [ Select an arc |: Select the arc as shown.

Select this arc

> Select the OK button to exit. &
> Use the Fit icon to fit the drawing to the

screen.

EEE

[ ropwes)

> Set the plane to Front. 2=

> Change the construction depth Z to 3 in the Status Bar. e ] -~ ENRN
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1.10 Create a polar arc.

Create
> Arc
> Create Arc Polar

> [ Enter the center point ]: Select the Fast Point icon.
> Enter the center point coordinates 0,0 (Enter).

» Enter the Radius &2 2 0.
> Enter the Start Angle % 50 (Tab).

> Enter the End Angle E 13Q (Enter).
> Use the Fit icon to fit the drawing to the screen.

» Select the OK button to exit. &4
» The final 3D wireframe should look like the
picture to the right.

STEP 2:
CREATE THE DRAFT SURFACES.

\ Q\Draft Surface: a surface generated by extruding one or more contours along a hne
_defined by an angle and a length. '

Applrcatlons used to create an angled surface a tapered wall or cones and cyhnders

2.1 Change the Main color to red (#12) and the Maln Level to 2 from
the Status Bar.

> Select Attributes from the Status Bar.

> Changes the Color to #12, the Level to 2 and the Surface Density to 2
as shown.

> Select the OK button to exit the Attributes dialog box. L.
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— Bl Right (wes)

> Change the Construction plane to Top

2.2 Create the draft surface.

Create

» Surface

> Create Draft Surface

> Select the chain as shown in the picture.

Select the
chain here

> Select the OK button to exit Chaining. E

> Change the Length and the Angle as shown in the screenshot.

> The drawing should look like the following picture.

> Select the OK button to exit the command.
> Use the Fit icon to fit the drawing to the screen. @

-
Draft Surface

Bj Gilength ) Plane
20 v e

SR
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STEP 3:
CREATE THE SWEPT SURFACE.

2L kSweep Surface: a surface generated by translating or rotating one or more contours
(across curves) along one or two other contours (along curves).

Applications: used when the across section of the surface at any point is constant (when
the surface is generated from one across contour and one along contour).

Also used when the across section at any section is not constant (when the surface is
generated from two or more across contours and one or two along contours). '

3.1 Change the Main color to blue (#9).

> Select Color from the Status Bar to change the main color to
blue (#9).
> Select the color blue (#9).

> Select the OK button to exit Colors. &

mEEEREREE
3.2 Create the Sweep surface. S b
Create
> Surface i
> Create Swept Surfaces N r

> [ Define the across contour(s) 1 ]: Select Chain 1 as shown.

D Cplare 3130

Select the across
contour here

é* Select the chains in the same directions as shown in the pictures. Please use the Reverse

button from the Chaining dialog box if you need it. ..__._” ! l

> Select the OK button to exit Across contour chaining. e
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> [ Define the along contour(s) 1 ]: Select Chain 1 as shown.

Select the along @
contour here @
nm

vil?2]

> Select the OK button to exit Along contour chaining.
> Select the OK button from the ribbon bar to

complete surface swept creation.
» The geometry should look as shown to the
right.

STEP 4:
CREATE THE FILLET SURFACES BETWEEN THE DRAFT AND THE
SWEEP SURFACES.

between a surface and a curve. .
_Appllcatnon used to smooth sharp edges

> Select Color from the Status Bar to change the h
main color to magenta (#13).
» Select color magenta (#13).

> Select the OK button to exit Colors.

Page 14-10




Mastercam.,

Mill X? TUTORIAL 14

4.2 Create fillet surfaces.

Create
» Surface
> Fillet Surface
> Fillet Surface to Surface
> [ Select first set of surfaces ]: Select the All button. - wa’ e
> Change the parameter as shown, click on the Color button. E f Gz
> Select the color red. ‘ o sve
> Select the OK button. L.¥ ] -
. o
it
[ Blarw mack: in chainrg
N | Igrore decths in
» Select End Selection. r;,.@ i)
a m i Only... fr e Dy Mask
> [ Select second set of surfaces ]: Select the All button. = —”— (Bl = (vI?]
> Select color blue.
e
Bl
£l
E}
0o
2
i
> Select the OK button.
> Select End Selection. | {Exd3geckon] Olfeomindoes
o dophs nchanng ¢
Higm
(@ vI?]
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> Change the parameters as shown in the screenshot to the right. "B Fittet Surfaces to Surfa... @"
é* If the part looks as shown below, you have to change the surface
normals.

1 N

3 24 N

@ (1]
s "“—"f"’:lwla!:i“‘“"ka:“:' W
2 ,‘nm"g?n“n“r . @ o |

.

6" The surface normals should always point toward the center curve of the resulting fillet
surface.

> Select the Flip Normal button to change the surface normaI.EB
> The drawing should look as in the following picture.

& Note that the surface normals for the red color surfaces are all orientated correctly towards
the center of the part. The draft surface (blue) normal is orientated upwards. We will need to

change it. S s
asasess TP
Select /] U5 [ 1 , "hlf‘“
Surface 1 U i ~1

» [ Click surface to flip normal ]: Select Surface 1.
> Press Enter,
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> In the Surface Fillet dialog box enable Trim.

» Select the OK button to exit.

STEP 5:
CREATE THE REVOLVED SURFACES.

u Fillet Surfaces to Surfa... [X

1H )

2 N

[T ]
@ v

[ Tsim Cldoin
[¥] Preview

(v [ 2]

line. . _
Applications: on parts that require arc or circular cross sections.

7%XRevolved Surface: a surface generated by rotating a contour around an axis ora

\\\\\\\

5.1 Change the Main color to brown (#6).

> Select Color from the Status Bar to change the main color
to brown (#6).

> Select the color brown (#6).

Custorze | ' .

i = d iR L e W
Sl |

EEREERNC NN '

> Select the OK button to exit Colors.

5.2 Create the revolved surface.

Create
» Surface
> Create Revolved Surfaces

> Cplane (333D
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> [ Select profile curve(s) ]: Select Entity A (in CCW
direction).
» Select Entity B.

Select Entity B

Select Entity A here

> Select the OK button to exit Chaining. j
> [ Select the axis of rotation ]: Select Entity C.

Select Entity C

» Make sure that the End angle @ is 360.

> Select the OK button. &£.J
> Use the Fit icon to fit the drawing to the screen.

> The surface should look as shown to the right.

> To display the part in a shaded mode, Alt +S.
> To display the part back in wireframe mode, Alt
+S again.
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STEP 6:

CREATE THE FILLET SURFACES BETWEEN THE DRAFT SURFACES
AND THE REVOLVED SURFACES.

6.1 Change the graphic view by using Alt key and down arrow cursor.

> Hold down the Alt key and select the down arrow
cursor key 4 several times until the part looks as
shown in the following picture.

> Screen fit . ‘Q'

6.2 Change the Main color to green (#2).

> Select Color from the Status Bar to change the
main color to green (#2).

{ Gt [2 ] M
AN NN
i i i 3 i By W T R B | g sy

e e Ml S g S e ool

> Select the color dark green (#2). N -
> Select the OK button to exit Colors. |

6.3 Create fillet surfaces.

Create

> Surface

> Fillet Surface

» Fillet Surface to Surface

LA
> [ Select first set of surfaces | Select the All button. {zﬁ ! m o |
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Select All

» Select the color red.
» Select the OK button. !

» Press Enter to continue. _
{] Plane mask ir chaining
[ ignore deplhs in chaining

Same as ..

(] Use Crly Mask

(@ |e] v]2]

> [ Select second set of surfaces ]: Select the All button.
» Select the color brown.

Al Endibies
o Razudt
e Broup

Sioup Manage:

Onoonsn

> Select the OK button. L.¥_
> Press Enter to continue.
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> Change the parameters as shown in the screenshot to the right.

& If the part looks as shown below, you have to change the surface
normals.
1t N
2 N
@ 05 ¥
O s Odoin
(¥ Preview _

&* The surface normals should always point toward
the center curve of the resulting fillet surface.

> Select the Flip Normal button to change the surface normal.
> The drawing should look like the following picture.

é* Note that the surface normals for the red color surfaces are all orientated towards the center

of the part. The revolved surfaces (brown) normals are orientated correctly outwards from
the center of the part. We will need to change the normals of the six red color surfaces.

S A

e
.
=-_':-'_""‘—_‘_-__:_;‘___‘:5:“‘-x,

= .“-—--.-';"‘3?—.
A

s &7

N,

SRR

—

e

£y

: vé}"f )4
\\\{l
%\\

N S

—
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» Select the Zoom Target icon.

> [ Pick point to zoom from ]: Select the center of the part.

Select this
point

» Drag the cursor to make a window around the part as
shown with hidden lines.

Window

Select this point

> [ Choose a second corner for your zooming I:
Select the point as shown.
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> [ Click surface to flip normal ]: Select Surface 1.

6 Make sure that you select the surface on the “flowlines” used to display it. You might need to
zoom the area too

> [ Click surface to flip normal ]: Select Surface 2.

> [ Click surface to flip normal ]: Select Surface 3.

Vo

Surface 5

Surface 6 N

Surface 1 —

Surface 2

Surface 3 / Surface 4 ,

> [ Click surface to flip normal ]: Select
Surface 4.

» [ Click surface to flip normal ]: Select Surface 5.

» [ Click surface to flip normal ]: Select Surface 6.

» Press Enter.

> The part should look as shown to the right.
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> In the Surface Fillet dialog box enable Trim. "B Fittet Surfaces to Surfa... rgf

> The part should look as shown below.

» Select the OK button to exit.

» Change the Graphic view to Isometric. } De E;@

» The drawing should look as shown in the pictures below.

STEP 7:
CREATE A RECTANGLE.

A w

e [Panes |

» Change to 2D plane.

Create Select the

> Create Rectangular Shapes double arrow

> Type the Width and the Height as shown in
the screenshot to the right.

> Select the double arrow to expand the Rectangle Options if
needed.

> Enable the Surface option.
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> Select the center radio button as the anchor.

Select this radio
button

] © (2]

> [ Select position for the base point |. Select the Origin as

BXB®@ || =

shown.
> Select the OK button to exit the Rectangular Shapes |O_g-gltions dialog box.

> Select the Fit button to fit the geometry to the screen.
> The drawing should look as shown in the following picture.
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AT
! ‘H ‘_m_",_,_rﬂw_\.,
___« E__ Mﬂ,
#,__._,,E__:,.

LehAn, .
W X

, XN
LA ”..{ ..\5.\ f/

{Geometry levels

Visble | Name

[ Make main lovel always visile

S

M | evel Manager
£
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HIDE THE 3D WIREFRAME.
> Select Level in the Status Bar.
> Select the OK button to exit. »

STEP 8:
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STEP 8:
CREATE A BOX TO REPRESENT THE STOCK.

20/30].
> Set the plane to 3D. fﬁd Gview i

Create O Poirts
> Create Bounding Box [} Center Poin
> Make the changes as shown in the screenshot to the right. [ Soice
> Expand value along Z-axis is 0.1.

» Select the OK button to exit the command.
> Select the Fit button to fit the geometry to the screen.

) Limes Avcs

Expanid

Shape

» The drawing should look as shown in the following picture.

STEP 9:

SET UP THE DATUM (WORK ZERO) AT THE TOP CENTER OF THE
BOX.

Xform
» Xform Translate

@] o) e

> Select the All button. L
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> Select the OK button to exit the Select All box. 1

» Click on the End Selection button.

> Enable Move.

» Enter Delta Z -1.8093.

> Select the OK button to exit the Translate dialog box.
> Select the Fit button to fit the geometry to the screen. IEI

Screen
> Clear Colors

r
Translate

o] on

Sehect Al

{1 Plare mask in chaining
{Honare depths in chaming

[} Use Ordy Mask

(a)=lv]?]

Abtnbutes
[ Uss New Attributes

o (7]
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> Select the OK button. L.Y_J

> The final geometry should look as shown below.

SAVE THE DRAWING.

File
> File name: “Your Name 14"

Mill X?
STEP 10:
> Save as
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TOOLPATH CREATION

STEP 11:
SET UP THE STOCK TO BE MACHINED.

> To display the Toolpaths Manager press Alt + O.

é“ Make sure that no machine is already selected. You only need one.

Machine fFypa e e e

> Mill drus4? o ¢@ ERP ESVTE DEHD T80 LR T

M HAEE- - )

> Select Default. e RSO N M-S EEOP%- 88k
5] [T ) Jirslca e e L L DR ]

M TEESOR P F
=G vale NG |

| Matrn S|
i oy Prmesies G Nl
“

RLURCEIGLEAD A 2ADWODPED &

b o, o
SARRLLE

> Use the Fit icon to fit the drawing to the screen. @
> Select the plus in front of Properties to expand the Toolpaths Group Properties.

Toolpaths 3 S olids ]

AR T
Select the plus B f|val s

Machine Group —
e \ll Propetties - Generic Mill
B Sﬂm

> Select Stock setup.

Select the Stock
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> Change the parameters to match the following screenshot.

The Stock 0i~|g|n values P
stock, ensuring that you have
an equal amount of extra
stock around the finish part.
Display options allow youto
set the stock as Wireframe
and to fit the stock to the

- screen (Fit Screen). "

[] Display
[v] Fit screen

&) Wire frame
O Solid

+ Stock Qrigin -~
In view
coordinates
x (00
y 00 |
z 0

Machine Group Properties

Tool Settings | Stock Setup | Safety Zore|

the value& that you gn,ter

Feed Ca]culatlorr sei From tool f:: »

Program # 114
Feed Calculation Toolpath Configuration -
@ From toal [¥] Assign tool numbers saquentially
) From material [ Wam of dupicate teol mumbers
| ©) From defaulta [C] Uss tool's step, pack. cootant
Search tool when
©) User defined 4 i oy e
Sneds spisad [ ]
sl Advancad options
— [#] Override defauts with modal values
[¥] Cearance height
[¥] Retraict haight
Sequence 8-
99999 | 1 I
: Mmg HES R TR
| [ALUMINUM inch - 2024 [ ) [ seext. ]

> Select the OK button to exit Toolpath Group Properties. |

...............
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STEP 12:
HIGH SPEED - CORE ROUGHING.

MG
L AN

area clearance cutting pass), and machine the bosses from the outside.

Core roughing toolpaths are designed for machining cores which can be approached
from the outside. An important feature of core roughing is that Mastercam can change the
machining strategy within the same operation if your part has, for example, a mixture of
bosses and cavities. In these cases, Mastercam will cut the cavities inside to out (Ilke an

Toolpaths
> Surface High Speed Toolpath
> Select the OK button to accept the NC name

> [ Select Drive Surface |: Select the All button. Lol

» Select the OK button to exit. : =¥

» Press Enter key.

» Select the OK button to exit Toolpath/surface selection. &

SH00000
i1

?
18

(5 Plars math i sy
ligrerm degttn i chanieg
Gt W ;

[T U Ok Mk

(el V7]
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> Select Toolpath Type and enable Roughing
» Select Core Roughlng

‘\l.ll'hll.t" Hl{—‘h ‘_-; __mlhs - Core Roughing

" Toolpath Type
( Tool
Holder

iz Cut Parameters
{1 Transitions

. Steep / Shallow Area Clearnce Rest Roughing "
@ Linking Parameters {0) |cAD fie..

Arc Fiter / Tolerance Show...
Planes (WCS)
Coolant
Canned Text
: Miscellaneous Values
| ¢ Axis Combination

Quick View Seltings

Tool 1/8BALLEN... |
Tool Diameter 0.125
Comer Radius  0.0625
Feed Rate 6.1609
Spindle Speed 4278
Coolant On
ToolLength 225
Length Offset 4
Diameter Off... 4
CPlane /TP.. TOP

= edited
& =disabled
> Select Tool.
> Click on the Select library tool button. EEE——
> Select the Filter button in the Tool Selection dialog box. '
> Select the None button in the Tool Types area. _[Z] Fiker A

Teasd List Filter

» Click on the Bullnose icon to
select the tool type.

» Select the drop-down arrow
in the Tool Diameter field, and
select Equal.

» Enter the diameter 0.75.

> Select the OK button to exit.

TeoMupid -
. [Fcabiss [FAUeDel)

o i .w.w&.w.w.o..o.w&mnwww&omwmww@wwrw&o’@v

| ﬂw\?;.'_:t e o A =
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> Select 0.75” Bull Nose with a 0.125“ corner radius.

> Select the OK button to exit the Tool Selection dialog box.

> Make the necessary changes in the Toolpath parameters to match the following screenshot.

Surface High Speed Toolpaths - Cor

.- Toolpath Type
v Tool
Holder

[zl Cut Parameters

] Transitions
Steep / Shallow

- Linking Parameters

-~ Arc Filer / Tolerance
Planes (WCS)
Coolant

Canned Text
Miscellaneous Values
Axis Combination

Quick View Settings

Tool
Tool Diameter 075
Corner Radius  0.125

Feed Rate 85568
Spindle Speed 713
Coolant off
ToolLength 375

Length Offset 1
Diameter Qff... 1
CPlane /TP.. TOP

3/4 BULLEN...

= edied
@ =disabled

| Numbet TooiTyps Diametes| ToolName Coret radus

/@ 1 Endmi3.. 07500 3/4BUL. 0.125000in

S e = i
thh-cﬁckl‘umm

- [0 Taol inspection / change

Fetter et oy

[] Fiter Active m

et
I I.::I.;I‘.

Tool diameter; | 0.75

Come radius: | 0.125

Tool name: | 3/4 BULL ENDMILL 0,125 RAD |

Tool mnbar ngthoﬁset 1

"] Force toal change Rapid Retract

Comment

(v ][ %] @] 2]
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> Select the Holder.

1 Open library I

> Select Open library button. LL!
> Select the Cat 40.holders and Open button.
> Select the C4E3-1250 holder

Surface High Speed Toolpaths - Core Boughing

Toolpath Type . : i I
Tool Use holder tor gouge checking Holder clearance :'1’35 l
i~ Holder Eo = 250
CAC3-0020 A | Segment Height  Diam1 | Diam2 | 1
Cut Parameters 02 I 0174 25 25 |
TR 5 C4C4-0011 1 2 0139 25 202
i C4C4-0016 |3 013 202 25
W e gri |4 0174 25 25
i@~ Linking Parameters C4C4-0032 | [ 5 1 295 225
- C4C4-1000 § 05 2% 17
Auc Filter / Tolerance E:g;::g?g el
Planes (WCS) P 4[:5:0020 S | ]
Coolart CAC5-0032
Canned Text C4C5-1000
3 Miscellaneous Values C4ACE-0016
o Asis Combination C4CB-0020
C4C6-1000
C4E3-0500
C4E3-0625
Quick View Setlings BB
A TR =
Tool Diameter 0.75 |
Comner Radius 0.125 | | | caE4-0250 :
Feed Rate 85568 | C4E4-0375 :
Spindle Speed 713 | C4E4-
Coolant Ok === g
Toollength 375 | — L
Length Offset 1 ; I Dpen fibrary ] le ey ] ) 7 )
Dismeter Off... 1 | - New segment |
CPlane / TP.. TOP | ‘ |
i [ Save iary i New Cat 40 holders - et
v =edited

T’Z):disabled o . 2 @
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> Select the Cut Parameters page and make the changes to match the foIIowmg screenshot

Surface quh Speod Toni;}dths Core Roughing

- Toolpath Type
Toot
Holder

iz« Cut Parameters
Transitions
Steep / Shallow

# Linking Parameters

Atc Filter / Tolerance
Planes (WCS)
Caoolant

Canned Text
Miscellaneous Values
Axis Combination

GQuick View Setlmgs

| Tool 3/4BULLEN.. |
Tool Diameter 0.75

Corner Radius
Feed Rate
Spindle Speed
Coolant

| Tool Length
Leng th Difset
Diameter Off..
CPlane / TP...

v = edited
& = disabled

0125
85568
713
Ot
375

1

Stepdown
Stepdown

[¥] Add cuts

Min stepdown

Max profile
stepover

{71 Smoothing

- Tonol cantainment

- Compensate ta: (0]
) Inside %) Center » Duisnﬂe

|+ | it alteal diviance ha ook s

Total offset distance = o

= stepover

% of dia,

Keep toal davan withiry

"3 Distance

{33 % of tool diameter | 1574.0

1 Minimize bunial
(Iptimize cut order
. I ’ To o
Tip comp
Stock to leave ||‘_| 03 ‘|
an walls __

Stock to leave [0.02 l
on floors e |

(v (%)@ 2]

NG
DS

Stepdown options allows you to configure how Mastercam spaces the cuts in Z.
Stepdown value sets a constant Z spacing between cutting passes.
Add cuts feature allows you to insert additional cutting passes in areas of your part where
the profile.is'close to flat. Mastercam will add new cuts to maintain the maximum profile
stepover, while spacing them each by at least as much as the minimum stepdown.
XY stepover settings allows you to configure the spacing between the passes at the same
Z. Mastercam will use the largest value possible (up to the maximum XY stepover) that
does not leave unwanted material between the passes. However, it will not separate the
passes by less than the minimum stepover.
- Stock to leave on your drive surfaces lets you enter separate values for the wall and floor
 surfaces. Note that the stock to leave on walls must be greater than or equal to the stock
 left on the floor. For surfaces that are not exactly horizontal or vertical, Mastercam will
interpolate between the wall and floor values.
- Keep tool down doesn't allow the tool to retract if the distance between the end of one
' pass and the start of the next pass is less than the distance.
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» Expand Cut Parameters and select Transitions to set the Entry helix.

Surface High Speed Toolpaths - Core Roughing

Toolpath Type
i Toal
Holder (33 Entry helix © Protile 1amp

-« Cut Parameters Radius

R T 1ansitans

Steep / Shallow [] Qutput arc moves
I B~ Linking Parameters

Mote: {F helix fails, profile ramp will be used

- Arc Filter / Tolerance

Select the ElanlesMCS]
= Coolant

pl us '(0 ‘: Canned Text
ex p an d Mi_scellanelous‘ Values

Axis Combination

Ruick View Settings

Z ciparance iﬁﬁg
i Tool 3/4 BULLEN.., Enty foed rate v
Tool Diameter 0.75 BlEoeED | 20 |
Corner Radius 0,125 : (=) Plungs 18ls SE———
Feed Ratf B.5568 i
Szindle S:eed 713 | O Feodrah Preferied profile |D o
| Cooln ot i .’ o oot o
Toollength  3.75 L Skip pockets TR
| Length Offset 1 smaller than |1] )
Diameter Off... 1

| CPlane /TP.. TOP
|

= edited
@ = disabled

FAERINEA

ax o
Transiton allows you to configure the entry move that the too! will make as it transitions to
“new Z levels. You can choose to create either a ramp entry, or helical entry move. If the
profile is too small to create a heltx of this size, Mastercam will create a ramp move
instead, \ g
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> Select the Linking Parameters page and change the parameters to match the following
screenshot.

Surface High Speed Toolpaths - Core Roughing

: -foolpalh Type
Tool
Holder

< Cut Parameters

i Transitions
Steep / Shallow
Linking Parameters

Arc Filter / Tolerance
Planes (WCS)
Coolant - e
Canned Text e
Miscellaneous Values
Ayis Combination

% = ] Lineat entrp/siit

Guick View Seitings i imioa = Minimizs Trimening

Tool V4BULLEN, Ses—— ) Ma tiroming
Tool Diameter 0.75
Cormer Radius 0125 Vettical arc ext
Feed Rate 85568
Spindle Speed 713
Coolant Bt
ToolLength 375
Length Offset 1
Diameter Off... 1
CPlane / TP... TGP

' =edited

@ = disabled 1 & || B l ?

':Linking options allows you to configure how Mastercam links air moves when the tool is
not in contact with the part

Minimum vertical retract is a vertlcal retract and constant-Z move at the Part clearance
height.

Leads flelds set the tool moves onto and off of the part at the start and end of each cuttlng
pass. These moves are applied to each pass no matter which cutting pass is selected.
Fitting settlngs allows you to choose how the entry and exit arcs fit to the ends of the
cutting passes.

Minimize trlmmmg sets the path of the retract to be as close to the surface as possuble
maintaining a minimum distance from the surface to fit the arc.

Max trimming distance parameter limits the amount of trimming applied to non-horizontal
passes.

> Select the OK button to exit parameter pages.
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> Enable Do not show this warning again this (e ——

session
>

> Select the OK button to accept the warning.

STEP 13:

This Toolpath has been gouge chacked against the selected Tool Holder.
Areas where the Tool Holder would collide with the part were identified
and the togipath may have been modified to avoid these locations,
Therefore, the toolpath may not have cut alf of the material that you
expected. Check the tnolpath motion in Backplot or Verify to make sure
you have understood what has been machined,

VERIFY THE ROUGH TOOLPATH AND SAVE IT AS A STL FILE TO BE

USED AS AN INTERMEDIATE STOCK.

> Select the Toolpaths manger tab to enable it.
> Select Toggle toolpath display on selected

'I;gdpall“a—[sgtdg 2.

operations to remove the
toolpath display. Select Toolpaths
manager

. % ¥ Y l.ctﬁ ? ‘?
Aq@ vaGe %o _
]Tlo_ﬂmmggms&mdgm_

» Expand the Toolpaths Manager if necessary by

dragging the right side.
> Select the Verify selected Select Verify
operations button.

Toolpaths | Goids | A

expand it

Drag the right side to
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7\&/{ Display 2o
Update after each toolpath updates the stock after each Tdsl
operation.

Moves/iefresh

. - ) . Speed /1T GQualy
Stop on collision pauses the verification when the tool S
tOUCheS the part Wlth a rap]d move. - {¥] Update after each toolpath

Stop options

] Stop on cofiision

7] Stop on tool change
{71 Stop after sach operation

[(verbose

@) w3 e
]
Toolpath:  Surface High Speed

» Enable Turbo mode. Tool #
- Tool label:

i

ralEaKa

> Select the Configure button.

" y "
DA . Verify Optians
2R

agn - Sk,
Initial stock size source should on Sarieis e

be set to Job Setup to use the © e [__sommopnigy_] %030 ||
stock information from Stock e v

Setup. O Sold 5| [ Poksockoomes. ] 2 [29
Use True Solid allows you, after i achdsio - ta = o

Lyindet axis
verifying the part, to rotate and © Sean ook L8
magnify it to more closely check U sec e
features, surface finish, or
éca"ops. ] . = :Qﬁ [ Translucent stock
Change tool/color to change the , e Tool pofle e
color of the cut stock to indicated [S1Use TSl
tool changes in the toolpath. el o comm okt

] Dioplay XrZ apes
[ Compata 1o STL fie
[ Aemuve chips Tool tolerance:

. o Ew : STL tolkerance:
> Select the OK button to exit Verify [ Hide tool 1 ssch 10

Options. ] Msks e thasade
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> Select Machine button to start simulation.

4

» The finished part should appear as shown to
the right.

> Select the Save stock as a file button.

> Save the STL file with the same name as the geometry
file.

> Select the Save button.
> Select the OK button to exit Verify. L.

O Verboss
o (4] () (&)
* - ] g’m mckuaﬂﬂe

STEP 14:
HIGH SPEED - FINISH HORIZONTAL AREA.

“Q e e
AT e RS S R LS e

> Select Toolpath Manager.

> Right-mouse click and hold it down on the folder icon in front of
the Surface High Speed.

> Drag the mouse down and release it.

> Select Copy after.

| -_!;mve before
| Move after
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Toolpaths : Sobds ¢ At |

% B Y

> You should now have two operations. ==
. o AL Properties - Generic M
> Left-click on the second operation Parameters. L

% % 1-Suface High Speed (Core roughing) - [WCS
Parameters
#1-0.7500 ENDMILL3 BULL - 3/4 BULL i

[ Geometry «
! Toolpath - 5070.1K - YOUR NAME _14 NC |
Select Parameters l ol

2 < Sudacs High Spesd | o roughig] - (WES

> Select Toolpath Type ¥ A PSn o ENOMLLBULL - 7 BULL
> Enable Finishing and choose Horizontal Area i S oot 50701 DU NAE 14N

Surface High Spead Toolpaths - Horizontal Area

Q) Roughing
) Firishing
Select Tool page
o
Cut Parameters e
Transitions ? X y
Steep / Shallow | Scallop Raster
Linking Parametess

A Filter / T olerance
Plar=s fWCS] T ;
Caolant | Spira Radal

> Select Tool page and click on the Select library tool button.
> Select the Filter button.

» Make sure that you select the None button first and then the Endmill Flat as the tool type.

Tool List Filter

Toc Haterial
V]HSS Ceramic
[#] Cartude [¥]UserDef 1

Uk mevking () Ti Costed [S]User Det 2

s?ss ‘f lpi i ’ | [ Copy job setup matl J

i

(E=a]
» Change the Tool Diameter to Equal and 0.5
> Select the OK button to exit Filter. L%

> Make sure that the tool is selected and select the OK button to exit Tool Selection.
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» Change the parameters

Surface High Speed Toolpaths -

to match the following screenshot.

Horizontal Area

Z, Toolpath Type i
= Tool _E . - —
Holder ; _Number ' Tool Type DigyehE:MMvIspleame_ Cormer ‘radius
: [ |® 1 Encmi3. 07500.. 3/4BUL. 0125000in
& CutParamelers | @ 2 Endmil. 08000, 1/2FLA. 0000000
©— Tiansiions i
Steep / Shallow Tool name: | 1/2 FLAT ENDMILL
® Linking Parameters o e —
; Tool number; | 2 Length offset: ;»2*' |
’ — ="
Arc Filter / Tolerance o "
Planes (WCS) Head number: iU Diameter offset: 12__ |
...... - Coolant o e o —
- Canned Text Feed iate: Spindls speed: {10
- Miscellaneous Values s =
~ Asis Combination Flunge rate: Retract rate: {541 76 )
[] Force toal change R apid Retract i
Quick View Settings =W : ._
Todl 73 FLATEN.. Right-click for aptions  [Fit fat arvas) A
Tool Diameter 05 : ;
Comer Radius 0 Select ibrary lool... [] Fitet Active
Feed Rate 6.4176
Spindle Speed 1069
Coolant oft
ToolLength 3
Length Offset 2 |
Diametes Off . 2 |
CPlane /TP.. TOP | -
[
< = gdited
& = disabled
» Select the Holder page
é* Note the holder is
already seIeCted Use holder for gouge checking Holder clesance |B-05 |
from the previous — e . = 248
: nnamed Horder Segment | Height | Dism1 | Diam2
ope.ratlon that we it Ay T
copied. B 01 1248 2138
3 0197 20866 20866
4 0.1 2188 248
5 0164 248 248
6 0.05 248 238
7 006 1.1 098
8 0343 098 098
9 0.04 1.175 1.255
: 10 0,586 1.255 1,255
: 1 0107 1.255 0885

Page 14-39




Mill X?

Mastercam,

TUTORIAL 14

> Select Cut Parameters and change the parameters as shown.

face High Speed T

piaths

Horizontal Area

-« Toolpath Type
~« Tool
Holder

= « CutParameters
Transitions
Steep / Shallow
- Linking Parameters

Arc Filter / Tolerance
Planes (WCS)
Coolart
Canned Text
- Miscellaneous Yalues
- Axis Combination

Quick View Seitings

Tool 1/2FLAT EN
Tool Diameter 0.5

Comer Radius 0

Feed Rate 6.4176
Spindle Speed 1069

Coolant Off
ToolLength 3

Length Offset 2

Diameter Off... 2

CPlane /TP.. TOP

¢ = edited
& =disabled

Deh cuts - Y stepover
1 of epth cuts % of d. 80 ]
Min 012375
Max. |0 25 J
- |w} Smoocthing R Keep tool dovsn withir

i M aw radius

{3 Distance

- Profile tolerance {3} % of tool diameter

Offset tolerance

. T ool containment

. Tip comp

- Compensate ta: 1] :

- Onside {# Center 3 Outside : Stock to leave
:> - : - on walls

3 3

: bt 1 Stock to leave
e et et distance b tool radiug St bl on ficors

Total offset distance = 0
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» Select Linking Parameters page.

Surface High Speed Toolpaths - Horizontal Area

« Toolpath Type

Tool Retm;llc ;
Hol earance plane
older {absolute]
| B Cut Parameters Iy
Transitions
| Steep / Shallow it
] Linking Parameters
2 Part clearance

Arc Filter / Tolerance | - I .

Planes (WCS) < ]
| |-~ Coolant 1 .. W e
| |~ CamnedTent | J L .
1| MI‘CE“QHE‘JL}SVE‘{L}ES ‘ e G

----- Axiz Combination
| Leads S e

— ]ﬁ;n;::nir:gi;exit i'u 05 ] Fittmg : T
Quick VYiew Settings —_— :Minimize Trimming
; - . Yertical arc entr 0.075
- Tool 172 FLAT EN... | y | Max ttimming

Tool Diameter 0.5 enie et |EI 075 | distance

| Comer Radius 0

| FeedRate 64176
Spindle Speed 1069

oolant Off

gr?lgtL:B?fTet g Horizantal aic exit

iameter OFff.. 2

Max ramp angle 1100

FEE e e B

v = pdited
& = disabled

[(vI[(®][Q][Z]

Toolpaths | Solids

LA |
> Select the OK button to exit parameter pages. G HL Sl P
> Select the Regenerate all dirty operation button to regenerate e —

the toolpath. 3 2= (3] \Regenerate al drty operatons|
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Toulpaths  Solids i At

> Select Toggle toolpath display on selected operations to

. » B = 0 o1 ¥o
the toolpath display. -
remove the toolpath display A vaD 2 %O
STEP 15: = = [ ot iyt oo o ernior]
HIGH SPEED - FINISH WATERLINE.

High speed waterline toolpath is a finish toolpath that performs muitiple cuts at constant z
depths. Waterline toolpaths are best suited for surfaces whose angles are between 30 and
- 90 degrees (steep walls).

& . Geometry
£8 Toolpath - 5068 6K - YOUR NAME_14.

> Select Toolpath Manager. -
> Right-mouse click (hold it down) on the folder icon in front of the W i )
Surface High Speed (Horizontal) ey s vouR awe_and

| Move after

LCopy before

> Drag the mouse down and release it.

> Select Copy after. A T
BEE vab @ _
CH it e
& 1L Propetties - Generic Mil
& &3 Toclpath Group1
% 2 1 - Sulace High Speed (Core 1oughing) « WS

> You should now have two Surface High Speed (Horizontal) o
operations. 5. Lo SR
> Left-click on the third operation Parameters. 1 SV

Patameters
#2-0.5000 ENDMILLY FLAT « 1/2FLAT E

Select Parameters -"_—-_-Iil:;-.:sa;:unmmrm 1ZRATE

&l Geuirmiy -

> Select Toolpath Type Tesah - 35 -YOUR WAMEAC -
» Enable Finishing and choose Waterline

 Roughing
1% Finishing

Drl\"e e A

a()(@]
oG] (@]

o2 ][@]
L [

Pencil Spiral Radial Check

> Select Tool page.

> Click on the Select library tool button.

> Use the Filter option to select the 0.625 Ball Endmiill.
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> Make sure that you select the None button first and then

Tool List Filter

the Spherical as the tool type.

Tool Types

Taood Diameter

Ca JCE)
Opetation masking Unit masking
He comibiebiaikng |ND unit masking
Heset all

Radus Type
[“IiNone (] Cainer [<] Full
1 ool Material
[“1Hss [v] Ceramic
[¥] Carbide User Daf 1
[¥] Ti Coated User Def 2
b { Alt ] [ Nong J { Copy job setup matt J j

(V][] 2]

» Change the Tool Diameter to Equal and 0.625".
> Select the OK button to exit Filter. -

> Make sure that the tool is selected and select the OK button to exit Tool Selection. &

» Change the parameters as shown in the following screenshots.

Surface High Speed Toolpaths - Water

g

Quick Visw Settings )

Tool 5/8 BALLEN...
Tool Diameter  0.625

Cormner Radius 03125

7] Taclinspection / change S

Feed Rate 6.36626
Spindle Speed 855
Coolant off
Toollength 375
Length Offset 3
Diameter Off_. 3
CPlane /TP.. TOP

= edited

& = disabled

Toolpath Type
« Tool L y "
— Holder el Tool Type Diameter | ToolMame | Comner radis! Tool diameater: 'U 625
: W 1 Endmi3.. 07500 3/4BUL. 0125000in | =
! | .
B Ce‘* ;a'amMe‘e'sd W 2 Endmil.. 05000 1/2FLA. 0000000in | Comelfedus| am—
g =) ez M alers & 3 Enamilz.. 0E20. S/EBAL.0125008 |
— Transitions v 5 e i rodm| wsmmnwu
; Steep / Shalow | | ==
B — Linking Parameters | TDdWl_
- ArcFiter / Toletance | Haadmumber |0 '
Planes (WCS) - - — : - -
- Codlant Feodiale (2000 | | Sl spesdt [12030 |
Canned Text = e
- Miscellaneous Valuss Phegssoe: (1000 | “"““‘“gxf MMMMM |
----- Asxis Combination [ Force tocl

““““““—wﬁj ‘g Commanit
ﬂm»ﬁ:k fot wlmr.

ﬂmm |

| Finish the boss atea.
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> Select the Cut parameters page and make the changes as shown.

Surface High Speed Toolpalhs - Waterline

Tnolpath_T;:e 0 R e
« Tool Cutting method |Cﬁrnh |
Holder Stepdowr
|
= Cul Patamelars Stepdown {004 | —
2 Rest Material -
Transitions AddcusBaRiS [ eI en.
Steep / Shallow S, i e
® Linking Parameters Min stepdown |D'UU‘ | .
Al
| Maimalle e = o
1 Are Filter / Tolerance stepover g%' e Keep tonl dawn within
e Planes (WCS) | '—_——]
NN Ul
e (Coolant ] Smoothing (. Distance | R
Canned Text -

Max radius

| @ %oftool diameter 200 J'

Miscellaneous Values

Axis Combination -
Profile tolerance

Quick View Settings Optimize cut order
| Tool 5/8BALLEN
| Tool Diameter 0,625 Toe! cortainment e s
Comer Radius 0.3125 Eompensatetol ) e Tip comp
Feed Rate 6.36626 : i
Spindle Speed 855 Yinside £t Center Q Outside 1 Stock :r, leave
Gaalsnt oif oy ; _ B
Toollengh 375 Offset distance = | g
LengthOffset 3 (HE & N I - Stack to leave
ng 2 Add offset distance to tool radius Y on floors

Diameter DIf... 3

CPlane /TP.. TOP Total offset distance = 04125

= edited

& = disabled

e

Stepdown is the spacing between cutting passes and is measured along z axis.

Add cuts option allows you to configure adaptive stepdown strategies. Use the Add
cuts feature to insert additional cutting passes in close to flat areas.

Smoothing settings allows you to insert arcs at corners to create smoother tool motion.
The arc radii will depend on the maximum radius that you enter, and the profle/offset
tolerances.

Profile tolerance determines the maximum deviation between the smoothed and
unsmoothed toolpaths and is only applied on the outermost cutting pass.

Offset tolerance is defined in the same way as the Profile tolerance, but it is applied
to all the inner passes
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> Select the Transitions page and enable Tangential ramp.
Tangential ramp creates a true high speed |, _

transition between the cutting passes. ol s S
Mastercam inserts arcs at the beginning and : o

end of the ramp for the smoothest tool =
motion into and out of the move.

T A
> Select the OK button to exit parameter / S

pages. : ]
> Select the R
the toolpath.

= Toolnat_h§ Salids | At | |
egenerate all dirty operation button to regenerate

> Select Toggle toolpath display on selected operations to Toolpaths | Soids | At |
remove the toolpath display. i 2w R

%%g‘p Z{j_‘ @ ol ?*g @‘@3
BNE vaGe N

& B8 [T toolpath display on selected operations
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STEP 16:
REMACHINE THE SURFACE (SCALLOP REST PASSES).

s

%
Rest passes is a finish toolpath that removes material in areas where the previous tool

oolpal

- could not fit.
I;s | o] 2 - Surface ngh Speed [Honzuntal] M

| Parameters

> Select Toolpath Manager.
» Right-mouse click (hold it down) on the folder icon in front of the
#2 - 0.5000 ENDMILL1 FLAT - 1/
& . Geometry -
) Be Toolpath -123 2K -YUUR NAM

Surface High Speed (Waterline)

 Move befare {0 ENDMILL2 SPHERE -

Move after b
Copy before {1416 9K - YOUR NAME

(Waterline) operation. - :

= £ 2- Sulece High Speed [Horzantal] - (WES: TOI
% Parameters

#2-05000 ENDMILL1 FLAT - 1/2FLATE

& Geometry -
Toolpath - 123.2K - YOUR NAME_14 NC -
iz [ 3 - Surface High Speed (Waterline} - [(WCS: TOH

Parameters
¢ § #3-06250 ENDMILL2 SPHERE - 5/8 BAL

Select |
Pa ramete rs - [l Geometry -
Toolpath - 1416.59K - YOUR NAME_14.NC -

= 4 - Surface High Speed (Waterline) - (WES: TOR

Patameters
#3- 06250 ENDMILL2 SPHERE - 5/8 BALY

» Drag the mouse down and release it.
> Select Copy after.
» Select Parameters in the second Surface High Speed

[ Geometry -
Toolpath - 1417.0K - YOUR NAME_14 NC -

» Select Scallop toolpaths =
) Roughing
&3 Finishing

Horizontal Area Raster

F'encd
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» Select Tool page

> Click on Select library tool and then on the Filter to select the 0.25 diameter End mill ball.
> Change the parameters in the Tool page as shown.

Surface Hig

WA Toolpath Type
=« Tool
f— Holder

] Cut Parameters
& RestMaterial
i Transitions
: - Steep / Shallow
% Linking Parameters

A Filter / Tolerance
Planes (WCS)
Coolant

Canned Text
Miscellaneous Values
Agis Combination

Quick \iew Settings
Tool

Tool Diamster  0.25
Comer Radius 0,125
Feed Rate £.4176
Spindle Speed 2139
Coolant Qif
ToolLength 25
Langth Offset 4

| Diamstes OFf.., 4

| CPlane / TP... TOP

|

L

« =edted
& =disabled

| Number ! Taool Type| Diameter

ili’ 1 Endmil3.. 07500..
® 2 Endwil .. 05000...
W 3 Endmi2.. 06250
¥ 4 Encmiz.. 02500..
< e

1/4BALLEN.., |

Select library taal...

[ Todl inspection / change

e AT

ToolName | Cormer radius

4BUL. 0125000 in
1/2FLA..  0.000000 in.
5/8BAL 0.312500in
1/48AL .

Right-click for options

[} Fitter Active

0.125000in, |

Toal number.

Head number:

Feed rate:

Plunge rate: {100.0

Rapid Retract

[ Force tool change

Comment

Finish the areas where the previous tool did not fit.

(V][ %][@][?

> Select the Rest Material page.

> Enable Use rest material.
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» Enable Compute the remaining stock from the Roughing Tool Diameter and change the

parameters as shown.

Compute remaining stock from Roughing Tool enable Mastercam to calculate the stock
based on the areas that could not be cut by a previous tool defined by its diameter and
corner radius.

"

Surface High Speed Toolpaths - Scallop

+ Toolpath Type
v Tool
Holdet

=] Cut Paramalers
|-« Fest Material
Transitions
Steep / Shallow
| @ Linking Parameters

Aic Fiter / Tolerance
Planes (WCS)
Coolant

Canned Text
Miscellarmous Values
Axis Combination

Quick View Settings

Tool Diameter 025
Corner Radiuz 0125

| Feed Rale 64176
| Spindle Spead 2139

| Coolant 0if
ToollLength 25
Length Offsst 4
Diameler OI.. 4
CPiane /TP.. TOP

Tool 1/4 BALLEN..

= pdfited
@ = cisabled

Uiz rest matedal
Compute remaning stock from:
(O Al previous opesations
(O Ona other operation
(& Roughing Tool
Diameter; 10.625

O CAD fin
Stock teschton: |0.02

A&Emrrwm te remaming stock:

(® Use iemaining stock a8 computed

O Adjust remaining =lock to ignore small cusps

(O Adust remaining stock to mill smal cusps

EE Machine Group-1
® i Properties - Generic Mil
& 28 Toolpath Group-1

@ [ 1 - Surface High Speed (Core roughing) - (WCS: TOP} - [Tplane: T
# [ 2- Surlace High Speed (Honzontal) - (WES: TOP] - [Tplane: TOF)
@ [ 3- Suiface High Speed [Waterline) - [WCS: TOP] - [Tplane: TOP]

< W

B e
SR
B o o
e
L

> Select the OK button to exit.

»> Select the Regenerate all dirty operation button to regenerate

the toolpath.

IIN:]EHII

%&nmuomW9

ate al dirty operations
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> Select Toggle toolpath display on selected operations to

remove the toolpath display.

STEP 17:

BACKPLOT THE TOOLPATH.

Tooipaths Sohdsi Art

et

‘% T Y% !ﬁcl'ﬁ'» ??

GG valh & ¥

= oa T

.

toolpath display on selected operations

Toolpaths tab

\

> Click on the Toolpaths Manager tab and on the Select all
visible operations icon to select all operations.

> Select the Backplot selected operations button.

> Make sure that you have the following buttons turned on (they

will appear pushed down).
> Display tool
> Display rapid moves

> Select the Play button

Toolpaths I Sniids

mmg

.mo E

Display tool

Display rapid moves
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> Select the OK button to exit Backplot. &

STEP 18:
VERIFY-TOOLPATH VERIFICATION.

Todpathe [Gobda [An |
W I.Gi'li 9 ?

> Select only the finish operations by selecting first the Surface
High Speed (Horizontal), and then holding down the Shift key
select Surface High Speed (Scallop rest passes). s B a0t

-l Propadies - Geneic Ml
-8 Tockath Group1
= B 1 - Surlacs High Spaed [Core roaghing] < [WES
Paearmoton
11 - 0.7500 ENCMILLI BULL - 24 BULLE
Goometry
*. B8 Toolpath - 070 1K - YOUR NAME_14NE - |
= W 2 - Surtace High Speed [Hesirontal] - (WES: TOR
Paramesess |
- 205000 ENDOMILLY FLAT - 1/2FLAT E1}
% Il Geometry: |
' 53 Toolpath - 1232 - YOUR NAME_TANC - P
= B3 Burace High Speed [Scallop] - (WLS: TOP}
Pacamoten
3 - DE250 ENDMILL2 SPHERE - ENML

- & 'Fubm i‘SEHZ( \'OI.IHN.GME T4 NE -

|1 ) Parameten

¢ 84 - (1 2500 ENDMILL2 SPHERE - 174 Bﬂ_l
Gisometry - |
Toolpath - 835 8 - YOUR NAME_14.KC- P

Toopaths |Sohds |
> Select the Verify selected operations button. _lﬁ!m =|@lciy| 2|
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Update after each toolpath updates the stock after each
operation.

Stop on collision pauses the vern‘“ catlon when the tool
touches the part with a rapid move _ Spmsd ij sty

"} Stop on tool change
"} Stop after sach operation

"Iverbose

> Select Turbo mode. i

> Select the Configure button. L1 LA ,

. Toolpath:  Surface High Speed
Tool #:
Tnal labet

-{j-

> Enable File in the Stock field.

Verify Options

> Select the File Manager icon. o = —
Shape :
O Box

O Gyinder

OFs it
O 5oid N

Initial stoick s soues - Cul

s Lo onigsatin ]

2 gl 2 e :

Stook Re: | | @ 1 Tanslucent stack

> Select the Stl file that you saved
earlier Your Name_14.STL
> Select the Open button.

> Select the OK button to exit Verify
Options. L.X¥.

| Fia name: ' .!Youn NAME_145TL
MyNetwok  Flesftpst  STLPles CSTL
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> The stock should look as shown to the right.

> Set the Verify speed to maximum by moving the slider bar in the speed control bar as shown.

> Select the Machine button to start simulation. E]
> The finished part should appear as shown in the following picture.

> Select the OK

button to exit Verify.
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STEP 19:

POST PROCESS THE FILE. Toopaths | Sobds | i

> Make sure that all operations are selected, otherwise: 2 | ‘

» Click on the Select all visible operations button. é%f—clt j:ﬁifﬁ::; [t @ ;
L L] | .

> Select the Post selected operations button from Toolpaths Manager. |®

A% [ |

:; ost selected operations

[FFFAnFET
[] Oulput MCX fle dsscrigtor | Froperties
El“cm e \..i
[ © Overwits [l Edi g
> In the Post processing window, make all the necessary ©ak
changes as shown to the right.
[] Send to machine
> Select the OK button to continue. A0 s
%:w s
. . L% 1(2]
> Enter the same name as the geometry name in the NC File :

name field.

» Select the Save button.

WyCompuler  Sovmempme  |NC Fee i)
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iy L
X B b Pew RCRoxton Bodems's Boject Campwe Commurkcatiors Toow Wincow ded
b Bl BEYBELABATIEE DS MY VT s 4%%N

-8

W ok a8 Yoo Cracpes Y ment Toat D o brevim Tost

N16 X-,1136 3
T -

> Select the red X box at the upper right corner to exit the Editor.

STEP 20:
SAVE THE UPDATED MCX FILE.

» Select the Save icon.

T TN

-
»
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REVIEW EXERCISE

Student practise. Create the Toolpath for Exercise-

Tutorial 14 as per the instructions below;

Downloaded from www.emastercam.com/files

¢ Note that the URL address is written with lowercase
letters only.

& Tips:
1. Establish the Stock size Y =4.5,X=4.5,2=15
Stock origin X=1.75,Y=1.5,Z2=1.35
2. High speed Core Roughing
Select All
Use 7/16" Bull End Mill with radius 0.0625
Stepdown =0.05
Enable add cuts
XY stepover 45 % of diam
Stock to leave on walls and on floors = 0.05
Transitions —Entry helix Radius 0.2
Linking parameters set to Minimum Vertical
Retract; Part clearance =0.25
Keep default Leads values
Minimize Trimming; distance =0.0825
3. High Speed - Finish Horizontal Area
Copy previous operation and change the
following parameters;
Use 3/8" Flat End Mill
# of depth cuts =1
Enable Smoothing
Stock to leave on walls = 0.05
Stock to leave on floors = 0
XY stepover = 45% of dia.

4. High Speed - Finish Scallop (check Tutorial 15)
Copy previous operation and change the
following parameters;

Use 3/8* Ball End Mill

Select the top red boundary as containments
Stock to leave on walls =0

Stepover = 0.0375

Disable Expand inside to out
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5. High Speed - Finish Scallop rest passes
Copy previous operation and change the
following parameters;
Use 1/8" Ball End Mill
In Rest material page enable Use rest material
Enable Roughing Tool
Diameter 0.375
Corner radius 0.1875

6. Backplot and Verify the toolpaths.
7. Post process the file.
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Objectives:

The Student will design a 3-dimensional drawing by:

> Opening an existing file with 3D wireframe in different construction planes.
» Creating a revolved surface.

> Creating a sweep surface from two across contours and one along contour.
> Creating a sweep surface from an across contour and an along contour.

> Creating two ruled surfaces.

> Creating fillet surfaces between the sweep surfaces and the revolved surfaces.
> Creating fillet surfaces between the ruled surface and the revolved surfaces.
> Trimming the revolved surface with the ruled surface.

> Creating flat boundary surfaces in the open areas.

> Creating the bounding box used for stock definition.

> Creating a rectangular surface at the bottom of the part.

The Student will create a 3-dimensional milling toolpath consisting of:

> High Speed Core Roughing toolpath.

> High Speed Horizontal finish toolpath.

> High Speed Scallop finish toolpath.

> High Speed Scallop rest passes finish toolpath to clean areas where previous tool did not fit.
> High Speed Pencil finish toolpath to clean sharp corners.

The Student will check the toolpath using Mastercam’s Verify module by:
> Defining a 3-dimensional block, the size of the workpiece.

> Running the Verify program to create an intermediate stock.

> Running the Verify program to machine the part on the screen.
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GEOMETRY CREATION

Setting the toolbar states:

é* Before starting the geometry creation we should customize the toolbars to see the toolbars
required to create the geometry and machine the 3D part. See Getting started page A-5 in
the User Notes.

é" Toolpaths/Solids operations manager to the left of the screen can be hidden to gain more
space in the graphic area for design. Press Alt + O to remove it.

é" Before starting the geometry make sure that the Grid is enabled. It will show you at each
moment where the part origin is. See Getting started page A-5 for details.

-

STEP 1: |
OPEN THE FILE. -

The wireframe geometry Tutorial15_wireframe.mcx can
be downloaded from http://www.emastercam.com/files.

é* Note that the URL address is written with lowercase letters
only. = !

File
» Open
> Select the Tutorial15_wireframe.mcx.
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STEP 2:
CREATE THE REVOLVED SURFACE.

2/ iRevolved Surface: a geometrlcal surface generated by rotating a sectional shape
around an axis or a line. e

Appllcatlons on par‘cs that reqwre arc or circular cross sections.

2.1 Change the attributes to create the revolved surface on Level 2
with color red (12).

> Select Attributes in the Status bar.
» Change the Color number to 12 and the Level number to 2.

> Select the OK button to exit. k

LineGipls -~

Paril Style

Level

2 [ gelect.
2.2 Create the revolved surface. | p—
Create Suﬂmw S
> Surface i
> Create Revolved Surfaces ol s

> Enable the radio button in front of 3D and Partial in the Chaining dialog (] [ x (%]
box. -

> [ Select profile curve(s) ]: Select Entity A (in CW direction).
> Select Entity B.

. :
&) @

 OCpre @D |

Select Entity A
here

Select Entity B \
E

> Select the OK button to exit Chaining. L.¥._
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> [ Select the axis of rotation ]: Select Entity A.

Select
Entity A

» Make sure that the End angle mi = 360.

> Select the OK button. &L
The surface should look as shown to the right

> To display the part in a shaded mode, select the Shaded icon or Alt+S.
¢ Alt+S again to display the part back in wireframe mode.

STEP 3:
CREATE THE SWEEP SURFACES.
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3.1 Change the main color to magenta (13).

> Select the Color in the Status bar. Select Color | = System color: 1

evel | 2

» Change the Color number to 13.

'IIIIIIII.‘ N
| _Jo || I) |

M|
» Select the OK button to exit. & aigd

3.2 Create the swept surface with two across contours and one along
contour.

Create

> Surface

> Create Swept Surfaces

> Select Chain in the Chaining dialog box.

> [ Define the across contour(s) 1 ]: Select Chain 1 as shown.

> [ Define the across contour(s) 2 ]: Select Chain 2.

é" Select all the chains in the same directions. Please use the Reverse

button from the Chaining dialog box if you need it. M’

7 ( ﬂi\

\\\ ~\\‘:\‘ - // :
Select Chain1 1 Select Chain 2 >
> Select here here the OK button to exit across
contour chaining_ |
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> [ Define the along contour(s) 1 J: Select Chain 1 as shown.

3 Cplane £33 3D

Select Chain 1 here

bar to complete surface swept creation.
> The surface should look as shown below.

3.3 Create the swept surface with one across contours and one along
contour.

Create

» Surface

> Create Swept Surfaces

> [ Define the across contour(s) 1 ]: Select Chain 1 as shown.

(&) |
=] |

here

| N—

> Select the OK button to exit across contour chaining.
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> [ Define the along contour(s) 1 ]: Select Chain 1 as shown.

(] &

{3 Cplane 13 3D

b g i‘-"v ks —'I"--."I j-—l'_ = s e
—*1 Select Chain 1

here 1 (D]

;

> Select the OK button to exit chaining along contour chaining. (3]
> Select the OK button from the ribbon bar to complete surface swept

creation, &)
> The surface should look as shown to the right.

STEP 4:
CREATE THE RULED SURFACES.

Applications: any time a surface must be fit between two or more o

contours. i 5 |

\\\\\

ooooooooooooooooooooooooooooooooooo

& To properly define a surface:
all of the start points must be lined up, if necessary by breaking an entity of the contour in
two pieces;

the contours should be selected sequentially; and

the contours should be chained in the same direction, or the surface will become twisted
and therefore be incorrect.
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4.1 Change the main color to blue (9).

> Select the Color in the Status bar. T Sen color: |

» Change the Color number to 9.

» Select the OK button to exit. L

4.2 Create the first ruled surface.

Create

> Surface

> Create Ruled/Lofted Surfaces

> [ Select chains1 ]: Select the Arc 1 as shown.
> [ Select chains2 ]: Select the Arc 2 as shown.

.L.I
1

Select Arc 1 —| Select Arczl
| here here

> Select the OK button to exit Chaining. |

> Select the OK button to exit the command. &
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4.3 Create the second ruled surface.

Create

> Surface

» Create Ruled/Lofted surfaces

> [ Select chains1 ]: Select the Entity 1 as shown.
> [ Select chains2 ]: Select the Entity 2 as shown.

(]
(D ]
:
Select Entity 2 (7]
here ralka)

Select Entity 1
here

» Select the OK button to exit Chaining. LY

> Select the OK button to exit the command. ¥

STEP 5:
TRIM THE RULED SURFACE TO THE REVOLVED SURFACE.

Page 15-9




Mastercam

Mill X? TUTORIAL 15

5.1 Create the trim surfaces.

Create

> Surface

» Trim Surface

> Trim Surfaces to Surfaces

> [ Select first set of surfaces ). Select the ruled surface as shown.

> Press Enter to end the selection.

> [ Select second set of surfaces ]: Select the revolved surface as shown.

Select
ruled
surface

Select
revolved
surface

> Press Enter to end the selection.
> [ Indicate area to keep — select a surface to be trimmed ]: Select two points on the ruled
surface as shown.

Click twice here
on the ruled
surface

Click twice here on
the revolved
surface

> [ Indicate area to keep — select a surface to be trimmed ]: Select two poinis on the revolved
surface as shown above.

> Select the OK button to exit trim surface. &£
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> The part should look as
shown to the right.

STEP 6:
CREATE THE FILLET SURFACES.

2 XFillet Surface: a surface ge_h_erated by creating fillets (radius) that are tahgént to the
original surfaces. You can also create a fillet surface between a surface and a plane, and

between a surface and a curve
Application: used to smooth sharp edges.

6.1 Change the main color to brown (4).

> Select the Color in the Status bar.

———
Colors | Customize |

e 1

EERENEE RN
V8 )

» Change the Color number to 4.
» Select the OK button to exit. L.

6.2 Flip the normal of one surface.
Edit

» Change Normal

> [ Select a surface ]: Select this surface

> Move the arrow to a location where you
can see the direction towards which is
pointing and click.

> If the arrow points towards the inside of
the part, as shown, select Flip button.

éi ‘ s ’ = !
6" Press Esc if the arrow points towards

the outside
» Select the OKbutton to exit the

Select this
surface

command. L.
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6.3 Create fillet surfaces with a 0.25” radius between the revolved
surface and the sweep and ruled surfaces.

Create

» Surface

> Fillet Surface

> Fillet Surfaces to Surfaces

> [ Select first set of surfaces ]: Select the
revolved surface.

Select the Revolved
surface

&* Note that there are two revolved
surfaces.

> Press Enter to end the selection.
> [ Select second set of surfaces ]: Select the ruled and the sweep surfaces as shown.

Select these ruled and
sweep surfaces

> Press Enter to end the selection.

» Change the parameters as shown in
the screenshot to the right.

> The part should look as shown
below.

Trim
Preview

> Select the OK button to exit.
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6.3 Create fillet surfaces with a 0.125” radius between the revolved
surface and the sweep surface.

Create

> Surface

> Fillet Surface

> Fillet Surfaces to Surfaces

> [ Select first set of surfaces ]: Select
the two revolved surfaces.

Select the two Revolved
surfaces

> Press Enter to end the selection.
> [ Select second set of surfaces ]: Select the sweep surface as shown.

Select the
sweep surface

» Press Enter to end the selection.

> Change the parameters as shown in the screenshot to the right.
> The part should look as shown below.

(e[ 2]

> Select the OK button to exit. L%
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STEP 7:
CREATE FLAT BOUNDARY SURFACES TO CLOSE THE OPEN
AREAS.

Flat Boundary Surface: a trlmmed surface generated by tnmmmg aflatsurfacetoa
specific boundary. .
Appllcatlons to create a flat surface ona part inside of a closed boundary.

7.1 CHANGE TO 2D.

> Select the 3D toggle function from the Status bar.
é" Note that the system will automatically change the plane to
2D.

3 [TGview Planes [ 2:[0.0 <l

7.2 Create the lines to close the contours.

Create
» Line
> Create Line Endpoint

Select Endpoint A

Select Endpoint B

Select Endpoint C

Select Endpoint D

é° When you move the cursor exactly on the
endpoint of the entlty the system will display a

small square. ZI‘I

> [ Specify the first endpoint }: Select Endpoint A.
> [ Specify the second endpoint |: Select Endpoint B.
> [ Specify the first endpoint ]: Select Endpoint C.
> [ Specify the second endpoint ]: Select Endpoint D.

> Select the OK button to exit the command. &,

Page 15-14




Mastercam.,

Mill X2 TUTORIAL 15

7.3 Create the flat surfaces

Create

> Surface

> Create Flat Boundary Surface

> [ Select chains to define flat boundary 1 ]: Select Entity A.
> [ Select chains to define flat boundary 2 ]: Select Entity B.

finside ] I" wat
Select JfLJ @;Q_J
Entity B QJ

7

> Select the OK button to exit Chaining. |

> Select the OK button to exit surface flat boundary command.

> Select the Geometry Levels from the Status bar. ' =
> Enter “Surfaces” in the Name field and click on the check mark | [

next to level 1 to disable it.
> The Level Manager should look as [ REEEEE
shown.

e armen

> Select the OK button to exit, L%
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STEP 8:
CREATE THE BOUNDING BOX TO REPRESENT THE STOCK.
8.1 Change the Main color to green (#2)

oP
System color: 4

o Level: ]2

es | z:0.0

=l

> Select Color from the Status Bar to change the main color to
green (#2).
» Select the color green (#2).

> Select the OK button to exit Colors.

Colors ! Customize |

| i 2] %
e
8.2 Change the plane to 3D. o ———
> Select the 2D/3D toggle function from the Status bar. D[ Grew [Pones | 200 =

& Note that the system will automatically change the plane to 3D.

Bounding Box

8.3 Create the bounding box.

Create E 1Al Entities
» Create Bounding Box - Create
» Make sure that you have the same settings as shown in the screenshot RS
to the right. =
» The part should look as shown. Ol
[[] Sakids
Expand s
X 05 ~
xos @
2 @

> Select the OK button to exit.
> Using the Fit icon to fit the drawing to the screen.

- (33 Rectangular

4 Cylindsical
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STEP 9:

CREATE A RECTANGLE WITH A SURFACE ON.

9.1 Change to 2D. _ 1
> Select the 2D/3D toggle function from the Status bar. BB e
é* Note that the system will automatically change to 2D mode. ol o s 200

9.2 Create the rectangle with surface on.
Create
> Create Rectangle

> Enter the Width & 10.5 (Tab).

> Enter the Height &3l 7.5 (Enter).

> Select the Surface button to enable it.

> [ Select position of first corner ]: Select the
lower left

corner on Select the lower left N
the box as corner
shown.

¥
> Select the OK button. £
» The part should look as shown.

> Alt +S to see the part in a shaded mode.
> Alt+S again to change it back to wireframe mode.
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STEP 10: 'Se‘im_:t All "
SET UP THE DATUM (WORK ZERO) AT THE BOTTOM i
AND CENTER OF THE BOX. e
I P W

> Set the plane back to 3D. N Rl
Xform B
» Xform Translate 0

i

Y ﬂl‘ Only..
» Select the All button. -~«-J~ '

L s T 0

{"ignore depths in chaining
Same a5,

[} Use Oniy Mask

([8]lev]2]

» Select the OK button to exit Select All.
> Press Enter to end the selection. "Transiate
> Select the Move radio button as shown in the screenshot.

Move Copy Join

X & 6 o6

» Enter Delta Z value -1.225.

on
Altribuites
[ Use New Attributes

vl 2]
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> Select the OK button to exit the Translate dialog box. |
Screen

» Clear Colors
» The geometry should look as shown below.

STEP 11:
SAVE THE DRAWING.

File
> Save as
» File name: “Your Name_15"

> Select the OK button.
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TOOLPATH CREATION
STEP 12:
SET UP THE STOCK TO BE MACHINED.

> To display the Toolpaths Manager press Alt + O.

&* Follow the next step to select the Mill Default only if there isn‘t any machine already
selected ; Otherwise, use the existing one.

Machine type

> Mill

> Select Default.

Toolpaths Screen

Machine Type
Default k.

vt AL AR UL ST LT EBAL LA W T AL 15 W 1
oy Hehz Crcle Sodds Xom Medine Tree Taobels Sopen At Selngy

‘@ lvn FINHMALE:
LS B w%T 4R 40
X G R L S Jiewics e B GmeSanm

IRty R

Bkl GEIFLLS] 4 AEE@ 0D PET N

| 2

> Use the Fit icon to fit
the drawing to the screen. Toolpaths | Soiids || At

> Select the + in front of Properties to expand the Toolpaths s HEEP cl'r-o ? ?

Group Properties.

RAEE valGe @
Select the pIUS e BB Machine Group-1
11 Properties - Generic Mill
| *%

Toolpaths | Sofids © A |

Gh L% EPan P

Machine Group-1
Setup 1l Properties - Generic Mill

-~ Ag8
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» Change the parameters to match the following screenshot. (Sgctoomens.] (Bomdigbex ] | iCi

> Select the Bounding Box button to automatically find the part [_usoids | [ A Enities | | Uns
extents.

Bounding Box

B [/ AR Entities ‘

Lreate e

[JPoints
{"| Certer Point

» Make sure that the expand values are set to 0. Dok,

Expand

> Select the OK button to exit the Bounding Box dialog box.

Display
Fit screen

{3 Wine frame:
3 Solid

- Stock Crigia
In view
coandinates

X {0238615
y |o757815
z (o0
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> Select the Tool Settings tab to set the " Machine Group Properties
tool parameters. Fies | Tool Setings | Stock Setup | Sefety Zone |
» Change the parameters to match the [
screenshot to the right.

Feed Caleutstion Toalpath Carfiguration
(& From ool Assign tool numbers sequentially
€ From materiad [eliam of duplicate tool numbers

£ From defaults [7] Use tool's step, peck, coolant

Search too! kbrary when
{3 User defined , (] e

> Select the OK button to exit Toolpath

Group Properties. |

Advanced options
Overide defacits with modal velues
Clearance height
Retract height
] Adjust feed an arc mave [] Feed plane
Mommarcteed [S0 ]

Pletract rate

|
t
3

|

Plunge e

Sequence &
Stant 1.0

. Matesal
 TALUMINUM ik - 2024

STEP 13:
SURFACE HIGH SPEED - CORE ROUGHING.

L% -

Core roughing toolpaths are designed for machining cores which can be approached :

 from the outside. An important feature of core roughing is that Mastercam can change the
machining strategy within the same operation if your part has, for example, a mixture of

| bosses and cavities. In these cases, Mastercam will cut the cavities inside to out (I|ke an
area clearance cutting pass), and machine the bosses from the outside.

Toolpaths
> Surface High Speed Toolpath

> Select the OK button to accept the NC name
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> [ Select Drive Surface |: Select the All button. o

-|oococon

» Select the OK button to exit. |

> Press Enter key to end the selection.

Toolpath/surface selection

Drive

> Select the OK button to exit Toolpath/surface selection. o
[ Show... :
' Check

o2 J[®]

Show...
Containment L

Approsimate startiog paik

L)
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Surface High Speed Toolpaths - Core Roughing

Tool
Holder

Cut Parameters
Transitions
Steep / Shallow

Linking Parameters

4rc Filter / Tolerance
Planes (WCS)
Coolant

Canned Text
Miscellaneous Values
Agis Combination

Quick View Settings
1/2FLAT EN..
Tool Diameter 0.5
Comer Radius 0
Feed Rate 64178
Spindle Speed 1069
Coolarit off
ToolLength O
Length Offset 1
Diameter Of... 1
CPlane / TP,,. TOP

& = disabled

Chack

o[ ][®]

Containment

ol & J[®]

Appraximate start point

(vI[%]) S I[2]

> Enable Roughing and select Core Roughing.

> Select Tool page.

> Click on the Select library tool button.

> Select the Filter button in the Tool Selection dialog box.
> Select the None button in the Tool Types area.

» Click on the Bullnose icon to
select the tool type.

» Select the drop-down arrow
in the Tool Diameter field, and
select Equal.

> Enter the diameter 0.75.

_ Tool Typss

Dperation masking

o apeticn pkng

Reset al

Unit masking

N =
{ No unit masking

- Toul Matenal

SIHSS
/] Catbide
111 Coated

vl Ceramic
UserDef1
[l UserDef 2

l All ] [ None J [ Copy job selup matl ] 3

» Select the OK button to exit. LV ]
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» Select 0.75” Bull Nose with a .125” corner radius.

> Select the OK button to exit Tool Selection.
> Make the necessary changes in the Toolpath parameters to match the following screenshot.

"

Surface High Speed Toolpaths - Core Roughing

"~ Toolpath Type

v Todl e
i~ Holder Number  Tool Type  Diameter’ ToolName Comerradius  Tooldiameter: 075
= ¥ 1 Endmi3.. 07500 3/4BUL. 01250000
=1 Cut Parameters
; Transitions
Steep / Shaliow

® Linking Parameters

i~ AicFilter / Tolerance

~—— Planes [WCS)

i—— Coolant
Canned Text
Miscellaneous Values
Axis Combination

[} Force tool change Rapid Retract

Quick View Settings
Toof  3/4BULLEN.

-

f |
Ezﬁ:g;ﬁﬁ; 3135 Select library tool... 71 Filter Active |I
|

Feed Rate 85568
Spindle Speed 713 [ Tool inspection / change
Coolant ot i

ToolLength 375 i

Length Offset 1
Diameter Off.., 1
CPlane /TP, TOP

T i ' '
§ i (x)[(&])[ 2]

> Select the Holder page.
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> Select Open library button.

[Dpen Iibrary] l New library |

[s

> Select the Cat 40.holders and Open button.
> Select the C4E3-1250 holder

Surface High Speed Toolpaths

Core Roughing

Toolpath Type
Tool
v Holdet |

[ - Cut Parameters
: - Transitions

- Steep / Shallow
& Linking Parameters

A Filter / Tolerance %

Planes [(WCS) |

Coolant

Canned Teut

- Miscellaneous Values
Agis Combination

Quick View Settings

Tool 3/4 BULLEN.,

Toot Diameter 0.75
Comer Radius  0.125
Feed Rate 85568
Spindls Speed 713
Coolant off
ToolLength 375
Length Offset 1
Diameter DFf... 1
CPlane /TP.. TOP

»  =adiled
& =disabled

Use holder for gouge checking

C4C3.0032
CAC4-0011
c4c4-0016
£4C4-0020
C4C4-0032 i
£4C4-1000 L
CAC41500 B
C4c50016 .
| C4C50020
Cac5.0032
£4C5-1000
C4CE-0016
C4CB-0020
C4C6-1000
C4E30500
C4E30625
C4E30750
C4E31000

C4E4-0187
C4E4-0250
C4E4-0375
C4E4-0500
£ )

C4C3-0020 Al |

Holder clearance

Segment

DA W =

Helght
0174
0139
0133
0174

1
025

- D |am«1

25
25
2.02
25
229
225

:

Dien 2
25
202

250

Segment properties
| Height 1.5

| Upper diameter

Lower diameter

[Dmnﬂxw] [ New libraty l

Save ibiaty New holder

Librany

Cal 40 holders

Mew segment

ra[Ea[r A

AL
PR

part geometry

‘Holder page allows you to create a hoider defwtlon Ioad a holder from an exsstmg
'~i|brary or edit the holder after it has been seiected

Holder clearance field to establish the minimum separatlon between the holder and
your surfac;e model Set the clearance bigger than the stock to leave on the walls.
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> Select the Cut Parameters page and make the changes to match the following screenshot.

Surfa

ce High Speed Toolpaths

Auis Combination

Core Roughing

Piofile tolerance

Offset tolerance

%) % of too] diameter

v Tool Stepdonn KY stepovet
« Holder et [ﬂ 075 % of dia, [50 |
: I ..................
[ & v CutParameters ] Add cuts Min 0.185625 |
Traritior:s =
' Max (03375
| Steep / Shallow Min stepdown ___l
& Linking Paramelsts Max profile
stepover
Asc Filer / Tolerance
o Planes (WCS) ,
fsenesr: Coolant - [¥] Smoothing Keep tacl down within
y X [r—
- Canned Text Max radius 3 Distance
Miscellaneous Values

uuﬁ Vb.w se‘l'.?.g.\f ................................ Tonl containment F ] Mpimizs bord

! 122: i 03;; BULLEN... i o] Dptimize cut order

| Comer Radius 0125 3 Inside (3 Center 3 Outside ! {W

o = o e L

i i, pi S L
Length Dffeet 1 Total offset distance = 0

Stock to leave | 003 |
| Diameters O, 1 on floots Pl
CPlane / TP.. TOP

AER N ER

Stepdown options allows you to configure how Mastercam spaces the cuts in Z.
Stepdown value sets a constant Z spacing between cutting passes.

Add cuts feature allows you to insert additional cutting passes in areas of your part where
the profile is close to flat. Mastercam will add new cuts to maintain the maximum profile
stepover, while spacing them each by at least as much as the minimum stepdown.
Smoothing settings allows you to insert arcs at corners to create smoother tool motion.
The arc radii will depend on the maximum radius that you enter, and the profile/offset
tolerances.

Profile tolerance determines the maximum deviation between the smoothed and
unsmoothed toolpaths and is only applied on the outermost cutting pass.

Offset tolerance is defined in the same way as the Profile tolerance, but it is applied to
all the inner passes.

XY stepover settings allows you to configure the spacmg between the passes at the same
Z. Mastercam will use the largest value possible (up to the maximum XY stepover) that
does not leave unwanted material between the passes. However, it will not separate the
passes by less than the minimum stepover.

Stock to leave on your drive surfaces lets you enter separate values for the wall and floor
surfaces. Note that the stock to leave on walls must be greater than or equal to the stock
left on the floor. For surfaces that are not exactly horizontal or vertical, Mastercam will
interpolate between the wall and floor values.
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> Expand Cut Parameters and select Transitions to set the Entry helix.

Surface High Speed Toolpaths - Care Roughing

=t

Select the
plus to
expand

Toolpath Type
« Tool
Holder

Cut Parameters

B T ranfiony
Steep / Shallow

i3 Linking Parameters

Arc Filter / Tolerance
Planes (WCS)
Coolant

Canned Text
Miscellaneous Values
Asis Combination

Quick Yiew Settings

| Tool 34 BULLEN.,,

Toot Diameter  0.75
Comer Radius 0125
| Feed Rate 85568
; Spindle Speed 713

I:oolant ot

2 ToolLength 375
| LengthOffset 1
| Diameter Off... 1

il:Piane/TP 0P
|
%,
o, = cited
@ & disabled

(%) Enlry hely
Radiua 0S|

[} Output are moves

Note: If helix fails, profile ramp will ba used

Eniry Tfoed rate
& Plunge iate

C) Feed 18l

Z clearance

Plunge angle

Prefened piofie
length

Skip pockets 2555
smaller than =

AL
ZAS

instead.

Transntlon allows you to configure the entry move that the tool wnll make as it transitions to~:
“new Z levels. You can choose to create either a ramp entry, or helical entry move. If the
profile is too small to create a helix of this size, Mastercam WI|| create a ramp move
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> Select the Linking Parameters page and change the parameters to match the following
screenshot.

Surface High Speed Toolpaths - Core Roughing

Toolpath Type
Tool : Hetracis L e
Holder i Clearance plane LE | Minirtium Vertical Retract Wl

[absolute]

=« Cut Parameters
+ Transitions

Steep / Shallow

#- « Linking Parameters

Arc Filter / Tolerance
Planes (WCS)
Coolant

o Canned Text

- Miscellaneous Values
Axis Combination

o Lmads
Linear entry/exit |Eﬁ | Fittg
i fincremental) leccar RN, | . e ot =
Quick View Sel!m Vet TR Minirmize Trimming vJ
At - ' " | 15
CTool “3/4 BULL EN ; S el _ Max timming noes |
Tool Diameter 0.75 i . ; 007 distance fi=——= .
Corner Radius  0.125 Ve e S -
' FeedRate 85568 .
: Spindle Speed 713

. Coolant ot |
ToolLength 375
Length Offset 1 |
Diameter Off... 1 L =1

CPlane / TP.. TOP

o
L

¢ = edited

& = disabled [—-x—] [—m m

~ Linking options allows you to configure how Mastercam links air moves when the tool is
 not in contact with the part

Minimum vertical retract is a vertical retract and constant-Z move at the Part clearance
height.

Leads fields set the tool moves onto and off of the part at the start and end of each cuttmg
pass. These moves are applied to each pass no matter which cutting pass is selected.

~ Fitting settings allows you to choose how the entry and exit arcs fit to the ends of the

~ cutting passes.

Minimize tnmmmg sets the path of the retract to be as close to the surface as poss:ble
maintaining a minimum distance from the surface to fit the arc.

Max trimming distance parameter I|m|ts the amount of trlmmlng applled to non- honZontal
passes.
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> Select Arc Filter/ Tolerance

Surface High Spesd Toolpaths - Core Roughing

Tookpath Tups =
v Tool
| v Holder
1| Filter ratio
| B« Cut Paramelers
Transitions Filter tolerance
Steep / Shallow
i Linking Paameters Cut tolerance
oo B Filles / Tolerance Total tolerance :U_UU'Z |
I . Planes WES) Em——
e Coolant [T One way fitering
i == Carined Teut
Mizcalaneous Values
#Asis Combination Create aics in XY
[} Create arcs inX2
e i {7] Create arcs in YZ
Qu&\&ms ot = Minimum arc radius
Tool 3/4 BULLEN , _
| Tool Diameter 0.75 Maximum arc radius

Comer Radius  0.125
Feed Rate 85568
Spindle Speed 713
Coolant off '
ToolLength 375 ik ot
Length Offset 1 T
Diameter OFf... 1
CPlane / TP.. TOP

o sedied
@ = dsabled

(vI[®][(D][7]

Filter ratio is the ratio between the filter tolerance and the cut tolerance and is typically set
to 2:1. When you filter a toolpath, Mastercam replaces multiple small toolpath moves that
lie within a specified tolerance with a smgle tool move to simplify the toolpath. You can

also optionally replace multiple linear tool moves W|th an arc move of a specified mlnlmum v
and maximum radius.

Cut tolerance determines the accuracy of the surface toolpaths using chordal deVIatlon to
linearize the toolpath.
Total tolerance is calculated as the sum of the cut tolerance and filter tolerance

> Select the OK button to exit parameter pages. |
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> Select Toggle toolpath display on selected operations to

remove the toolpath display.

STEP 14:

Todmms Suid-S|AJ! i

Gh D% EPcih P P

HIGH SPEED - FINISH HORIZONTAL AREA.

g ITgle toolpath display on selected operations

HNE vaG 2 XQ

A/
/A\:

exit on a sidewall.

‘Horizontal Area toolpaths are designed for machining the flat areas of your surface
model. Mastercam will create cutting passes at the Z height of each area. Even if the drive
surface as a whole is not flat, Mastercam will identify and only machine the flat areas.
Mastercam will automatically calculate the toolpath in such a way that the tool does not

> Select Toolpath Manager.

> Right-mouse click and hold it down on the folder icon in front of

the Surface High Speed.

» Drag the mouse down and release it.

> Select Copy after.

> You should now have two operations.
> Left-click on the second operation Parameters.

> Select Toolpath Type

ace High Speed ([
Paamdﬁs
7503ENEIH|LI
ity -
Eh 5070.1K -

%«i&en*{x l@m'{a’a ? 9
m%; vAE-%:%’léQ

:EE Machina Group-1
% 1t Properties - Generic Ml
i §§ Toolpath Group1
@ I 1 - Suface High Speed (Core roughing) - (WCS
Paiameters

#1.0.7500 ENDMILL3 BULL - 3/4 BULL B

Select Parameters

Geometry -
Toolpath -5070.1K - YODUR NAME_14 NC

> Enable Finishing and choose Horizontal Area

Select Tool page | — ||

| kme(el:

#Y$0.7500 ENDMILL3 BULL - 3/4 BULL
Geometry
Toolnath 5070 1K . YOLR NAME 14.NC §

|

e

2

B

Holder

- Cut Patamedars

Transitions |

- Steep / Shallow i
Linking Paramaters

Asc Fiter / Tolerance |
Planes (WCS) I
Coolant Il Penc

Spiral Radial

> Select Tool page and click on the Select library tool button.

» Select the Filter button.
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> Make sure that you select the None button first and then the Endmill Flat as the tool type.

r

Tool List Filter

- Tool Types

Operation masking Urit masking

M ot e | Mo unit masking

Tool Diamete

{1 Corner [FlFul

Tool taterizl
HSS
Carbide
Ti Coated

FA_II ] [ Nong J { Copy job setup matl ]
(v %] ?]

Ceramic
User Def 1
User Def 2

> Select the OK button to exit Filter. |

» Make sure that the tool is selected and select the OK button to exit Tool Selection. ’
» Change the parameters to match the following screenshot.

Surface High Speed Toolpaths - Horizental Area

Cut Parameters
Transitions
Steep / Shallow

Linking Parameters

Arc Fiter 7 Tolerance
Planes (WCS)
Coolant

Cannhed Text
Miscellaneous Values
Asis Combination

Quick Yiew Settings

Tool Diameter 0,375
Comer Radius 0

Feed Rate 6.33203
Spindle Speed 1426
Coolant off
ToolLength 25
Length Offset 2
Diameter Off . 2
CPlane /TP TOP

Tool A/BFLAT EN..

| NumbetjMToq!_qu_eE Diamater | Tool Name Corner radius;
@ 1 Endma3. 07500.. 3/4BUL. 01250000 |
92 0.000000n |

Endmdl .. 03750 3I/BFLA.

e

" Rlight-click for options

e
[ Tootiispection # change

Select fibrary tool...

Fooe rstiel desss

Tool diameter 0375 |

Corner radius: :G_U_

Plunge rats:

[} Force tool change Rapid Retract

Comment
| Finish the flat areas
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> Select the Holder page

Use holder for gouge checking Holder clearance [U- 08 }
| Unnamed Helder Segment  Height Diam 1 Diam 2
| il 0375 248 248
2 a1 2.48 2138
| 3 0197 2.0866 20866
4 a1 2108 248
5 0,164 2.48 248
[ 005 248 238
7 0.08 1.1 098
9 0.343 098 038
3 0.04 1,175 1.255
10 0586 1.255 1.255
1 0107 1.2585 0.885
|

& Note the holder is already selected from the previous operation that we copied.
> Select the Cut Parameters page and change the parameters as shown.

Surface High Speed Toolpaths - Horizontal Area

v Toolpath Type |
~» Tool
v Holder Gehole- 0 WY ABPOYEE
- Tt Paramaters 1 of depth culs _11 | % of dia.
Transitions ; roamaeme )
; Steep / Shallow > l ] | Min
&= Linking Parameters
Arc Fitter / Tolerance
Planes (wCS)
Coolant [Z] Smeothing
Canned Text
Miscellaneous Values Mg
Axis Combination B e tolerarion O xoltoold 104?:33 ----- -*i
Olfset tolerance e
Quick View Settings
Tool  3/BFLATEN.. |
Tool Diameter 0375 T ool containment e e i
Comer Radius 0 I o o Tip comp
Feed Rate 633203 7 4 L
Spindle Speed 1426 O Insida @ Center. 73 Dtside Stock tﬁa leave
Coolant oft | o on walls
ToolLength 25 e : £ Stock to leave
Length Dffset 2 e s romR e R i
Diameter OFf... 2 1 Add offeed diilaies Lo tank t.‘%.:,‘*?,‘ an floors
CPlane / TP.. TOP

Total offset distance = o

~* = edited

o el | xS 7]
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» Select Linking Parameters page.

Surface High Speed Toolpaths - Horizontal Area

« Toolpath T ype

Tool Retiacts
Holder Clearance plane [ Minimum Vertical Retract
{absolute)

&« Cut Parameters [¥] Qutput feed move

Transitions
Steep / Shallow
Linking Parameters

Arc Fifter / Tolerance
Planes (WCS)
Coolant

Canned Text
Miscellaneous Values
Axis Combination

Loads L =
Linear entry/exit [ogs | Fitting
{incremental { .3 s S
Quick View Settings ! ] = Minimize Trimming v%

Tool 172FLATEN.. |
Tool Diameter 0.5
Corner Radius 0 |
Feed Rate 6.4176 i
Spindle Speed 1069 i
Coolant oK ‘

Ma tiimming TR
distance i

Vertical arc exit

ToolLength 3
Length Offset 2

| Diameter OFf... 2

' CPlane /TP.. TOP

Horizontal arc exit

Max tamp angle

v =edited

@ =dsabled L&J m LQ_J i__c?_l

> Select the OK button to exit parameter pages. L.¥ _
> Select the Regenerate all dirty operation button to regenerate T ——— qperetus)

the toolpath.

Page 15-34




Mill X?

Mastercam

TUTORIAL 15

> Select Toggle toolpath display on selected operations to
remove the toolpath display.

Toolpaths | Soids | At |

w% Lk SPak ? ‘?

AEE vah & %@

STEP 15: | & B8 [Fogge toobpath dsiay on selectad operations
CREATING A BOUNDARY USING SILHOUETTEBOUNDARY.DLL
C-HOOK.

party application developers, or by CNC Software itself.

C-Hooks are and NET-Hooks are edd -in applications or utilities that customize, enhance, or
extend Mastercam's functionality. They can be created by individual users, resellers thlrd- i

» Change z depth of the construction plane to 2.

> To open the Chooks directory press Alt+C.

> Select SilhouetteBoundary.dll from the
list.

» Select the Open button.

> Select the OK button.

» Select the flat bottom surface to
unselect it.

Select this flat surface

» Press Enter to finish the selection.
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» The boundaries will look as
shown in the following
screenshot.

STEP 16:
HIGH SPEED - FINISH SCALLOP.

High speed scallop toolpaths differ from other finish toolpaths in that the stepover distanpe
is a 3D value which is measured along the surface, instead of parallel to the toolplane. This

ensures a consistent scallop height across the surface, regardless of the surface direction.

[ Geomety
' B2 Toolpath - 5068 6K - YOUR NAME_14
> Select Toolpath Manager. iv
> Right-mouse click (hold it down) on the folder icon in front of the L B oLl FUAT™ 1)
Surface High Speed (Horizontal) [ Hovebetrs T 0k rouR a1
Copy before :
» Drag the mouse down and release it. Copemrme—
> Select Copy after. G BE SR PP
GER vaDS XY

= &8 Mactine Gioup-1
@ 1l Propetties - Generic Mil
i 83 Toolpath Group-1
% @2 1 - Suilace High Speed (Cose soughing) - WCS

> You should now have two Surface High Speed (Horizontal) i o

] Geometry -

operations. | B o s Yo 5
» Left-click on the third operation Parameters. 10 2. Sulos i Smnd ol WES: TO

) Paameters
#2-0.5000 ENDMILLY FLAT . 1/2FLAT E

1
g— i < SO0 ENDMILLY FLAT - 1R RATE

» Select Toolpath Type Select Parameters

| i# [l Geomenny .
I Tocipaih - 560 - YOLF NAME_ 14T - Py
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» Enable Finishing and choose
Scallop

Show...

Chaek s

o)

Contamment
D=

> Click on Containment button as shown.

» Select the first boundary as shown. =
I -\Dcfpfahs. ?30
Select the first @—]
boundary
|

Select the - 00
second finsds % Clwat
it

(@]
.

» Selet the End chain

button in the Chaining dialog box. L.
> Select the second boundary as shown above.

> Select the OK button to exit Chaining. ! v
> Select the Tool page.

» Click on the Select library tool button.

Page 15-37




Mastlercam,

Mill X? TUTORIAL 15

> Use the Filter option to select the 0.5 Ball Endmiill.
»> Make sure that you select the None button first and then the Spherical as the tool type.

Tool List Filter

Tool Diametes
@ ................... v| [U_s b
N — =
Radius Type
Coimer Full
Tool Material
[wlHSS Ceramic
Carbide User Def 1
[¥] Ti Coated [¥] User Def 2

l All } [ None ] [ Copy job setup matl ]

o e

> Change the Tool Diameter to Equal and 0.5".
> Select the OK button to exit Filter.

» Make sure that the tool is selected and select the OK button to exit Tool Selection. L
> Change the parameters as shown in the following screenshots.

Surface High Speed Toolpaths - Scallop

¥
e Toolpath Type
i Todl o W
“ Holder Number ToolTypn| Diameter| Too|Name | Cormet radius]
@ 1 Enami. 07500, 34BUL. 0125000in |
Bl CutParameters @ 2 Endmil . 03750 3/8FLA.. 0000000in
S peatkateral B 3 endmic 05000, 1ZBALL 0250000

Transitions
Steep / Shallow
Linking Parameters

Auc Filter / Tolerance

Planes (wCS)
Coolant
Canned Text
Misceflaneous Values Plunge rate: i vl
gRazorbnation "I Force tadl change Rapid Retract
s e i
Quick View Settings o H@ﬂ T L Linirert L
-click for oplions T E
Tool 1/2BALLEN.. Finish the boss areas =

Tool Diameter 05 . . .‘
cgﬁ,e,l;rggi:; 025 Select library taol... [ Fitter Active

Feed Rate 64176

Spindle Speed 1069 [ Test inspection / change
| Coolant Ot e TN
Teollength 3 G ah I | rEe g .
Length Offset 3 FIiTE s avery —
Diameter Off... 3 _ {0 Ml : ‘

CPlane /TP, TOP

Page 15-38




Mill X? TUTORIAL 15

> Select the Cut parameters page and make the changes as shown.

Surface High Speed Toolpaths - Scallop

=V T T —————
g ol Cutting method {OneWay v
Holder
Stepover
= o Cut Parameters . [} Expand inside to out
2 Rest Material Scallop height
Transitions
----- Steep / Shallow
| & Linking Parameters
| Arc Filter / Tolerance
Planes (WCS)
s lant v
" E::::d Text f ¥.eep toal down vithin
Miscellaneous Values | Down / ug mil - Distance
Axis Combination | . i
| L s = | 9 % of tool diametes
Quick View Settings | EeRES ]
[Tool  1/2BALLEN. . i
Tool Diameter 0.5 T ool containment KPR
Eg;ge;;':;d'us gi?m Compensale to: (2 m Stock to leave
Spindle Speed 1069 : 3 Inside i3 Center {2 Outside on walls
e ot ] — e
Talaals Gifsat distance ol ] ;s tock b eay
Length Offset 3 Add oftset distance o tool radius .
Diameter Of... 3
CPlane /TP.. TOP Total offset distance = 035
~ = adited
& =disabled
v [ % ][&][2]

Stepover is the spacing between cutting passes and is measured as a 3D value along the
surface.

Scallop height value is linked to the stepover value. When you enter a value in one of the
field the other field value is updated.

Expand inside to out disabled allows the machining to start from the outside towards the
center of the part. In this case we avoid cutting with the tool center.

> Select the Transitions page and enable Tangential ramp.

Tangential ramp creates a true high speed
transition between the cutting passes.
Mastercam inserts arcs at the beginning and
end of the ramp for the smoothest tool
motion into and out of the move. _ 7 7

# Transton

) Tangential ramp S Ramp < Straght

A A
> Select the OK button to exit parameter : s /A

pages. |
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> Select the Regenerate all dirty operation button to regenerate
the toolpath.

Toclpaths | Soiids | At |

|
ma LG EPcl P 1

= @ JEQL"E*‘"'W;Q

» Select Toggle toolpath display on selected operations to Toopaths | Soids At

remove the toolpath display if needed.

STEP 15:

REMACHINE THE SURFACE (SCALLOP REST PASSES).

S
B

tool could not fit.

Scallop rest passes is a finish toolpath that removes material in areas where the previous

> Select Toolpath Manager.
> Right-mouse click (hold it down) on the folder icon in front of the

Surface High Speed (Scallop)

» Drag the mouse down and release it.

> Select Copy after.
> Select Parameters in the second Surface High Speed (Scallop)

operation.

Parameters

& BB Machine Group-1
q AL Propertes - Genesic Ml
Toolpath Group-1
«;;Q) Surlace High Speed [Core roughing] - [WCS: |
Parameters
#1-0.7500 ENDMILL3 BULL JMBLILLE
T [ -
: Toalpath - 5070 1K - YOUR NAME_14 NC -
& n 2 - Suface High Speed {Horzortal] - [WCS: T{'I
Paameters
B2+ (L5000 ENDMILLY FLAT rzmren
% [l Geometry |

Tookath - 123 2K - YOUR NAME_14NC - P
=i

Move before
Move after ENDMILL2 SPHERE - S8 BAL|
Capy belore

m!’;ﬁ [ - YOUR MAME_14NC -
—

| 3 D 3 Suface High Speed (Scalop) - WCS: TOFI |

Select —~—] |

[n] n 2 - Surface High Speed (Horizental) - [WCS: TDF
Parameters
#2 - 0.5000 ENDMILL1 FLAT - 1/2 FLAT EI’

Genmetry -
Toolpath - 123.2K - YOUR NAME_14 NC - P

Parameters

i~ B #3-0,6260 ENDMILL2 SPHERE - 5!'88.0]_

: 3 I Geometry - i
» Toobdh 25610( YDUFI HAM

" #4- 02500 ENDMILL2 SPHERE - 174 BAL

B Toolpath - 5767 9K - YOUR NAME_14NC -

I‘ E . Geomstry -
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> Select Tool page
> Click on Select library tool and then on the Filter to select the 0.125 diameter End mill ball.
> Change the parameters in the Tool page as shown.

Surface High Speed Toolpaths - Scallop

¥

Toolpath Type
Tool . - o e
Holder Nurnber | Tool Type | _Diameter | TooiName: Comerradus  Tool diameter: (0.125
W Endmil3.. 0.7500.. 3/4BUL.. 0.125000in.

Corner radius: 0.0625

8 g“ :“T:‘e's | @ 2 Endmil. 03750.. 3/BFLA. 0.000000in _ _
S palens @ 3 Endmiz.. D5000.. 1/2BAL. 0.250000n. | = =
|1 ;:a“s"'fg;a“ | ¥ 4 Endwilz.. 01250 1/BBAL. 0052500 | fcelpaier: 178 BALL ENDMILL
: eep low = z
%~ Linking Parameters Tool number: : 4 i Length offset: | B
- Arc Filter / Tolerance Diameter offset:
Planes (WCS)
Coolant I
Canned Text e
Misceflaneous Values /6.160836 | Rebact rate: | 6 15043:35_4
Agis Combination [ Force ool change [i¢] Rapid Retract
e il C . e e
sy eIl _ M et M Commant
2 alteics Right-chck for options [ inich the arsas whers the previous toal did not fit
Tool 1/8BALLEN. g

e Sedoot fbrasy loo.. [ Fiter Active
Feed Rate 6.1609
Spindle Speed 4278
Coolant ot
Toollength 225
Length Offset 4
Diameter Off,. 4 MirdlEs i

CPlane / TP... TOP L el

v = edited
@ =diabled

> Select the Rest Material page.
> Enable Use rest material.
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> Enable Compute the remaining stock from the Roughing Tool Diameter and change the

parameters as shown.

AL N4
7 N

Compute remaining stock from Roughing Tool enable Mastercam to calculate the stock
based on the areas that could not be cut by a previous tool defined by its diameter and

corner radius.

-

Surface High Spe

‘oolpaths - Scallop

Toolpath Type I
v Tool |
Holdet |

(] Cut Parameters
- Flest Materal
Transitions
Steep / Shallow
& Linking Parameters

Ausc Fiker / Tolerance
Planes (WLS]
Coolant

Canned Text
Miscellaneous Values
Asay Combination

Quick, View Settings

[ Tool 1/8BALLEN..
| Tool Diameter 0,125
| Corner Radius 0.0625
| FeedRate 51609
| Spindle Speed 4278
| Coolant off
| Toollength 225
Length Offset 4
| Diameter Off., 4
CPlane /TP, TOP

v =edited
@ = diabled

Use rest matesial
Compute remaining stock, from
) All previous operations
) One other operation
133 Roughing T ool

Diameter:

Cormer radius:
3 CAD file

Stock resolution:

i_EJ__Ma_air;e Group-1

£ gg Toolpath Group-1

@ gl Properties - Generic Mil

%573 1 - Surface High Speed [Core roughing] - [WCS: TOP] - [Tplane: T1
{3 2- Surtace High Speed (Hoizontal] - WCS: TOP] - [Tplane: TOP] |
@ £ 3- Surlace High Speed [Seallap] - [WCS: TOP] - [Tplane: TOF] - F}

Adiustments 1o remairing stock:

{#3 Use remaining stock as computed
) Adjust remaining stock to ighore smalf cusps

3 Adjust rmaining stock to mill small cusps

Adjustment
distance

(v][%][Q][ 2]

> Select the OK button to exit.
» Select the Regenerate all dirty operation button to regenerate

the toolpath.

o D L,

ﬁ E @ Jm&zaﬂd&t;m_u‘am"[
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Toolpaths | Solids | At |
> Select Toggle toolpath display on selected operations to g a
remove the toolpath display if needed. vé L B9 m( LAk Al
AR wvah & XG

@EE Toggle toolpath display on selected tions

STEP 16:
HIGH SPEED - FINISH PENCIL.

LS - il o

High speed pencil toolpaths can be used as a finish operation to clean leftover
materials from corners. The tool follows a contour defined by the intersection of two or
more surfaces. You can create pencil toolpaths with either single or muitiple passes.

» Select Toolpath Manager.
» Right-mouse click (hold it down) on the folder icon in front of the
Surface High Speed (Scallop rest passes)

. Move after
| Copybefore  [BASK-T

» Drag the mouse down and release it. i

Pt Copy el b B 3 - Surface High Speed (Scallop)
Parameters
‘@ #3-05000ENDMILL2 SPH
» You should now have three Surface High Speed (Scall 2l Geanety-
ou should now have three Surface High Spee (Scallop) " 3 Toopath - 658 0K - TUTORY
operatlons. b 4 - Surface High Speed (Scallop

Parameters
#4 - 0.1250 ENDMILL2 SPHY

) Geometry -
b Toolpath - 584.5K - TUTORI
~F & " Surtace High Speed [Scallop
Select Parameters B

> Select Toolpath Type ﬁ = ENDMILL2 SPH
o.q n . - eometry -
» Enable Finishing and choose Pencil A !
» Click on Select button in the Containment field to remove the two
boundaries used in scallop.

» Left-click on the fifth operation Parameters.

@ Fluugh.ing
7% Finishing
/| )

_—| e Dl e—— i -o«vo«\M\M:-;

fi==3_1

Wateiline Scallop Horizontal Area Raster ? ) .

=

Sa-
(G
H i
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> Right-mouse click on the Chain 1 and select Delete.
> Right-mouse click on the Chain 2 and select Delete.

> Select the OK button to exit Chain Manager. |

& Note that 0 chains are selected in the Containment area.

> Select Tool page.

> Click on the Select library tool button,

> Use the Filter option to select the 1/16 Ball Endmill.
» Change the parameters as shown in the following screenshots.

Surface High Speed Toolpaths - Pencil

| — « Toolpath Type
i« Too) .. L .
1= Holder [ Number | Teol Type | Diameter Tool Name | Corner radus| Tool diamater;
& 1 Erdmi3.. 07500 3/4BUL. 0.125000in | ==
& CutPaameters i!f 2 Endeifi.. 03750.. 3/8FLA. 0000000in |  Comerredus;0.03125
 RestMaterial @ 3 Endmi2. 05000 1/2BAL. 0.250000in - .
- | mill2 .. i Rl ) E
;:“""’fg; L ® 4 Endmii2. 01250 1/8BAL. 0.062500in Tooi name: ; 1/16 BALL ENDMILL
eep / Shallow " .
Linking Parameters ‘ ¥ 5 Endni w. 00625, (1/1BBA. | Q0312500 Tool number: Length offset:
..... Arc Fiter / Tolerance Head number: Diameter offset:
Planes (WCS) | —
Coolant | Feed rate: | 150.0

Spindle speed: - 20000

Canned Text = ——— S
Miscellaneous Values Plunge rate: : 750 ; Retract rate: 200 0
Axis Combination | "] Force tool chang Hapid Betract
| — . —— . il o -
Quick View Sellings - camm—— i e = Commont .

Right-click for options
Tool TAGBALLE... : o 2

Tool Diameter 00625 :
‘ Cgronerlana‘:ii 003125 i Seloct library tool. ] Fitter Active

Feed Rate 61603

‘Cf:mm sharp comers. |

Spindle Speed 8556 ] Tedlinspection / change
Coolant off |

ToolLength 225 L e :
Length Dfset 5 Foe it vy

| Diameter Off... 5
\CPIanefTP... TOP

= edited

2 =disabled

(vI[%][Q][ 2]
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> Select the Cut parameters page and make the changes as shown.

Surface High Speed Toolpaths - Pencil

o~ Toolpath Type

r o Tool Cutting methad
Holder
Stepover
& Cul Paramaters
Rest Material Scallop height
Transitions
Steep / Shallow

i e (R G [¥] Limit # of offsets to
Arc Filter / Tolerance
Planes (WCS)
Coolart

Canned Text
Miscellaneous Values
Axis Combination |

Overthickness

Bitangericy angle

Dowe 7 up ol

Q uick View Settings

Tool /16 BALLE.
Tool Diameter 0.0625
Comer Radius  0.03125

Tao} containment

FeedRate 51609 poeesel ©
Spindle Speed 8556 & aloside {3 Center
Coolant oft

Toollength 225 Offset distance

Length Offset 5
Diameter Off... 5
CPlane /TP... TOP

[V} &idd offset distance ta tool radius

Total offset distance =

v = edited
@ =disabled

013125

- Keep tool down
. (O Distance

: £ % of tool diametes

Tip comp

Stack ta leave

aon walls

on floors

|
Stock toleave %D_ j

within

Lv ]

T
surface.
field the other field value is updated.

be twice the number of offsets, plus one.

;'sharpness of the angle between them.

Stepover is the spacing between cutting passes and is measured as a 3D value along the
Scallop height value is linked to the stepover value. When you enter a value in one of the
Limit # of offset to sets the number of 'machlnmg passes. The total number of passes will

~ Bitangency angle lets you control which intersections are to be machined based on the

> Select the Rest material page and disable Use
rest material.
> Select the OK button to exit parameter pages.

]

> Select the Regenerate all dirty operation button to regenerate

the toolpath.

Surface High Speed Toolpaths - Pencil

Toclpath Type

< Taool

Holder

Cut Parameters

Ceonpute rel

il pee

Tiairivg shock fiom

winls Opesalion:.

Toolpaths i Sollds Pat

v

NTITE

=

Regenefate all dlrty gperauwﬂ
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STEP 17:

Toolpaths tab
BACKPLOT THE TOOLPATH.

\

> Enable Toolpaths Manager and click on the Select all
visible operations icon to select all operations.

Séed aII vlsnble uperanorrs A.J

> Select the Backplot selected operations button.

Tnolpalhs I Sohds

e /%) F@low| 2 |
@]ﬁ:l@l vlﬂﬁadq:iotsdec‘hedopemhuns

> Make sure that you have the following buttons turned on (they

will appear pushed down).

B:c}cplut

> Display tool Display tool
> Display rapid moves

Display rapid moves

> Select the Play button.

0 0 D 7 e

» Select the OK button to exit

Backplot -
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STEP 18:
VERIFY-TOOLPATH VERIFICATION.

> Select the Verify selected operations button.

Toolpaths 5 Sords

I gﬂ v|4]l:lg?q-am stors]

s
L%

part with a rapid move.

Update after each toolpath updates the stock after each operation.
Stop on collision pauses the verification when the tool touches the

Moves/step:

Moves/|efissh;

» Select the Configure button.

Verify Options

Biock

[=]Stop on coliseri
"1 5top on losl change
[ top after each oparaticn

CVerbose
© @
m L

3-

surface finish, or scallops
Change toolfcolor to change
the color of ttxe cut stock to

tool path

> Select the OK button)to exit
Verify Options. ¥ |

 Bhape . Boundaties Winpoint  Macpoint  Margine
(??:;..-u.-.. [_M X [50165% | [s4sei7s a0 ]
./Q( QFk m y[30  |[asisss [nu
Use True Solid allows you, Osl &1 [ pocuoskooms. ] 2[1@22][00 [0 |
after verifying the part, to Iritaf stock sze source Cylinder ais
rotate arig m%gmfy? it to 'm_pre s 2% (ST
closely check features, o -5 e o

- [ Use TrusSoid

[] Cutet eomp in contiol
| ClDisplay Rv2 avee
 [JCompare to STL fie
: Dﬁ.mchme

'_ 'Dmmumm _

. Toolpeofie
Pims .
R A e

Tool lolerance:
STL tolerance:
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> Set the Verify spe

‘ J

> Select the Machine button to start simulation. @

» The finished part should
appear as shown in the
picture to the right.

» Select the OK button to
exit Verify.

STEP 19:

POST PROCESS THE FILE.

» Make sure that all operations are selected, otherwise:

> Click on the Select all visible operations button.

> Select the Post selected operations button from Toolpaths Manager.

> In the Post processing window, make all the necessary
changes as shown to the right.

ed to maximum by moving the slider bar in the speed control bar as shown.

» Select the OK button to continue.

> Select the Save button to accept the NC name.

[ HCHe

Al

[Tl Gutput ML fite descriptor '.':;_\-.‘:'t.ll.’!. . |
] NERe e

O Overwite

o

: Ej Sendto machine

2 | Dvsyie
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astercam X Editor MILLNCSTUTORIAL 15_WIREF RAME.NC]

Fle Edt Yiew MCFunclicns Bockmarks Project Compare Communkations Jods Window Help
Nev. R H S BAPLQBOABRTSRE O X e MY HF e 4% %%

B Mark &) Tool Cherges €9 Next Tool ) Goto Previous Todk I
i A
| 00015 =

mi (PROGRAM NAME - TUTORIALLS WIREFRAME }
%: (DATE=DD-:RI-¥Y - C4-1D-06 TIME=HH:MS - 15 )
| N100 G20
N102 GO Gi7 G40 G49 388 GO
( 5/4 BULL ENDMILL G.125 RAD  7T0GL - 1 DIA. OFF. - 1 IEN. =1 OpIA. = .75 )
N104 T1 M€
N106 5O G0 G54 X&.0083 Y-2.86215 AC. 818066 M3
N108 G43 H1 z2.
N1Ll0 Z.G087
N1i2 Gl %-.0693 #1900,
N1i4 Xe.0047 Y-2.6214 2-,0925
N116 X5.554 ¥Y-2.621 2-.1134
N113 ®5.9775 Y-2.6203 z-.13
N120 XS.9566 Y~2.6195 Z-.1407
N122 X5.9334 Y-2.6186 7-.1443
N124 X5.6318 Y-2.€078
N126 53 X5.6084 Y-2.6186 K.04563
N128 X5.517 ¥-2.6981 R4.5157 £200.
N130 &1 X5.5209 y-2.7022
N132 %5.5084
N134 X5.5334
N13€& X5.95&6 Z-.1407
N138 ®5.9775 #~-.13
N140 X5.3941 2-.1134
N142 X6.0047 2-.0925
N144 X6.0084 %-.0693
N146 Z.2146 F54G.
N148 X6.0083 ¥-2.3524
N150 2,8057
N152 %- ]
S = e o
[Ready,.. i Line: 1Coli 0 | FieSize; 1033k | 10/04/2006 | 3:02PM
i —

> Select the red X box at the upper right corner to exit the Editor.

STEP 20:
SAVE THE UPDATED MCX FILE.

> Select the Save icon.
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REVIEW EXERCISE

Student practise. Create the Toolpath for Exercise-Tutorial 15 as
per the instructions below;

Download the file from www.emastercam.com/files

& Note that the URL address is written with lowercase letters only.

&= Tips:
1. Create/ Surface/ Remove Boundary from Trimmed Surfaces

Select the Top surface (green surface)

Slide the arrow to one boundary and accept Remove all internal boundaries.
2. Create/ Bounding Box

Select all entities

Enable only Lines Arcs

Expand on X=0.5; Y=0.5; Z= 0.1
3. Change the z value to -1.59
4.Create/ Rectangle with surface option on
5. Establish the Stock size using bounding box

6. High speed Core Roughing
Select All
Use 7/16“ Bull End Mill with radius 0.0625
Stepdown =0.05
XY stepover 45 % of diam
Stock to leave on walls and on floors = 0.03
Transitions —Entry helix Radius 0.2
Linking parameters set to Minimum Vertical Retract;
Part clearance =0.25
Keep default Leads values
Minimize Trimming; distance =0.0825
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7. High Speed - Finish Horizontal Area
Copy previous operation and change the following
parameters;
Use 3/8“ Flat End Mill
# of depth cuts =1
Enable Smoothing
Stock to leave on walls = 0.03
Stock to leave on floors = 0
XY stepover = 45% of dia.

8. High Speed - Finish Waterline
Copy previous operation and change the following
parameters;
Use 3/8" Ball End Mill
Stock to leave on walls =0
Stepdown = 0.0375
Enable Add cuts
Change Max profile stepover to 0.03

9. High Speed Finish Pencil
Copy previous operation and change the
following parameters;
Use 1/8“ Ball End Mill
Stepover =0.05
Limit # of offsets to 1

10. Backplot and Verify the toolpaths.
11. Post process the file.
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