TUTORIAL SERIES FOR
Mastercam. ,{

TUTORIAL #1
LEVEL 1 - 2D GEOMETRY, DRILL & CONTOUR.




Mastercam.

Mill X2 TUTORIAL 1

Objectives:
The Student will design a 3-dimensional wireframe drawing by:

> Creating a rectangle knowing the width and the height of the rectangle.
> Creating parallel lines, by defining the offset direction and distance.

> Trimming 1 entity to another existing entity.

» Creating fillet radii.

> Creating 45 degree chamfers.

> Creating arcs knowing the diameter and the center point.

» Mirroring existing geometry to complete a part.

The Student will create a 2-dimensional milling toolpath consisting of:

> 4 holes drilled through the part.

> A 2-dimensional contour.

> Lead in and lead out toolpath entry.

> Modifing the existing contour toolpath by adding 2 depth cuts, 2 roughing passes and 1 finish
pass.

The Student will check the toolpath using Mastercam’s Verify module by:

» Defining a 3-dimensional rectangular block the size of the workpiece.
> Running the Verify function to machine the part on the screen.
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GEOMETRY CREATION
Setting the toolbar states

¢~ Before starting the geometry creation we should customize the toolbars to see the toolbars
required to create the geometry and machine a 2D part. See Getting started page A-5 in
the User Notes.

¢ Toolpaths/Solids Manager to the left of the screen can

be hidden to gain more space in the graphic area for
design. Press Alt + O to remove it.
* Before starting the geometry make sure that the

Grid is enabled. It will show you at each moment where the part
origin is. See Getting started page A-5
for details.

6" Since this drawing is symmetrical in the X-axis, you will only
draw half of the total part, and use the mirror function to complete the part.

STEP 1:
CREATE HALF THE OUTSIDE BOUNDARY.

1.1 Create a rectangle knowing the width, the "
height and the base point.

Rectangular Shapes Options {

Select the double
Create arrow

> Create Rectangular Shapes

» Select the radio button in front of Base Point.

> Enter the Width and the Height as shown in the screenshot to
the right.

> Select the double arrow to expand the Rectangular Shapes
Options as shown.

> Select the upper left corner radio button as the anchor.

Select
this radio
button

. [I5ufees [CentePor @

rajiinal
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> [Select position for base point]: Select the center location of the grid (the origin).

> Select the OK button to exit the
Rectangular §hapes Options

dialog box. |

> Use the Fit icon to fit the drawing to the screen. ig@
6% During the geometry creation of this tutorial, if you make a mistake you can undo the last

step using the Undo icon. You can undo as many steps as neeg:[gd. 2
&* If you delete or undo a step by mistake, just use the Redo icon. c*

STEP 2:
CREATE THE INSIDE GEOMETRY.
2.1 Create parallel lines. '

Create T \ Entity A

» Line

» Create Line Parallel Entity B =]
> [Select a line]: Select Entity A.

» [Select the point to place a parallel line through]: Pick a point lower than the selected line.

6~ Note that the color of the geometry is cyan which means that the entity is “alive” and you
can still change the line parameters.

»> Enter the Distance U?l 0.8 (Enter). e

¢ To continue using the same command select the Apply button. + To exit the command

you can either start a new command or select the OK button. .

> Select the Apply button to continue.
> [Select a line]: Select Entity B.
> [Select the point to ﬁ{ice a parallel line through]: Pick a point to the left of the selected line.

> Type the Distance l*1 0.04 (Enter).
> Select the OK button. @

The drawing should look as shown to the o
right.
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2.2 Trimming one entity.

|| PointB Point C \
Edit | | N\
» Trim/Break
» Trim/Break/Extend . /

> Select Trim 1 Entity. ~lItn 1=t — | Point A Entity D |~
> [Select the entity to trim/extend]:
> Select the entity at Point A (select all

points exactly as shown in the drawing).
> [Select the entity to trim/extend to]: Select Point B.
> [Select the entity to trim/extend]: Select Point C.
> [Select the entity to trim/extend to]: Select Point D.

> Select the OK button. &

2.3 Create fillet. — PointA |~

Create
> Fillet
> Fillet Entities

> Enter the fillet Radius &3 0.25, ,

> [Select an entity]: Select Point A. Point B ’

& Note that a fillet option will be automatically drawn depending on where you move the cursor
around the entities.
> [Select another entity]: Select Point B.

W" Delete this line | ~_
> Select the OK button. £ \
2.6 Deleting a line. o ’
> Select the horizontal line as shown to the

right.

o

> Select the Delete entity icon. ‘£.

STEP 3:
COMPLETE THE OUTSIDE PROFILE.
3.1 Create the 45 degree chamfer.

Create
» Chamfer
» Chamfer Entities

» Make sure that 1 Distance & |! Pstance

enabled.

-:-: is selected and the Trim ' option is
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> Enter the Distance 1 . 0.75 [
(Enter).

> [Select line or arc]: Select Entity A. | Select Entity A
> [Select line or arc]: Select Entity B. — J
> Select the OK button. i‘ \
Select Entity B
| \

3.2 Create a fillet.

Create iy J
> Fillet
» Fillet Entities

' Move the cursor in the corner
> Enter the fillet Radius & 0.56 (Enter). \/
> [Select an entity]: Move the cursor in

the corner area until the desired fillet
appears. Left-mouse click to accept it.

¢ Note that a fillet will be drawn automatically depending on where you move the cursor on the
entities.

> Select the OK button. &4

3.3 Create the arcs knowing the center point and the radius/diameter.

Create
> Arc
> Create Circle Center Point

> Enter the Diameter value & 0.5 N /
(Enter). —_—

> [Enter the center point]: Move the cursor at the center location of the 0.56 radius fillet. Select
the point when the little rectangle and the circle icon appear.
é* To create more arcs with the same diameter click on the diameter icon. The diameter and

radius values will be highlighted in red. ' . =

> [Enter the center point]: Select the Fast Point icon. &
» Enter the coordinates: 0.56+3.5, -1.5 (Enter).

» Select the OK button to exit
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& Note that Mastercam will perform basic math operations ( +, -, *, /).
You can enter the values without any of the corresponding coordinate letters (X, Y, Z) as
long as you enter them in this order and separate them by commas.

3.4 Transform the geometry to represent the whole part.

Xform
» Xform Mirror
> [Select entities to mirror]: Click on the All button.

@ || (e (o]

Mirror

> Select the OK button in the Select All dlalog box. L

> Click on the End Selection button. -

> Set the parameters to match the following dialog box (keep the
original entities Copy, to mirror about X-axis, Fit the geometry to the
screen).

» Select the OK button to exit the Mirror window. &

Preview

- Attributes

L__] tise New Attributes
Screen

» Clear Colors - -

» The part should look as shown in the following
picture.

STEP 4:
SAVE THE FILE.

File
> Save As
> File name: “Your Name_1"

» Select the OK button. L3




Mill X?

Mastercam.

TUTORIAL 1

TOOLPATH CREATION
STEP 5:
SET UP THE STOCK TO BE MACHINED.

> To display the Toolpaths Manager press Alt + O.
> Extend the Toolpaths Manager if necessary.

Extend here

» Machine type
> Mill
» Default

Machine Group 1

=on
[ﬂ 1t Propetties - Genetic Mill

Toolpaths  Scrmen  Settings Help .

Default |

C:\MCAMX\CNC_MACHINES\3 - AXIS HMC.MMD
€ MCAMX\CNC_MACHINES\3 - AXIS VMC.MMD

>
&
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> Select the plus in front of Properties to expand the Toolpaths

Group Properties.

Toclpaths | Salids | ..
e B EDop
Ax@EvabG 2

»

Select the plus

T MEERE

> Select Stock setup.

Select Stock
setup

El-ggd Machine Group 1
w41 Properties - Generic Mill
e--:;m

Toolpaihe | Saics |
A T XA

ooooo

i) Machine Group 1
-1t Properties - Generic M3

i
£
£

W]

we o
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» Change the parameters to match the
screenshot to the right.

The Stock Origin values

“adjust the positioning of the
stock, ensuring that you have
equal amount of extra stock
around the finish part.
Display options allows you to
set the stock as Wireframe
and to fit the stock to the
screen.(Fit Screen)

> Select the Tool Settings tab to set the
tool parameters and the part material.

» Change the parameters to match the
screenshot to the right.

Mastercam

TUTORIAL 1

Machine Group Properties

Stock View

Shape

{® Rectangular O Salid

Oomdcs O [ i v KN

...... [Setect comers...] { Bounding bax | |
[ wsutaces |1 msoids | [ mEotes | [ unseleci |

,;( Eac o '3‘

Assign tool numbers sequentially
allows you to overwrite the tool number
from the library with the next available
tool number. (First operation —*tool

number 1; Second operation ~*tool

| number 2, etc.)

Warn of duplicate tool numbers allows
you to get a warning if you enter two
tools with the same number.

~ Override defaults with modal values
enables the system to keep the values
that you enter.

Feed Calculatlon set From tool uses
feed rate, plunge rate, retract rate and
spindle speed from the tool definition.

Toolpath Corfiguration
[V} Assign ool numbers sequentially
Wam of duplicate taol numbers
[[] Use taol’s step, psck, coolant

DSearchtooi%mrywhen
ertering & ool number

[F]Ovenide defauts winmodal vakes |
[¥] Cenrance haight .
%] Retract hegtt
[ Foed plarie

Sequence §
Dt 10 |

i _.I

| [ALUMINGM och - 2024

[[_ e Select |
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Select the OK button to exit Toolpath Group Properties. L;‘Z/J

> E e @Select the Isometric View from the view toolbar to see the stock.

> Select the Top View from the view toolbar to see the part from the top. j €6

STEP 6:
CENTER DRILL 4 X '2” DIAMETER HOLES.

Toolpaths
> Drill Toolpath CMCAORHILLNGY
> Select the OK button to accept the NC file name the same | YOUR NAME _1 |

(vI[%][2]

as the geometry name.

> Select the 4 circle centers by moving the cursor at the
center of the arcs as is shown in the following picture.

> Select the OK button, once you select all four centers. L%

> Select the Select library tool button.

(Homepos ] O [fitmyzes |

Page 1-10
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> Click on the Tool Type to organize the tool list by the

type A Tool Selection - C:AMCAMX2VAILLATOOLS\MILL _INCH.TODLS

[MILL_INCH.T0OLS v & l

T . Tool Name: Comerradus | Radus Type
Center Drit 0. .. 1/8CEN.. 0000000n. None
Center Drit 0.2500... 1/4CEN 0.000000in.  None
Center Drit 0.5000, 1/2 CEN 0.000000in.  None
Drill 00156.. 1/64DR.. 0000000in. Nore
Orill 00160.. NO.78,.. 000000Cin. None

o080, NO77..  0000000in  None

MILLINCH YUULS -

» Select the 12” Center Drill from the list. | e et D Tt Gt e

|0 7 Cowwiei 070 VHCEN DO0DDW  Morw

|

1‘ .l Y Qs None
000000, Noos
0000000 Nore
00000Mn  None
000000 Nore
0000000k Norw
0000000 . Nons
€000000m.  None

> Select the OK button.

0000000 None
00U Nere
MNore
Nore
None
None

* The Feed rate,
Plunge rate,
Retract rate and il -
Spindle speed Tool name: | 1/2CENTERDRILL
are based on the 1 ComerDdl 05000.. 1/2CEN.. 0000000} Tool #: {1  lenofset|l
tool definition. o=
Change them as S
desired.

'"_—I

Plunge rate: ;

[ Farce tool change

Comment
Center drill all holes]

e T
@&&@&&M@@& S | w&z

Right-elici for options

I:I} Ton! fiter ]

» In the Comment field type a comment about the toolpath for future reference
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> Select the Simple drill tab and make the changes to match the following screenshot.

-
Drill/Counterbore - Center drill all holes

[ Clearance... ”2 0 [ Cycle
® fbsolute Olnmmtaa | Dril/Courterbore

start and end of operatmn

[ Retract ... !0-1 ‘ Subseguent pack
@ Absohute O g Pk cleasnce
(Topofsodc J 00 | e

Aatract amourd

@ fbachte ) incremental

[ Deph. J[015 I.E] Dwel
® Absolute ) Incremental Sigh

] Subprogram

Alolise | ncramental

STEP 7:

DRILL 4 X '2” DIAMETER HOLES.

Toolpaths

> Drill Toolpath

» Select the Last button in the Drill Point Selection dialog box to
select the same center points as you did before.

> Select the OK button to exit Drill Point Selection. L.
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DOLSWWILL  TRCH. TOGLS:

> Click on the Select library

tool button. C
a . ; =
> Select the Filter button in F s v T v o |
R R 2 CetmOl 02500 1M4CEN. 0000000n  Nore
the TOOI seIeCtlon dlalog W 3 ComDil 05000 1/2CEN. 0DOOOB00RM  None
b W7 e 0015 1/64DA. 0000000  None
OX. ¥ &5 oa 00160 NO 78 0000000A  Nane
¥ 3 pa 00180, NO.77_ 00000000 Nare
¥ o oa 00200 NO 76 0000000in  None 2N of 3ok
¥ ooa 00210 NO.75. 0Q000000m  Nore
¥ 12 oa 00225 NO 74 0000000in None
¥ 13 oa 00240, NO.73_ 0000000 Nore
® 4 oa 00250 NO 72 0000000n  Nore
W5 o 000 NO.71. 0000000l None
|® 16 o 00280 ND 70. 0000000n Nore
| 7 o 00292 NO.BY.. 0000000n  None
: 18 O 00310 NO B8, 0D0DO00N  None
1B ol 00313 1/32DR. 0000000 Nane
HE RS . sl ][%][ %)

“Tool Types Tool Diameter
 CEqual | (05 }
R adius Typs o e
None Corner Full
5 T OE‘I rV1atEfria| R e R T
HSS Ceramic
Carbide User Det 1 :
Operation masking Unit masking Ti Coated User Def 2
| No‘ciphration mshing ~ | [ Nounitmasking &) [ ar [ wone | [ Copyiobsetupmati |
LY [ %] 2]
— - —

» Select
the None button to disable any previous tool selection as shown.
> Select the Drill in the Tool Types list.
> Select the drop-down arrow in the Tool Diameter field and select Equal.
» Enter 0.5 in the Tool Diameter value box.

» Select the OK button
to exit Tool List

Filter. L
» Make sure that the
tool in the Tool
Selection window is
highlighted.
Otherwise select it.

LLAMILLATOOESWILL _INCH, TOOLS

3

ToolName  Comoriadin . B

ades Typn

| 21 Filmr ctive
1d323lod_l:

(v ][%][7]

> Select the OK button to exit Tool Selection.
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» Make any necessary changes in the Toolpath Parameters page.

Drill/Counterbore 1£|

R —— .11} e g
Toolpath parameters | Simple dil - no peck || Simple drl custom parameters | L,

W 1 CerterDdil 05000.. 1/2CEN.. 0.000000%
- . . Tool #:
¥ 2 oa 05000 . 1/2DRILL 0,000000% i |

_ Number| Tool Type  Diameter ToolName | Comerrad  Tool name: | 1/2 DRILL

Comer radius: (0.0

| Feedrate (42784 | Spindie speed: [534 ]
Plunge rate: ilzm Retract te:

[C] Force tool change {1 Rt retracs

| Comment

T == [Dell all 4 holes] Al
Right-cick fecoptione il - — -~ .~ &

Select library tool... Dl Tool fiter |

.*‘;m i':‘z;m.g;:! sL@Mé%J} ......... | |M.=cvdum| O zT-.:vy!_;-\_r:‘_ls N Fii I—ﬁ po

Dltobach ofe

[ Panes.. | [ Canned Tot.. ]

> Select the Simple drill-no peck page and enter the Depth value as shown in the following
screenshot.

—

Drill/Counterbore - Drill all 4 holes

@ [ Cesmnce. ][20 | o

& pbsolte O Incrementa) I Dril/Counterbore [
Use clearance orlly at the —
start and end of operation 15t peck 0

[ Retract... ] ’{N l Subsequent pech

& fbsoite O incremental m

Pack cleatance

( Iopofsock. | |00 ] i s
(@ Absolte O Incremental ratiact ametnt l:

Comn. J[os  |@m| o 0w |
@?Absoiuf:e S incremental Shit . oo

[ Subprogram

Sbuplge
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> Enable the Tip comp... to cut deeper than the final depth with the tip of the drill.

'f,l/' Drill tip compensation

Breakthrough amount value
allows you to give an extra
amount for the tool to go deeper
than the final depth to prevent
any remaining material for the
cut-outs. L
Tip length value is automatically

Tool diameter 5

| Breskthiough U1J
| amount . —

calculated by the system based
on the diameter and tip angle of
the tool. The value is added to
the final depth.

> Select the OK button to exit. L. |
> Select the OK button to exit Drill Parameters page.

STEP 8:

CONTOUR THE OUTSIDE PROFILE.
Toolpaths

» Contour Toolpath

> Select the first entity in the contour, as shown.
& Be sure to chain the contour in a CW direction.

» Otherwise select the Reverse button. M. |

G T

Select the
contour
here

O

> Select the OK button to exit Chaining. ¥

Tip length 0150215

B i e @
v ][ %] 2]
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> Click on the Select library tool button.

> Select the 0.25 diameter Endmill from the Tool Selections list.

A Tool Selection - C:AMCAMXZWILLATOOLS WILL_INCH.TOOLS

» Select

the OK button to exit Tool Selection. L.¥_
> Make all the necessary changes as shown below

r

Contour (2D)

Toolpath parameters | Carﬁnupamnatm {

{MILL_INCH.TOOLS v
| Number: ToolTypa’ Dismeter! Toal Name " Comerradius: Radius Type
|87197 "Endmil . 05312.. 17/32F.. 0000000m  None
(W 229 Endmill . 00313.. 1/32FL, 0000000Nn  None
W 230 Endmil . 00625.. 1/16FL. 0000000l  None il
¥ 231 Endmi . 00938. 3/32FL. 0000000k None
¥ 232 Endmifl.. 01250.. 1/8FLA. 0000000k  None 5] it Act
| 233 Endmill.. 01563.. 5/32FL.. 0000000,  None A
il Endmill .. 01675.. 3/16FL.. 0000000in  None 60 of 323 tooks
% E sl 0.2 FAFLA £ (00000 Nome
L) Endmil . Ny ; P
W 237 Endmin . .. %BFLA. 0000000  None
¥ 238 Endmin . . 7NBFL. 0000000n Nore
¥ 233 Endni . 12FLA. 0000000 None
¥ 240 Endmid . 5/8FLA.  000000in  None
{9 201 Endmit . 34FLA. 0000000  None
'@ 242 Endmil . 7/8FLA.  0000000in  None
® 243 Endmil . . 1INCH.. 0000000in None
¥ 244 Endnin . 11/2FL. 0000000l  Nare ~ [ & } KN EKS
. W e ok TS T e L. ___ 18
e o —

Number | Tool Type © Diameter | Too! Name | _
. CerterCrll 05000 1/2CEN.. 0000000
D 05000 . 1/2DRILL D.000000#
Endmiil .. 02500 . 124 FLA.  {.000000)

=®E

_. i&_._|| '.&!

Right-click for options

I:]I Too fiter I

Toslmame) | 1/4 FLAT ENDMILL

Tool #: Len. offset: |3
Head # E:j Dia. nﬂset:

Tool dia:
Comerradkus: [00

ElFort:elooId'lange

Cnmmant

Contour the profile.

(Tool dspley..] [ [ Fef port . |

[ Planes.. | | Canned Tex.. |

Pt A — ———

Lv Il 2)
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> Select the Contour parameter page and make the changes as shown below.

=

Contour (2D)

(Ceaonce.. ] 20
@ Abscite ) Incremental

[[] Use dlearance only at the
start and end of operation

(o i3

& rbsolute O Incremental
(Feedplane ] 01 ¢
O fbsoite (%) Incremental

1

(Top of stock...] [00
& Absohte ) Incremental

XY stock 00 =
[E @ ] o= &
@ Apsolte (3 incremertal to lsave 100 _|
| ki passes._
ol B
| O A6l

(vI[%][(2]

» Enable the box in front

of the Lead in/out button and select a combination of one Line and an Arc at the beginning

and/or end of the contour
toolpath for a smooth
entry/exit while cutting the
part.

> Select the OK button to exit
the Lead In/Out dialog box.

> eIect the OK button again to

Lead In/Out

[¥] Gouge check entip/exit mation
= Enliy

Lo e O

Famp height;

= :

Radus:  [1000  |x

SM .
| Heixheight :
. [JUse enty poit [ use et point i ol
: ) Lee pot déstiy JRAECE G U .
- [l Enter on first depth cut only {71 Exit on tast depth cut only
. [ Plunge aftes firsl move [] Retract before fast move

[ - Adusttatof contous :
CEuen : ?%ﬁ?flt:r—-

e

[ Oveiide fesd tate [54176 |

[ Adustend ol conlow _
) Lengih oo |slfoo I

. Exland ¥ Shovten
.

v ][ %[ ?]

exit Contour parameters. EL.
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STEP 9: fo ;m\r[ EPcit p?

BACKPLOT THE TOOLPATH. eI Tt .
& Ui Propertes - Ganenc Ml

> Click on the Toolpath Group in the Toolpaths Manager to select ¥ T

all operations.

& B 1 - Dill/Courdesbore - (WES: TOP] - ;

? Patamaters |
#1 - 05000 CENTER DRILL - 1
Geomelry - [4) Points

Select Toolpaths Group |4 & % Pl ol

?P’ ineters
#2-0.5000 DRILL - 1/2 DRILL
B Geometry - (4} Points
' B Todpath - 5.1K - YOUR NAME_
Jnl? 3- Contow (2D] - (WCS: TOP] - |ra.”

Parameters
Ki l].B]D ENDMILH FLAT

Toolpaths §Sohds |

BNl Pty P

> Select the Backplot selected operations button.

@ =z @ w qaadmlotse(ecbed Uperahons]

» Make sure that you have the following buttons turned on (they
will appear pushed down).

;«\t Backplot

Display tool

Display rapid moves

> Select the Isometric View from the view toolbar to see the stock. f 2@ @®

> Select the Fit button. ":'Z
> Select the Play button.

fefledmlpl (207

» Select the OK button to
exit Backplot. | ;
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il 'Tﬁzl;ﬂ;ll Pcil?
MODIFY THE EXISTING CONTOUR TOOLPATH T il

(ADDING 2 DEPTH CUTS, 2 ROUGH PASSES AND 1  |~ummmmy
FINISH PASS). | He

. Too settings

B X Stock setup
Select contour | Ty A
= imple dril - no peck - E
Parameters T ) Parameters
i ’ - #1-05000CENTER DRILL -
\ E Geometty - (4) Points
i Toolpath - 45K - TOOLPATH_C
2 - Simple dril - no peck - WCS: TO
Patameters
Geomstry - (4] Points
Toolpath - 4 5K - TODLPATH_C
our (2D]) - [WCS: TOP] - [Tpl

> In the Toolpaths Manager select the contour
Parameters.

> Select the Contour parameters page. S A e

» Check the boxes in front of Multi passes and Depth cuts. | N Toopath- 74K - TOOLPATH_C

Contour (2D) - Contour the |

[ [Mipasses... | [ [La-dmu ]
> Select the Multi passes i L] @ (Deghote. ] O fe
button to set the tool | e, =| Pavp.. | |Remsctining O geskitve, | O [ Te2a. |
movements in the XY plane.
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> Select the OK button to exit. M
> Select the Depth cuts button to set the Z-

Depth cuts

axis cuts.

Max rough step: ;0_25 Depth cut order
;‘Q’( _ ‘M—.ﬁ . ®Bycontour By depth

# Finish cuts: —
Max rough step value setsthe o '%%m_;
maximum amount of material removed in 5 e |
the Z-axis for each cut. The system will [Jkeep tool down [l apered vale URSut &
automatically divide the material in equal ] Subprogram o |
cuts until it reaches the final depth. - Mt ot

(v I][% ][ 2]

> Select the OK button to exit.

» Select the OK button to exit the Contour parameters dialog I
: , Tookathe | Solds §

boxes. LY. W e et e
& Note the red X in front of the Toolpath description in the Argvass xo
Contour operation. To update the toolpath with the new S ndho k.

& B8 Machine Group-1

11 Properties - Generic Mil
i {3 Files

@ Tool settings

parameters you have to Regenerate it.

| ! Stock setup

Select Regenerate all i | eég Salety zone
q R G Toolpath Group-1
dlrty Opel'atlonS %:qur‘-ami“ll:ounlerbme - WCS: TOP] - ||

> Select the Regenerate all dirty Parameters
operations button. @ #1-0.5000 CENTER DRILL - 1

P ' Geometry - (4] Points
. L.B¥ Toolpath - 5.1K - YOUR NAME_
: 2 - Diill/Counterbore - [WCS: TQP] -
) Parameters
§ #2-05000DRILL - 1/2 DRILL
Geomelry - (4] Points
: ath - 5.1K - YOUR NA|

Red X

ME_|

#3-0.2500 ENDMILLY FLAT - |
Geometry - (1) chainfs)
Toolpath - 6.7 - YOUR NAME_
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VERIFY- TOOLPATH VERIFICATION

STEP 11:

VERIFY.

Tosae [ [ At

_ﬁ«‘ % B. Glfe 9 ?
fromidemioa} O 2 | X @

> Expand the Toolpaths Manager if necessary by dragging
the right side.

> Select the Select all operations button.

> Select the Verify selected operations button.

1% _ : |
Update after each toolpath updates the stock after each [@ E:] ¢ {E

operation. ' ]@ lI] [_I—J

: Display control
Stop on collision pauses the verification when the tool | Movesser 1|

touches the part with a rapid move. - Movestetisse |1 l

Spesd __]_ Qualty

[¥] Update after sach toclpath

- Stop options

' [7] Stop on colksion

[ top on tool change
[1] [ Stop after each operation.
> Select the Configure button. [Verbose: '

i i i

"

1 st E
@7 [w) 35 (@
| : A
- o SO :

Toolpath:  Contour
Tool it
Tool latiet

v [ % ][ 2]
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) vl
Slels

Initial stock size source should

be set to Job Setup to use the
stock information from Stock
Setup. '

Use True Solid allows you, after
verifying the part, to rotate and
magnify the part to more closely
check features, surface ﬂnlsh or
scallops. /

Cutter comp in control allows =
Verify to use the information

regarding the tool diameter and to

simulate the cutter compensation.

Change tool/color to change the

color of the cut stock to indicated
tool changes in the toolpath.

> Select the OK button to exit
Verify Options. L

> Select the Play button to start simulation.

[/Block
| Shape
() Box
. O Cyinder

:OFIQ
© Sokd [

Iriitial stock size souce

| OSeantodipathis)
() Stock Setup
; O Use last size

3 | Lise Stock Setup values Y 2125

Boundaries
[ Sean toolpathis)

Max paint:  Margins:

g4 oo

Min paint:
] x 01

(CEoockcones. ] 2{05 Jja0

. . Cylindet avis

- Miscellaneowus optians
[¥] Use TrueSolid
* [«] Cutter comp in control
+ [[] Display XYZ axes

™1 Compare to STL file

["]Hide oola each slop
[ Meake tiue threads

™ Transhicent stock

Set colors...

Tool tolerance: {0.008

4

» The finished part should appear as shown in the following picture.

» Select the OK button to exit

Verify.

STEP 12:

SAVE THE UPDATED MCX FILE

> Select the Save icon.
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STEP 13: Toolpaths { Solids |
POST THE FILE. Wk DY SEPot

> Make sure that all operations are selected, otherwise: Godomimh G

> Select all operations Toolpaths | Soligs | At |
> Select the Post selected operations button from Y LR S@ ?{-‘ﬁ"’ % 9

Toolpath Manager. \
i val %]Postselected opera

Post processing

> In the Post processing window, make all the necessary
changes as shown to the right.

: i : {7 Cutput MCX file descriptor
7% e |

NCHe

NC file enabled allows you to keep the & Craic Ded

- NC file and to assign the same name T o e
as the MCX file. o T R =
 Edit enabled allows you to S

~ automatically launch the default editor. L

—— [[] NCI file
» Select the OK button to continue. Oveuwrits
> Select the Save button to accept in the File name field the
same name as the geometry name (“Your Name_1").

X pe gdt yew K Functans Sookmads Project Compere Gomawncztions Iook Window Hep
P bl G BEYHBOARAIT2RE PSS MY I PE S A% NN
W stack 4l Tool Changes. €3 RewtTooi &) Goto Prevous Tool

o000l
NAME 1)

0f TimEerm:me - 18:47

S e

17 G40 G545 GHU &S50

TN~ 1 BIA. oFP. ~ 1

N3

54 G0 050 O34 X.36 ¥1.5 AD. ¥534 M3
x5 543 H1 22.

N6 T.1

N7 G99 GBL 3-.18 |1 PL.0
NEB X4.08

% ¥-1.5

W10 x.56

W1l &40

w12 22

¥i3 NS

14 S51 =28 20.

¥15 S28 xD. ¥0. AO.

9GO0 590 654 X.56 Y1.5 A0, 3534 M3
43 K2 22,
N0 2.1
W2l 999 SE1L £-.7502 R.1 P4.28
K22 X4.06

=

e e 13 8 A il

> Select the red X box at the upper right corner to exit the Editor.
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Mastercam.
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REVIEW EXERCISE 1.

Student practise. Create the Toolpath for Exercise 1- Tutorial 1 as per the instructions below;

S
-
-

.
o

Tips:
Stock size; X=70,Y=50andZ=2.0

Contour-rough the part using 1.0 “ Flat End Mill;
Max rough step =0.50" (Depth cuts)
2 roughing passes with spacing = 0.40"
Stock to leave in XY and Z axis =0.05"

Contour -finish the part using the 0.50“ Flat End Mill
Stock to leave in XY and Z axis =0.0“
3 roughing passes with spacing = 0.20"
Depth Cuts disabled

Backplot and Verify the toolpaths.

Post process the file.
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REVIEW EXERCISE 2.

Student practise. Create the Toolpath for Exercise 2- Tutorial 1 as per the instructions below;

Tips:
Stock size; X=10.0,Y=6.0andZ=1.0

Contour-rough the part using 1.0 “ Flat End Mill;

4 roughing passes with spacing = 0.45"

Stock to leave in XY and Z axis =0.03"
Contour -finish the part using the 0.750" Flat End Mill

Stock to leave in XY and Z axis =0.0“

6 roughing passes with spacing = 0.35*
Backplot and Verify the toolpaths.

Post process the file.
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POCKETING, ASSOCIATIVITY, MODIFY THE POCKET
TOOLPATH, AND SAVE TAPPING OPERATIONS TO A
LIBRARY.
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Objectives:
The Student will design a 3-dimensional wireframe drawing by:

> Creating a rectangle using the 2 points entry method.

» Creating parallel lines by defining the offset direction and distance.
> Creating lines using co-ordinate entry functions.

> Creating arcs using center/radius functions.

> Creating arcs using polar positioning.

» Inserting fillets at the corners.

> Mirroring existing geometry to complete a part.

> Translating existing geometry to create a 3-dimensional block.

The Student will create a 2-dimensional milling toolpath consisting of:

» Machining 6 holes, spot drilled, drilled and tapped.

» Machining a 2-dimensional pocket.

» Machining a 2-dimensional contour.

» Using lead in and lead out toolpath entry.

> Modifying the pocket toolpath by creating a rough pocket, a remachining pocket and a finish
pocket.

» Saving to library 9/16-12 tap holes.

The Student will check the toolpath using Mastercam’s Verify module by:

> Defining a 3-dimensional rectangular block the size of the workpiece.
> Running the Verify function to machine the part on the screen.

Page 2-2
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GEOMETRY CREATION
Setting the toolbar states

To start a new file from Mastercam:

¥

File

> New

é* Before starting the geometry creation we should
customize the toolbars to see the toolbars required to
create the geometry and machine a 2D part. See Getting

started page A-5 in the User Notes. |

Toolpaths/Solids manager to the left of the screen can be hidden to gain more space in the
graphic area for design. Press Alt + O to remove it.

é* Before starting the geometry make sure that the Grid is enabled. It will show you at each
moment where the part origin is. See Getting started page A-5 for details.

é* Since this drawing is symmetrical in the X-axis and Y-axis, you will only draw 1/4 of the total
part, and use the mirror function to complete the part.

STEP 1:

CREATE "4 OF THE OUTSIDE GEOMETRY.

1.1 Create a rectangle knowing the width and the height of the
rectangle.

Create
» Create Rectangle
» Enter the Width 5.0 (Tab).

» Enter the Height 3.0 (Enter).
> [Select position of first corner]: Select the Origin (center of the grid) as shown.

> Select the OK button. 8]

FE [ Select position of first comer
> Use the Fit icon to fit the drawing to the screen.

Bt

Select the center of
the grid

é" During the geometry creation of this tutorial, if you make a mistake you can undo the last
step using the Undo icon. You can undo as many steps as needed. ¥
& If you delete or undo a step by mistake, just use the Redo icon. o
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STEP 2:
CREATE THE INSIDE GEOMETRY.
2.1 Create parallel lines.

Create
» Line \
> Create Line Parallel Select Entity A
> [Select a line]: Select Entity A.
> [Select the point to place a parallel line
through]: Pick a point below the selected line.
¢ Note that the color of the geometry is cyan.
This means that the entity is “alive” and you g S P /
|
|

can still change the line parameters. To exit | | Select Entity B
the command you can either start a new gk

command or select the OK button. £
> Type the Distance [F"I 0.5.

» To continue using the same command, select the Apply button.
> To create more parallel lines with the same distance click on the distance icon. The distance

value will be highlighted in red. .
> [Select a line]: Select Entity B
> [Select the point to place a parallel line through]: Pick a point
to the left of the selected line.

> Select the OK button. &£

» The drawing should look as shown in the picture to the right.

2.2 Create polar arcs knowing the center
location, initial and final angles.

Create
> Arc
» Create Arc Polar

> Enter the Radius &3 1.0 (Tab).

é" To set the other parameters of the arc use the Tab key. Note that the diameter value is
automatically changed by the system based on the radius.

> Enter the Start Angle 3 180 (Tab).

» Enter the End Angle <% 27Q (Enter).
> [Enter the center point]: Select the center point

Select the Intersection

>
at the intersection as shown in the picture to the /Tf_
right.
> Select the Apply button to continue using the
same command. point
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» Enter the Radius 1.0 (Tab). T b e s
» Enter the Start Angle @ 270 (Tab).
» Enter the End Angle &=* 0 (Enter).
» [Enter the center point]. Select the endpoint —
of the line as shown in the picture to the
right.
> Select the Apply button. S Select the Endpoint of
> Enter the Radius &2 31/64/2 (Tab). the line

> Enter the Start Angle @ 270 (Tab).

» Enter the End Angle &= 9Q (Enter). _
> [Enter the center point]. Select the same endpoint of the line as shown in the picture above.

> Select the OK button. &2

2.3 Create an arc knowing the center point and the radius/diameter.

Create
» Arc

> Create Circle Center Point
- < N
» Enter the Diameter value &2 31/64 (Enter). >
> [Enter the center point]: Select the point
when the rectangle with the circle appears. -/
> Select the OK button. ¥4

&

Select the center point

here

2.4 Create fillets.

Create
> Fillet
» Fillet Entities

> Enter the fillet Radius

-
K2 0.0625.

Al A dEn JdE A A A A

> [Select an entity]: Select Entity A.
> [Select another entity]: Select Entity B.
> [Select an entity]: Select Entity B. ™\ T
» [Select another entity]: Select Entity C. 7 \/
> [Select an entity]: Select Entity C. \
> [Select another entity]: Select Entity D. Entity B
» Select the OK button. 8. Entity & Entity C /

=1—:

Entity D I
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Mill X?
2.5 Deleting the construction lines.
» Select the lines as shown to the right. )
> Select tﬂljge Delete entity -/
icon. ,ﬁ Delete these two e—
lines

\x .
STEP 3: B
TRANSFORM THE GEOMETRY TO REPRESENT THE WHOLE PART.
Xform
> Mirror

> [Select entities to mirror]

(@) {j [ All.ly}?g [any. ]

» Click on the All button.
> Select the OK button. i

» Click on the End Selection button. End Selection

> Set the parameters in the dialog box as shown (enable Copy to keep
the original entities, enable mirror about X-axis and Preview and Fit
to see the result on the screen).

) @)

» Select the OK button. L.

» Click on the End Selection button. |
> Change the Axis to mirror about to Y-axis as shown to the right.

Move Copy Join
O & O

| Mt bt s Lkt
P
o] on
o
" [ Use New Attributes

gEAKIEa

Move Capy Join
o o el

m o A .l

|
[Tl Ues New Attibutes

Karaua
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> Select the OK button to exit. MJ

Screen o) 0 O

> Clear Colors

» The part should look as shown in the picture to the
right.

STEP 4:
JOIN THE TWO ARCS. O 0 O

Edit

> Join entities

> [Select entities to join]: Select Entity A.
> [Select entities to join]: Select Entity B.
> [Select entities to join]: Select Entity C.
> [Select entities to join]: Select Entity D.

ity A
Select Entity Select Entity B

ZE
<

© o

» Select End Selection button.

STEP 5:

SAVE THE FILE.

File

> Save as

> File name: “Your Name_2"

» Select the OK button. &
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TOOLPATH CREATION
STEP 6:

SET UP THE STOCK TO BE MACHINED.

> To display the Toolpaths Operation Manager press Alt + O.
& If a machine is already selected in the Toolpaths Manager, skip the next selection.

Machine type Toolpaths Sceen Art
> Mill i
> Default

Lathe »| 1 CYMCAMX2\CNC _MA

1 | [t iSdn | an e -M
Ll hLE MOk %
Blaauvacens E
B g O O Ol %
= |

o m :;
[t} -
| c
# | i
E st
&
|
®
P
®
s O O O
-,& |
T k

f e
r—ry - X Guaw | Pamer B EE »‘.- T 1 o Cetien |, | i A WO D

> Use the Fit icon to fit the drawing to the screen. @

> Select the plus in front of Properties to expand the Toolpaths Toolpaths | Solids A | 50

Group Properties. % “ H%EPan P

A=0 vaGs %0
Select the plus N ﬁ Machie Gicipt
=)

1L Propetties - Generic Mill

 —— i _ i |
> Select Stock setup. Tooaths [ sods [[an | .

AxE vaGa %G
Select Stock B=Evalh S Bl
SetUp - 1l1 Properties - Generic Mil

Stock setup
Salety zone
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» Change the parameters to match the
screenshot to the right.

Machin

Display options allow you to
set the stock as Wireframe
- and to fit the stock to the
~ screen (Fit Screen).

=<

i ~
‘The Stock Origin values e
adjust the positioning of the g;’:"’"‘
stock, ensuring that you have

“equal amount of extra stock o

around the finished part.

>

e Group Properties

coordinates

I_Sjmlmm] l Eundﬂnwa . NCleaterds |
[ Misufaces | [ miSoids | [ MEntes | [ Unscled |

» Select the Tool Settings tab to set the

tool parameters and the part material.
» Change the parameters to match the
screenshot on the right.

> See Tutorial #1 pages 1-9 for more info.

> Select the OK button to exit Toolpath

Group Properties. &

Program #
| Feed Caleufation Tocipath Coriguration
& From todl [ Aasign toci numbrs. sequertsaly
£ From materal ] Wam of dupficate tod! rumbers
' £ From defas 1 Use tod!'s step, peck. coolant
— Search ool ibrary when
¢ O ser defined L) entering a tect nuvber
Advanced options ~
7] Ovenide defauits wih modal values
Retract rate .
[#Cleararice height
Fheos o Reract teight
| [] Adiust feed on arc mave [¥] Feed glane
L Winimum arc feed 50 _J
Sequence #————————ii
increment ﬁ,‘g T
Mol e
[ALUMINUM inch - 2024 [ [ Select
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> Select the Isometric View from the view toolbar to see the stock. J e @
I | - -
> Select the Top View from the view toolbar to see the part from the top. jiﬂ @ =

STEP 7:
SPOT DRILL 6 X 5/16” DIAMETER HOLES.

Toolpaths
» Drill Toolpath
> Select the OK button to enter the same NC name as the

geometry file name. LY.

CAMCAMMZAMILLANCY

[vouRmeME2 |

TAEIES

Drill Point Selection

> Select the Mask on Arc button.

> [Select arc to match]: Select one of the 6 circles as shown in the 3 [ R
following picture.

Window Points |

~ Diameter.

 Toletance:

[Subprograms... ] [ Last ]

[ Sorting... ] 1 Edil,.: J

é* The Diameter value should be now 0.48438.
> Select the entire part using Window.

Select a
window
around the
part

» Hit Enter when finish.
> Select the OK button to exit Drill Point Selection.
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O/ rooin

0 o sy

> Click on the Select library tool

button Fécfm}_::x:.s.. [ Planes... ] [ C;med Text... ]
[ %]
» Select the Filter button in the Tool R |
Selection dialog box. <D

> Select the None button to disable any previous tool selection as shown.

» Select the Spot Drill in the Tool Types list.

> Select the drop-down arrow in the Tool Diameter field and select Equal.
> Enter 0.75 in the Tool Diameter value box.

» Select the OK button to exit Tool List Filter.

Tool List Filter

Tool Types
Padie Tupe e
[~} None [¥] Caner Full
Tecd Material e
lHss 4] Ceramic
{7} Carbide - lUserDef 1
Dperation masking Uit masking ¥ Ti Coated E]'User Def 2
Mg _\,.L-_-|:x| oy sk bling |,.N°"_'?tl"“kf";_ U,' [ Al J 1 o ] [ e i it J
TAEaEa

» Make sure that the tool is selected (highlighted) in
the Tool Selection window.

» Select the OK button to exit Tool Selection. i..3..
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6" The Feed rate, Plunge
rate, Retract rate and
Spindle speed are based
on the tool definition.
Change them as desired.

F

Drill/Counterbore

Toolpath parameters | Simple diil -no peck | Simple dril custom parameters |
| Number  ToolTips| Dametsr ToolNee| Comerrad Toolname: [VASFOTORLL |
¥ 1 SsctDd 07500 24SPO..  0.000000 m
5 -
Todlda: [075
Cormrn IO
Feed rate [32.597333 | Spindie speed: F]
Plnge rate: (32597333 | Retract rte: [32597333
D Force tool change Fiaped retract
| e T U ik o
R = -
Right-click for options Sout —‘
Select Mbrary toal, . | | Toal filter il
35 (Detacdt (1 0 Tool caplsy 0 | Fiad poire
[ | Retary wes | Planes... ! Canned Ted..,

> in the Comment field type a comment about the toolpath for future reference.
> Select the Simple drill-no peck tab and change the parameters to match the following

screenshot.

Cycle
| Dil/Counterbore e
tart and end of cperation 14 ock [o1
[ Retract... ] icm ! Sbventpaent punck | ] '
) Abscite ) Incremental ' Ps ,v—i
[ Top chtocks ] kﬂ.u { B o i(zl___%
() Apsolte ) incremental R i) :
(e )0 |G O LA

@ Absoite O Incremeantal Shlt
[ Subprogram

Abpohsta

S et

.................

6 We want to use the spot drilling to chamfer the holes.
> To calculate the Depth, select the calculator icon.f@l
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» Change the parameters as shown in the screenshot to the
right.

Depth Calculator

Use current tool values

ﬁ : ; Tool diameter ; -
Enter the Finish diameter value to set the 100l i included angle
outside diameter of the chamfer. The system Firish diameter
automatically calculates the machining depth Tool tip diameter (lat on tip} |

for the spot drill operation. I i —1

) Add to dept

> Select the OK button to exit. tLJ
> The drilling Cycle should be set to the default, [ v J[ R ” P ]
Drill/Counterbore (G81). ‘

> Select the O}ﬂbL}_Jtt_on to exit drilling

parameters.

> To change the order in which the holes are spot drilled, select
Geometry in the Toolpaths Manager.

i ﬁ“_Machine Group-1
- 11 Propeities - Generic Mill
. G Files

: @ Too settings
o Stock setup

i L\ Safety zone

Select Geometry

#1-0.7500 SPOT DRILL
Geometry - (6} Points

T _7”:’ .b; -
B oo sedpescn

BN Point 3 N ~
Point 4

¢ P:::tﬁ Reverse

mm Foint 6 Deiete points....

> Right-mouse click inside of the Drill Point Manager and select
Sort options...

Sotstals: O

| ReSot i  —
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> Select the Point to Point sort method. v
> Select the OK button to exit the Point Sorting dialog box. L_i.J

Select Point to Point S

Oraw path
7] Aiter ot dupiicates
|

> [Select sorting start point]: Select the center
point of the first hole to drill. :

Select this center
point

e e e e i i ot b e it o B e e e L s

> Select the OK button to exit the Drill Point Manager dialog box. LY.

é* Note the red X in front of the Toolpath description in the Drill operatlon To update the
toolpath with the new parameters you have to regenerate it.

> Select the Regenerate all dirty operations button.

Toolpaths | Soids | L
v ¥ | ISPl l v
Select the Regenerate button | 1@ = @ | 1mmmmnmymm

STEP 8 m?uu:gath GIOUDI;\MCAMX\CNE
DRILL THE 6 X 31/64” DIAMETER HOLES. g

[ e ¥ Tool settings
L@ Stock selup

=) Lathe talpaths n

L}
Wire tosipath »

» Toolpaths Manager ter tooaths » PP
L3

Router fonlpaths
it
> Right-Mouse Click and select Copy. ut
> Right-Mouse Click again and select Paste. oy oo
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> The Toolpaths Manager will look as shown in the screenshot to

the right.
> Select the Parameters in the second drill operations.

Select Parameters

» Select the Toolpath parameters tab.
> Click on Select library tool.
> Select the Filter button.

> Make the changes as shown below.

E

| Mo ot mahing | v

All

J [ Nove ]

Unit masking

{ No unit masking

| Equal

Radius Type

[“] Nore

Toal Matsrial
HSS
Carbide

TiCoated

N

Toolpaths | Solds | A ]

A T
A6 vahG$ %@
| & BH Machine Group-1 7

#-4lL Proparties - Genedic Mil
=82 Toolpath Group1

Patameters
¥ #1-0.7500SPOT DRILL -
| Geomety - (6] Points
i Toolpath - 5.5K - YOUR N4
il Deamilerbore - {WCS, T
Patameters
#1-0.7500 SPOT DRILL -
[l Geometry - [6) Paints
L. &8 Toolpath - 55K - YOUR Ny

= B 1 - Dill/Counterbore - [WES: TH

_ Tonl Diameter

Corner Fult

Cetamic
User Def 1
User Def 2

[ a

] { MNone J [ Copy job setup mat} ] i

i

raE3Ea

> Select the OK button.

> Highlight the 31/64" Dirill.

Ly (%2

> Select the OK button. &




Mastercam,

Mill x? TUTORIAL 2

» Make any necessary changes in the Toolpath parameters page.

Drill/Counterbore - Spot drilting all 6 holes. JZ!

Toabath parameters | Simple doll-no peck | Smple ol custom parameters| -

Number | Tool Type | Diameter | Tool Name ?w%er; Tool name: i31/5“DR|LL
® 1 SpctDil 07500, 3/4SPO.. 0.000000%
¥ 2 ow 04844 . 31/64D.. 0000000

é* The Feed rate and
Spindle speed are
based on the tool

definition. Change [Select ibrary tool.. i) ‘__

them as desired.

Commert
| Drlling a# € 31/64 diameter holes.

i

(& {Tool deplay. | 1= Rat —
e |y

1 7o batch

» In the Comment field type a comment about the toolpath for future reference.
» Select the Simple drill-no peck tab and change options as shown in the following
screenshot.

Pack Drill - Drillin 31/64 diameter holes.

@ fbschite ) Incremental
Use clearance only at the
start and end of operation Peck
L_ Retract... ] IO.'I i Subseruait patk

& sbsolte ) Incremental

[ Tepcfstock . | 15.{7 i

3 pbsolte (Y Incremental

Cow 0+ Jm o
& Absoite ) Incremental Skt

[ Subprogram

Shschde & frcpmmanist
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» Enable the Tip comp... button and select it.

Tip comp... enabled allows you to cut

_deeper than the final depth with the tip of
the drill. The system automatically
calculates the tip length based on the drill
diameter and angle.

» Change the parameters as shown.
» Select the OK button to exit the Drill tip

compensation page.

» Select the OK button to exit the Drill Parameters page.
> Select the Regenerate all dirty operations button.

Select the Regenerate button

TUTORIAL 2

Drill tip compensation

Tool diameter 1 454575

| Breakthrough ! éﬂ ____________ _]

_Tnolpalhs § Sg“ds.’_ o

EXA ST

5 2= (3] | Wregenerate all dity nperat':l':sl|

STEP 9:
TAPPING THE 6 X 9/16-12 UNC DIAMETER TAP
HOLES.

> In the Toolpaths Manager, select only the Peck Drill operation.

> Right-Mouse Click and select Copy.
» Right-Mouse Click again and select Paste.

> The Toolpaths Manager will look as shown in the screenshot to
the right.
> Select the Parameters in the second drill operations.

= E Toolpath Group 1

i=-4l1 Properties - C:A\MCAMXACNC
o 3 Files

. —@ Tool settings

«p Stock setup

Sl e S
| Router toolpsths
i | Editoperations

{ Groups

V% NEEPcR P
A= vahG s K&

#-1l1 Properties - Generic Mill
% 88 Toolpath Group-1
i= I 1 - Diill/Counterbore - (WCS: TE
Parametets
: ¥ #1-0.7500 SPOT DRILL -
- Geometry - (6) Points
B8 Toolpath - 5.5K - YOUR N4

Select Parameters

& B 2- Peck Diill - [WCS: TOP} - [T
~3 - Parameters
#2-0.4844 DRILL - 31/64

I Geometry - (6] Points
&= Toolpath - 5.5K - YOUR N

5] Parameters
§ #2-04844 DRILL - 31/6¢
Geometry - (E] Points
b Toolpath - 5.5K - YOUR N£
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> Select the Toolpath parameters.

> Click on Select library tool and using the Filter, select the 9/16-12 Right Hand Tap from the
library.

> Make any necessary changes in the Toolpath Parameters page.

Peck Drill - Drilling all & 31/64 diameter holes.

Mumbar | Tocﬁ'ype' ‘Diameter. Tool Name;_.éumsnadi Tool name:
(W 7 scoom 0700, 345P0. 03000
‘Q’ Ol 04844 .. 31/64D.. 0000000

2
¥ 3 TepRH 0565 91612, 00000006

Tool &:

Feedma@ Spinde speed:[475 |
Plunge rate: E‘ST@ Retract rate:
[[] Force tool change L Pt ety
: I A e e ot
¢ Note that the feed rate is | Rgre ik forcptars | 7979 M /16 dameter hles.
calculated based on the r
spindle speed and the e e i
number of threads/inch. ZEie G ey 1
[ To bateh O rota

| | ; V = .__?H
> In the Comment field type a comment about the toolpath for future reference.
> Select the second page and enter the Depth value as shown in the following screenshot.

{_Ceamnce.. | P-D ] Cycle
@ssoite Ohoemertal | Tap

[7] Use clearance only at the
start and end of aperation jMper

BT

& Absolute ) Incrementsd

(Dt J[10 |gal Ove

& #bsohte O Incremental Shily

[ Subprogram

St

8 ncremertal

> Disable Tip comp... S I s
» Change the drill Cycle to e E‘j

Tap.

» Select the OK button to exit the Drill Parameters page. L.
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> Select the Regenerate all dirty operations button.

Toopaths foois|
Y E@cT P

| wlRegenerate al dirty operations |
- mm 71

Select the Regenerate button

> If necessary. select the down arrow to move the arrow one T o]
step down to include the tapping operation. ATE T ‘
— | 7 —

Move insert arrow f=m-valb &

=% | Move insert arrow down one item

down one item

STEP 10:
CONTOUR THE OUTSIDE PROFILE.

Toolpaths

» Contour Toolpath.

> Select the first entity in the contour, as shown.
» Be sure to chain the contour in a CW direction.

ino M

Select the contour here

> Select the OK button to exit Chaining. L.X

> Select the Toolpath parameters tab.

> Click on the Select library tool button.

» Use the Filter button to select the % Flat Endmill from the library.
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'f.clrlr.aur (2D)
| Nomber | Too Type | OimeterTooiNeme _Camerrad
[ 1 SpotD@ 07500, 3/4SPO.. D.0BO0ODY
W 2 oa 04344 . 31/64D.  0000000:
|l»‘ 3 TapRH 05625 9/16-12.. 0.000000
¥ 4 Endmll . 07500.. 3AFLA.  00DDSOOY
Tool dia: [0.75
e
Comerradius: [D.0 | [ Cotart.. ]
Feedrate: (54175 | Spinde speed: 713 |
Plngerate: (64176 | Retractrate: (4176 |
[ Force tool change [ Rapid retract
| Comment
é* The Feed rate, Plunge " [Contourine outside profie A
ratg, Retract rate and e N [Geane | ;
Spindle speed are based A —
on the tool definition. hus Conbei © : B [ il o
Change them as desired. D Tobaich - [Lems. ] [comedTen. ]
(vI[%][2]

> In the Comment field type a comment about the toolpath for future reference.
» Make all the necessary changes as shown above and select the Contour parameter page.

[Ci_eamnce.,. ] §
{© Absolte ) Incremental
[ Use clearance anly at the
start and end of operation o Opiwsize
= [ Retract... ] 13-25 ! Tip comp
@ fbschite ) Incrementat Roll cutter ;
51 around comen |
| Eecd pare.. U : | Infinte look ahead
O dbsotute 3 Incremental s
tolerance
[Top ot stock...| 28 Mas. depth
%) Absoite () incremental &
XY stock
[ Depth... ] i.g.g f taleave
Z stock
® fosoite Olocrementsl 30 40
O [Mitipmses. | [ | Loadin
(e
@ 0=

> Enable Depth cuts and select the button to set the
cuts along the Z-axis.
» Change the Max rough step value as shown.

> Select the OK button to exit.
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> If you want to cut through without leaving any burr enable Break through and select the

button.
> Enter the Break through amount as shown.

Break through

S

Break through 01_ .
amount: e il

1 -

S

» Enable the box in front of Lead in/out and select a combination of a Line and an Arc at the
beginning and/or end of the contour toolpath for a smooth entry/exit while cutting the part.

» Change the parameters as shown.

Lead In/Out

] E nter/extt at midpoint in closed contours
Gouge check entry/exit motion
Entry
L|h5 e
) Perpendicular . %) Tangent
Length: 1 I

Ramp height:

A
Radus: 1000 %

Sweep:

Helix height lo0

"} Use entry point
Llie poms dasbs
I Erter on first depth cut only

[T] Plunge after first mave
[CJ0veride teed 1ate (£ 4776

ol Addjust start of contour

e
i o Gl

. Length Qr %4

Overlap: 00

ol Esit
Line

¥ Perpendicular . (7} Tangent

Length: 100 |x (07

Ramp height: D 0

R adius:

Sweep:

Helix height IJ 0

™ Use exit point
I Hbre pein debll
- TTE %t on last depth cut only
"] Retract before last mave

[T 0veride feed rate | 4176 ]

E] . Adust end of contaur

5 Length: -

i
oy

> Select the OK button to exit the Lead In/Out dialog box.

> Select the OK button again to exit Contour

parameters.
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STEP 11:
POCKET THE INSIDE CONTOUR.

Toolpaths
> Pocket Toolpath.
» Select one entity of the pocket chain, as shown.

?

Select the

O O pocket

chain here

L e T S —— e —

> Select the OK button to exit Chaining.
> Select the 0.375” Flat End Mill following the steps outlined before.

Packet {Standard)

Toolpath parameters | Pocketing parsmeters | Roughing/Finishing parameters |

Mumber  Tool Type Diameter| TooiNsme Comerrad  Tool rame: | 3/8 FLAT ENDMILL J
@ 1 SpotDil  0.7500. 3/4SPO.. 0.0000004 '
& 2 oDm 04844 . 31/64D.. 0000000

@ 3 TepRH 05625 9/1612.. 0000000 |

@ 4 Endmiti . 07500. 3/4FLA.  QO0D000GH §

¥ 5 CEndmil). 03750 VBFLA. 0000000  Toolda: |

S

Comer radius: ![ﬂ.{l |

[ Force tool change [ Rapid retract

L S Ny

: iRemnve the material inside of the pocket

O (o)

e oA & e
Dwé)rﬁ}*«ii% j { Planes... ] [Ca"nedTad,“ ]

" IraEana
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> Make all the necessary
changes as shown above
and then select the Pocket
parameter page.

» Enter the Depth value to set
the final machining depth for
the pocket operation (-0.25).

> Select the Constant
Overlap Spiral as the
Cutting method.

Stepover percentage sets
the distance between
roughmg passes in the XY
axis as a percentage of the
tool diameter and will
automatically update the

~ stepover distance.

‘Spiral inside to outside
_enabled allows you to spiral
“from the center to the pocket
‘wall.

~ Entry-ramp sets a ramp
entry into the part.

> Disable the Finish area.

Pocket (Standard)

i

i

i

S

S
-

{ Toolpath parameter | Pocketing parameters | Roughing/Finishing parameters |

| & (Geames ] 20 ]
(%) Absolute ) Incremental
|

[ Use dlearance orly at the
| start and end of operation

o () 5|
(D Abscite ) Incremental
(Eeedplone ] 01|
) Absohste {3 Incremental

(Eoptmocc ] 00 |
@ Absoite | () Incremental

{__Deoth.. 1025

& Absolte O incremental

achining direction

&amb Convertional

Tip comp

Roll cutter

around comers

Lir
tolerance

XY stock to leave

Z stock to leave

- [ | Cath cuts

ion

| Toolpath parameter | Pocketig perametes | Roughng/Frshing parameters |

[¥] Rough

g!mwnemm [50 |_ 3

muhﬁ Gmdmiﬂwuhpﬁwi

[¥] Mirémiza too! burial
[¥] Spiral Insida to outside

Fained oo

> Select the OK button to exit Pocket parameters.

Page 2-23




Mastercam.

Mill x? TUTORIAL 2

STEP 12:
BACKPLOT THE TOOLPATH.

> Click on the Toolpath Group-1 in the Toolpaths Manager to
select all operations.

> Select the Select All Operation button.
> Select the Backplot selected operations button.
»> Make sure that you have the following buttons turned on (they will appear pushed down).

> Display tool

Display tool

> Display rapid moves Display rapid moves

> Select Fit button, %"
> Select the Play button.

PR 2] g ' —

> Select the OK button to
exit Backplot. |
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VERIFY- TOOLPATH VERIFICATION
STEP 13:
VERIFY.

> Expand the Toolpaths Manager if necessary by dragging the
right side.

> Select the Verify selected operations button.

> Set the Verify speed by moving the slider bar in the speed control | omaeii |

Maves/iefesh: 1

| Speed _]_ Quality

 [#] Updale aftet sach tocipath.

Stop options
[]Stop on collsion

[0 Stap on tool change.
[ Stop after sach opetsiion

.ﬂVﬂtme ”

A —1 [
» Select the Machine button to start simulation. 4 _
» The finished part should appear as shown in the following picture. Toolpathc:  Pooket '

— m/ [‘-‘-ﬂ [‘“‘j@ i
» Select the OK button to exit Verify. 1 v . e
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STEP 14:
ASSOCIATIVITY.

14.1 Modify the existing geometry. Chamfer the corners of the outside
profile.

> Select the Top View from the view toolbar to see the part from the top. L.
Create

» Chamfer

> Chamfer Chains

> Select the outside contour.

/ Select the contour here

lo = o\ o

> Select the OK button to exit Chaining. L
» Enter the Chamfer distance @ 0.25.

> Set the chamfer style to 1 Distance. IDistricet,
> Make sure the Trim option is active (this button should be

selected).
> Select the OK button.

A

14.2 Update the toolpath. O O O

 Geet /s

¢ Notice the red X in the contour toolpath. This indicates that the toolpath was affected and
needs to be regenerated.

» To regenerate the Contour toolpath select the Regenerate all

dirty operations icon as shown. _T??‘???‘i?59ff?§ B
YU LY EP i 9;-_’
Select the Regenerate button | - [Bcgenerote st ety cpneatons
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14.3 Modify the existing pocket toolpath. Rough out the pocket.

é* Note that the 3/8” Flat End Mill could not clean the .0625” radius fillets.

& To improve the toolpath efficiency we will use a 1” Flat End Mill to rough out the part. Using
a 1/8” Flat End Mill and the remachining pocket type we will remove the material in the
areas where the 1” tool could not fit. " @ #4-0.7500 ENDMILL]

H . Geometry - (1) chain(s)
» In the Pocket Operation select the Parameters. B8 Toopath. 345K -YOU

Qu} 5 - Pocket (Standard) - (W
Select Parameters B Parameters

¥ #5-0.3750 ENDMILL1
E Geometry - (1) chain(s)
Toolpath - 29.2K - YOL

L

» Select the Toolpath parameters tab.

» Click on 3/8” Flat End Mill, and select Delete from the
keyboard.

> Select the Yes button.

r

Deleting tool used in operation(s)!

X,}«:," ) Are you sure?

» Click on Select library tool.
» Use Filter to select the 1.0” Flat End Mill.

—

Pocket (Standard) - Remove the material inside of the packet.

Toclpath parameters [P;dcatlng parameters | Roughing/Finishing parameters |

Number| Tool Type Diameter Tool Name  Comerrad Tooiname: | 1INCH FLAT ENDMILL 5
Spot Dl 0.7500.. 3/4SPO.. 0000000
Dl 04844 .. 31/64D.. 0.00DD0CH
Tap RH 0.5625-.. 9/1612 .. 0.0OCOOD
Endmifi1 ... 07500 . J/4FLA. DO0BOGDN
Endmilt .. 10000.. 1IMCH.. 00000004

GQQQ&
(5 I SRRy Nl

Feed rate: | 541 76

Plunge rate: ;5.4178 Retract rate: |6.4176
[ Force tool change Rapid retract

= |Remove the matenal inside of the pocket.

[j‘ Tool filtter I
[} To batch ¥ F s [ Flanes... J Canned Text... J

% Htt]l
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> Select the Pocketing parameters to enter the XY stock to leave amount, to instruct the
system to leave stock along the pocket wall for future finish operations.

Pocket (Standard) - Remove the material inside of the pockst.

[ Toolpath parameters | Pocketing parameters | Roughing/ Finshing parsmeters |
R ) [Qesmnce. ] [207] Machining recion
§ gﬁ ® Absokte ) incremental @Cfl“b O Conventionai
| Otsedemnceotyate  Tpom [T
- 1 start and end of operation
o] 7 ] Mo,
| ©avsote ) incremental T
[E“dm} i(” | tolerance
) Apsoite {8 Incremental XY stock to leava
Z stock to leave
(Topofstock ] [00 |
@ Aosolute ) incremental Cremie addtional firish apamtion
Depth... 425
3 @ Posoite | () Incremental
> Select the OK button to exit
the Pocket parameters. | rockattps: | [Saams W Vi(aens) e}
i
Lv [ %] 2]

> Select the Regenerate all dirty operations icon as shown to
update the toolpath.

Select the Regenerate button

14.4 Remachine the pocket corners.

> In the Toolpaths Manager, select only the Pocket operation.

! ﬁ Patameters
i H H ¢ -8 #4-07500 ENDMILLT FLAT -
> Right-mouse click on the Pocket, hold it down and drag, and L BB Geomety-{1)chaiis)

select Copy after.

|

|

| 88 Toopath-29.2K - TODLPATH_
=R 15 - Pocket [Standad] - WIS TOF]
{ LT Paramatars

: ..... 7 Move before h FLAT -

i L Move afier

o Copybefore  BLPATH_E

Caccel
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> The Toolpaths Manager will look as shown in the screenshot to the T ¢ Comou D) WCS TOFT 1ol
nght -{) Parameters
SR ST S R R || | e ¥ H4-07500ENDMILLT FLAT -
-JJl Geometry - (1) chain(s)
.8 Toolpath - 23 2K - TOOLPATH_
5 - Pocket (Standard) - fw/CS: TOP]
Parameters
----- W #5-1.0000 ENDMILL1 FLAT -
..JJ}| Geometry - (1) chain(s)
8% Toolpath - 9.9K - TOOLPATH_C

----- @ 45-1.0000 ENDMILLY FLAT -
—[ Geomety - (1) chains)
~&8 Toolpath - 10.0K - TOOLPATH_

> Select the down arrow to move the arrow one step down to
include the second pocket operation.

Move insert arrow down one item

= |--
E] & 5 - Pocket {Standard) - [v
Parameters
@ #5-1.0000 ENDMIL

> Select the Parameters in the second Pocket

operation Select ~N = l?eolrnetl:; ; 9[14]Kchain[:
: = oolpath - 9.

> Select the Toolpath parameters tab. parameters .8 Pk Sardad)1
> Click on the Select library tool button. B o1 o00n ENDMIL

B Geomety - (1) chain(:
B8 Toolpath - 9.4K

> Select the 1/8” Flat End Mill from the library.

=

Pocket {Standard} - Remove the material inside of the pocket.

1
% 2 oa 04844 . 31/64D. 0000200 A
W 3 TepRH 05625 91612 00000004 Head # 0
@ 4 Endmit . 07500 3/4FLA. D.000C00W s
¥ s
¥ s

Edmill . 10000 TINCH.. 0000000K  Tooida: |
Endmill .. 0.1250... T/BFLA. 0.000000)

Feed rate: (6,16
616089

Piunge rate:

i [] Ferce tool change ") Rapid retract

%

s (Defaut (1) Misc valuss.. | O ghel)
| ‘ -;—.';_-,?;,-,- D [ Planes. .. ] [anﬁd Text... ]

(vI[%] 2]

é* The Feed rate, Plunge rate, Retract rate and Spindle speed are based on the tool
definition. Change them as desired.
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> Select the Pocket parameter page and enter 0 in the XY stock to leave.

Packet (Standard) - Remove the material inside of the pocket.

! | Cearance... | | ¢ Machiring diretion
: jonal
g @absolte ) incremental ®amb O Convention
- [[] Use clearanice only at the Tnlcomy o
start and end of operation k |
| Rall cutter e o
& [(Rege. ) [15 | Dolote g @

@ Mbschte O Incremental e =
(Eeedpne. ] [01 7] tolemnce |
O Abschte (&) Incremental XY stock to leave !ﬂ.U |

Z stock to leave 00
(Top o stock..] 100 | -
@ osolute {3 Incremental e g ;

Depth... ! .25

& fbsalte 1) tncremental

[ Pdvancedﬁ

v ][ %] 2]

> Change the Pocket type to Remachining, select the Remachining button and change the

parameters as shown. "
Pockét remachining
: 721/( Compute remairing stock fom;
Compute remaining stock from: The previous ) All previous operations
operation enables the system to calculate the , {3 The previous operation
remaining stock for remachining by determining the el e

stock left after the previous operation. B
Clearance, set as a percentage of the tool diameter,
allows you to expand the remachining area at the Caarance {50.0 % {u.nszs
beginning and at the end to prevent a remaining cusp
of material.

Apply entry/exit curves to rough passes allows you
to use the Lead in/out parameters.

Machine complete finish passes aIIows you to finish | ¢ | [
the entire part. _N

Apply entry/exit curves to rough passes

Machine complete finish passes

> Select the OK button to exit the Pocket

remachining dialog box. L.¥_] oo | Depcuod -~
> E Max rough step El.ﬁ D .
nable the Depth cuts button and enter DBy pockel 3 By depth

0.05in the Max rough step. # Frish cuts u_““[
> Select the OK button to exit. L.¥_ Frish sep ps |

Depth cuts

"1 Keep taol down
{1 Use istand depths
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» Select the Roughing/Finishing parameters.

= [ Roughing/Finishing parameters [

» Enable the Finish area and enable the Lead in/out.

Cutting method:  Parallel Spirat

Constant
Ovesiap Spiral

Paraflel Spiral,  Momh Spral  High Speed Ona W
Clean Comers i

Roughing angle

 WFwish

| Passes Spacing

Spring passes  Cutter compensation

Minimize tool burial v Enftry
Spiral inside to outside

Qvemide Fead Speed
[ Feed rate 51

i | oo

| foompter ¥

[ Spindie speed

[¥] Finish outer boundary
[ Start finish pass at ciosest sntity
[ eep toc! down

| B

Machine finish passes after mughing all pockets

vhaz oultEr come 0 corirgl

-M

[1 Machine finish passes only at final depth

(v %] 2]

Lead InfOut

A
Radiuz

Sweep:

Hel height

Pocket parameters. |

> Select the OK button to exit QW Otwawt: OFependeulsr @Tangont
, | Lot [0 Jx o5 longh [0 |x[007
Lead In/Out. L. i o s *—ﬁ_@m ]

7] Use ety point [ Use esit point
L et cliity i e o depth
- [ Entet on first depth eul only 1€t on last depth cut ony
. BMaRe’f first move ] Aetract befors fast move
Dﬁmudafmdm.e [6.80806 | []uvm:w:ae |
» Select the OK button to exit - =
‘ f v (%] 2]

> Select Lead In/Out and set the line and the arc at the beginning and/or end of the cuts.

update the toolpath.

» Select the Regenerate aII d|rty operations icon as shown to

Select the Regenerate button
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STEP 15:
VERIFY THE CHANGED PART.

Toolpaths | Solids f At |

> Select the Select all operations button from Toolpath Manager.

> Repeat STEP 13 to be sure that the changes have taken place.
> The finished part should appear as shown in the following picture.

STEP 16:
EXPORT TO LIBRARY ALL DRILLING OPERATIONS. T:b:* ;ﬂ; [ Mﬁ'
6% We are going to create an operations library by exporting all drilling a=djva

= BB Machine Group1

operations from the current MCX file into a library (Ops folder). We are B 1k Proster Gesicht 8

going to Import the operations saved in the library each time we need - gmﬁ%ﬁmwg
to machine 9/16 -12 tap holes. 'm Q75005POT Dl

Geometry - (6) Points
! Toolpath - 5.5K - YOUF
:é ﬁ 2- Peck Dril - [wCS: TOP]

Parameters

#2-0.4844 DRILL - 31 |

> Select only the Spot drilling operation. - : !
> Hold down the Shift key and select the Tapping toolpath. . |

} #3-0.5625X 1200 Thwﬁ
it HGeometly [E)Points |
6 Toolpath - 5.5K - YDIJF@&?
B@ 4 - Contour {2D) - [WCS: IEW
Parameters

- ﬂ75|IIENDMILL1$$
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> Right click in the Toolpaths Manager window (below the

operations).
> Select Export...

> In the File field type Your name.Operations to
create a new library to which the operations will be
exported.

> In the Group field enter the name of the operations
group that will be saved in the new library.

> Disable Export operation’s geometry to export
parameters only and no geometry.

> Select the Export button.

» Select the OK button. ‘
» Select the OK button to exit.

STEP 17:
POST THE FILE

> Select the Select all operations button from Toolpath Manager.

> Select Post selected operations.

=

Undeets

Expand all
Collapse al
Doc fie...
Sort

Import...

et

M Export Toolpath Operatians

Fils EYour Name.OPERATIONS

Group 9/15 12Tap

[ Export operation's geometry

7] Disable duplicate tool checking

@ AL Propeties - Generic Mil

=82 Toolpath Group-1
# & 1 - Dril/Counterbore - WCS: TOP] - [Tplane: TOP] -
-3 2 - Peck Drill - WCS: TOP] - [Tplane: TOP} - Drilling
% 62 3- Tap- WCS: TOP] - [Tplane: TOP) - Tapping al
& £ 4 - Contour (2D) - WES: TGP} - [Tplane: TOP] - Cor
»‘ﬂ £33 5 - Packet (Standard) - WCS: TOP] - [Tplane: TOP]
3£ 6 - Packet (Remachining) - [WCS: TOP] - [Tplane: T|

—
Export toolpath operations ,ﬁ[

3 operations exported successfully,

V¥ | k
ﬁsdect all uperaumsl

[t =@ ¥ 9

!_i‘ 0 Spostselected operations
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> In the Post processing window, make all the necessary
changes as shown to the right.

» Enable NC file to keep the NC file assigning the same name
as the MCX file.

Post processing

.ZE.‘_»I-.L:-' Pod ‘

> Enable Edit to automatically launch the default editor. [ Output MCX fite descriptor
. ML file
> Select the OK button to continue. O Overwits 7] Edit

@Ak

["]Send to machine

[ NC file

> Select the Save button.

— T T = = S oo

¥ ] YOUR RAME_ L NC

w8 2

Wi

Wb:nmu i

My Natwark e name;
Seveasbpe:  NCFles ©NC)

[ T M | Al i TR AR e )

Ze B Yai WCPuciues foomats el Conpwe Comuniater Tk gindoe e
tee. @l BURGBIARATEFERTE TG BT WE S 4%%N
W kN Tod Geger ) MentTos £ Soto Freveous ok . -

i . e -

> Select the red X to exit Mastercam
Editor.

STEP 18:
SAVE THE UPDATED MCX FILE.

> Select the Save icon.
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REVIEW EXERCISES.

Student practise. Create the Toolpath for Exercise 1-Tutorial 2 as per the instructions below;

Tips:
Stock size; X =19.5,Y=16.5and Z = 4
Spot Drill the holes using a 0.75” Spot drill
Drill through holes with a 1.0” drill (right-mouse click on the tool in the Toolpath parameters and
Edit Tool: Flute = 4.125; Shoulder =4.25 : Overall = 4.5)
Cycle Peck Drilling
Drill through holes using a 1-3/8” drill
Change the current library to Big.tools in the Tool selection window.
Edit the tool as in the previous step.
Cycle: peck Drilling
Contour the part using 1 “ Flat End Mill; Edit the tool height to 4.5
Max rough step =0.5* (Depth cuts)
2 roughing passes with spacing = 0.75"
1 finish pass 0.05" (Muti passes)
Pocket the part using the same 1 Flat End Mill
Max rough step = 0.5 “ (Depth cuts)
Cutting method = Parallel Spiral
Backplot and Verify the toolpaths.
Post process the file.
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TUTORIAL 2

Student practise. Create the Toolpath for Exercise 2-Tutorial 2 as per the instructions below;

Tips:
Stock size use Bounding box/All/Entities and give
Z=1"
Drill the 0.2 diameter holes using 0.2010 Drill
Cycle: Peck drilling
Contour the part using 1 “ Flat End Mill;
Max rough step =0.5* (Depth cuts)
1 roughing passes with spacing = .75"
1 finish pass 0.05" (Muti passes)
Pocket (rough) the part using the same 1“ Flat End Mill
Stock to leave XY = 0.05
Pocket (remachining) the part using the 3/8" Flat End Mill
Pocket (finish) the part using the 3/8“ Flat End Mill
Drill the 3/4 diameter thru holes using 3/4 Drill
Cycle: Drill/conterbore
Top of stock = -0.500( abs)
Feed plane = 0.100 (incr)
Depth =-0.75
Circle milling the 1 % diameter holes using 3/4 Flat End Mill
See Tutorial #5 Step 11
Top of stock = -0.500( abs)
Feed plane = 0.100 (incr)
Backplot and Verify the toolpaths.
Post process the file.
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Objectives:

The Student will design a 3-dimensional wireframe drawing by:

> Creating arcs using polar positioning.

> Creating lines using co-ordinate entry.

> Creating arcs tangent to 2 existing entities.

> Trimming 1 entity to another existing entity.

> Creating fillet radii.

> Creating parallel lines, by defining the offset direction and distance.
> Breaking existing geometry into 2 sections.

> Translating existing geometry to create a 3-dimensional block.

The Student will create a 2-dimensional milling toolpath consisting of:

> 3 holes drilled through the part.

> A 2-dimensional pocket.

> A 2-dimensional contour.

> Lead in and lead out toolpath entry.

The Student will check the toolpath using Mastercam’s Verify module by:

> Defining a 3-dimensional rectangular block the size of the workpiece.
> Running the Verify function to machine the part on the screen.
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GEOMETRY CREATION
To start a new file from Mastercam:

File

> New

Setting the toolbar states

é* Before starting the geometry creation we should customize the toolbars to see the toolbars
required to create the geometry and machine a 2D part. See Getting started page A-5in
the User Notes.

é* Toolpaths/Solids manager to the left of the screen can be hidden to gain more space in
the graphic area for design. Press Alt + O to remove it.

é* Before starting the geometry make sure that the Grid is enabled. It will show you at each
moment where the part origin is. See Getting started page A-5 for details.

STEP 1: i
CREATE THE OUTSIDE PROFILE OF THE -
SLOT. |
1.1 Create an obround shape using
rectangular shapes.

Create

> Create Rectangular Shapes

> Type the Width and the Height as shown in the following .
picture. Rectangular Shapes Options [X|

> Select the double arrow to expand the Rectangle Options as
shown in the screenshot below if needed.

Select the Double
arrow
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Rectangular Shapes Options 5(;|

> Select the Obround Shape. B hecral
> Select the middle bottom radio button as the anchor. © 2 Pints

Select the Obround
shape

Select this radio button

of

e 0 ol

O ND O
> [Select the position for the base point]; Select the Fast Point icon. o o
> Enter the values into the box to the left of the icon: 0, -0. 76/2 (Enter) DOlsufoce  []0emer Poin
| P

> Select the OK button to exit the rectangle dialog box. |

» Use the Fit icon to fit the drawing to the screen. .
& During the geometry creation of this tutorial, if you make a mistake, to undo the last step you
can use the Undo icon. You can undo as many

steps as needed. *?if you delete or undo a step by mistake, just use the Redo icon. &
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1.2 Create the outside obround shape using offset contour.

Xform
» Xform Offset Contour.
> Select the chain as shown in the following screenshot.

Select this
entity

> Select the OK button to exit the Chaining dialog box. t ‘

> Select the radio button in front of Copy to keep the original geometry
> Enter the Distance in the dialog box: 0.37.

> Enable the Preview and Fit to be able to see the result in the graphic

area. 5 ¢ F
é* Note that the resulting offset contour should be outside of the ]
original one. -

» Select the direction arrow button if you need to change the side of

Crams

the offset contour.

Otone csm o §
P'ee\ﬁew

on

» Select the OK button to exit. L. ¥

Screen
> Clear color

] Uze Mew Altnbutes

(VIS z2]
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STEP 2:

CREATE THE 9/16” AND 1.5” DIAMETER ARCS KNOWING THE
CENTER POINT AND THE DIAMETER.

Create
> Arc
» Create Circle Center Point

> Enter the Diameter value @

9/16 (Enter).

> [Enter the center point]: Select the Fast Point icon. k&
> Enter the values into the box to the left of the icon : 5.5, 2.75 (Enter).

> Use the Fit icon to fit the drawing to the screen.
> Select the Apply button.

> Enter the Diameter value &2 1.5 (Enter).

> [Enter the center point]: Select the center point of the created circle.

vy Select the
> Select the OK button. & center
» Use the Fit icon to fit the drawing to the screen. point
STEP 3:

CREATE THE TANGENT ARCS WITH 6” AND 4.2” RADII USING THE
FILLET COMMAND.

Create
> Fillet
» Fillet Entities

> Enter the fillet Radius &2

U

» Enable the No Trim icon from the ribbon band Mo Trm
> [Select an entity]: Select Entity A.

> [Select another entity]: Select Entity B.

Select Entity A

Select Entity B

é* There will be many options displayed.
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> [Select the fillet to use]: Select the arc as shown.

Select this
arc

> Select the Apply button. &

> Enter the fillet Radius @ 4.2,
> Keep the same no-trim option.
> [Select an entity]: Select Entity C.

> [Select another entity]: Select Entity D.

Select Entity D

| Select Entity C

> [Select the fillet to use]: Select the arc as shown.

» Select the OK button. . Select the

this arc
STEP 4:
CREATE THE 1.0” RADIUS FILLET.

Create
> Fillet
> Fillet Entities

e
> Enter the fillet Radius &2 1.0
> Keep the No Trim icon from the Ribbon band as shown before.

> [Select an entity]: Select Entity A. ——
> [Select another entity]: Select Entity B.

Select Entity A |7

é* There will be many options displayed.

Select Entity B

> [Select the fillet to use]: Select the arc as shown.

Select this arc

> Select the OK button. &
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STEP 5:
TRIM ONE ENTITY.

Edit
» Trim/Break
» Trim/Break/Extend

> Select the Trim 1 entity button.
> [Select the entity to trim/extend]: Select Entity A.
> [Select the entity to trim/extend to]: Select Entity B.

> Select the OK button. §

N
-

Select Entity A [’ Select Entity B

STEP 6:

CREATE THE 0.56” RADIUS POLAR ARC KNOWING THE CENTER
LOCATION, INITIAL AND FINAL ANGLES.

Create

> Arc

» Create Arc Polar

&* The center location of the arc is measured relative to the center of the 1.5
diameter circle.

> [Enter the center point]: Click on the drop-down arrow as shown and select
Relative.

> [Enter a known point...]: Select the center point of the 1.5 diameter circle as
shown in the picture below.

e o Along ode |
Select the

center
point

-3.4, 1.25 (Enter).

> [Enter rectangular or polar coordinates]:

Page 3-8
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> Enter the Radius ) 0.56.
é* To set the other parameters of the arc use the Tab key. Note that the diameter value is
automatically changed by the system based on the radius.

> Enter the Start Angle =5 0 (Tab).
> Enter the End Angle = 180 (Enter).

> Use the Fit icon to fit the drawing to the screen. @
> Select the OK button. »A

STEP 7:
CREATE THE 0.38” RADIUS FILLET.

Create
> Fillet
> Fillet Entities

3 0.38. .
:
» Enable the No Trim icon from the ribbon band (should be already enabled).

» [Select an entity]: Select Entity A.
> [Select another entity] Select Entity B.

Select Entity C

Select Entity A

Select Entity B

| select Entity D

> [Select an entity]: Select Entity C.

> [Select another entity]: Select Entity D.

é* Note that a fillet option will be automatically drawn depending on where you move the cursor
around the entities. You can select the desired fillet.

» Select the OK button. &L
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STEP 8:
CREATE THE 9/16” DIAMETER CIRCLE KNOWING THE CENTER
POINT AND THE RADIUS/DIAMETER.

Create

> Arc Select the

> Create Circle Center Point center =
() point

> Enter the Diameter value & 9/16 (Enter).

> [Enter the center point]: Select the center of the 0.56 radius

arc. o
> Select the OK button. &£
STEP 9:

TRIMMING THE ENTITIES.
9.1 Trim two entities.

Edit
> Trim/Break
> Trim/Break/Extend

nuf » Jisk
> Select the Trim 2 Entities button, [L[_{rmzeny
> [Select entity to trim/extend]: Select Point :
e 4 ! PointA |~ Z | FointC
> [Select the entity to trim/extend
to]: Select Point B.
> [Select the entity to trim/extend): Select
Point C.
> [Select the entity to trim/extend to]: Select
Point D.

1
Point B

9.2 Remove the arc that lies between the two fillet arcs using divide.

.

» Select the Divide icon from the trim ribbon bar. J.I_li!‘ﬂl

» [Select the curve to divide]: Select
Entity A. Select the Entity A ~

> Select the OK button.
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STEP 10:

BREAK THE EXISTING ARCS AT INTERSECTION TO BE ABLE TO

CHAIN THE OUTSIDE CONTOUR.

AN
/L:k\

Entity H at the endpoint of the Entity G, so that the chaining can follow the
outside contour that has to be machined .

When you chain geometry, you select one or more sets of curves (lines, arcs,
and splines) which have adjoining endpoints. We have to break Entity A at the
endpoint of the Entity B; Entity C at the endpoint of the Entities D and F; and

Endpoint of Entity D

Endpoint of Entity B

I

~ | Entity C

Entity A — ] " Endpoint of
v | Entity F
| | -

Entity H \ i I
| U— Endpoint of Entity G

Edit
> Trim/Break
> Break at Intersection

Only...

> [Select the entities to break]: Select the All button.

> Select the OK button inside the Select All dialog box. L.¥._]

AlEntiies
Xform Result
Xfotm Group

Group Manager

. Digrore desihs in chsning
=

 ClUise Oy Mask
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O @

> Select the End Selection icon End Sefecbon

> Select the Repaint icon. |4
The geometry should look as shown in the picture below.

STEP 11:

SAVE THE FILE.

File
> Save as
» File name: “Your Name 3”‘

> Select the OK button. |
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TOOLPATH CREATION
STEP 12:
SET THE MACHINE TYPE.

Machine type Toolpaths Scoeen  Art
> Wil B T S|
> Select the Default Lathe *| 1 C}\MCAMX2\CNC_MA

> To display the Toolpaths Manager press Alt + O.

§5% (oo fedretie faats S A1 Setrye de

o o8B BES 93 ‘Q?% Te i‘ TR @ RS ICH WAZE-

dHASFWIELNE

FEPPSP | SXRT e BE &= 3 BBRE o

]
L e

STEP 13: e — e R S S
SET UP THE STOCK TO BE MACHINED.

> Select the plus in front of Properties to expand the Toolpaths Group Properties.

Todpaths [Soide [ At |
CEA ST o
(% i wval $ K¢

Select the plus ~ g MaaCraed
- 1l Propetties - Generic Mil
a-- .4 | cioip L1

» Select Stock setup.

K a@‘!.écﬁ.%w%%”

Select Stock N
setup

= B8 Machine Group-1
= -AlL Properties - Genenc Mil
& Files

Stock setup
Safety zone
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» Select the Bounding box button for the system to automatically find the part’'s overall
dimensions.

> Select the OK button to exit the Bounding Box window. LY

-
-
-
M S
-
-
-
-

Machine Group Properties

» Enter the Z value 1.0".

(oo ] [Bomrgier] [ i |

[ MEwe [ Uesean |

e
i e i i ;
G S S S
S - i

i s
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> Select the Tool Settings tab and change
the parameters to match the screenshot
to the left.
& For more info on parameters see
Tutorial #1.

Machine Group Properties

« Feed Calodation ~ = 5 Toclpath Corfiguration

& From tool Assign toal numbers sequentially

{7 From matesial Wam of dupicate tool numbers
i From defaults [7] Use toal's step, peck, contart
Otomsir D
¢ Advariced options
Retroct rate : | [Flovenide defauts with medal values

= Clearance height
Plunge rate : 7] Retract height
[7] Adiust teed on arc move Feeri plane
Seguence ¥
St (a1

¢ Material
ALUMINUM inch - 2024

> Select the OK button to exit Toolpath

Group Properties. j
> Select the Isometric Vlew from the view

(vI[®] 2]
toolbar to see the stock.| @ ¥ Q@ .

> Select the Top View from the view toolbar to see the part from the top
» Use the Fit icon to fit the drawing to the screen. .
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‘ STEP 14:
CONTOUR THE OUTSIDE PROFILE.

Enter new NC name
Toolpaths
> Contour Toolpath C:AMCAMXZAMILLANC

> Select the OK button to accept the NC file name. [ItOUIR NAME_3

> Select the first entity in the contour, as shown.
& Be sure to chain the contour in a CW direction.

Pick here | O Cplane & D
second Pick here 5| [ |
third
Select here Pick here
first \ fourth
| |

i i ]

» Select the OK button to exit Chaining. e ——— % @‘ﬁ«did{fampftm_s
> Select the 0.75” Flat End Mill following the

steps outlined below. Select fibrary to. 0
> Click on the Select library tool button. || — i == iy
:

> Select the Filter button in the Tool Selection window.

A Tool Seloction - CAMCAMXZUMILLY] ESWHEL INCH. TOOLS

MILL_INCH.TOOLS v
Mumber | ToolType| Diemeter, ToolName Comeriadus! BadisTyos &

197 Endmill .. 05312.. 17/32F.. 0000000in. None e
223 Endmill.. 0O0313.. 1/32FL.. 0000000in Nene i

230 Endmill.. 00625.. 1/16FL.. 0000000in None
231 Endmill .. 00938. 3/32FL. 0000000in. None
232 Endmill . 01250. 1/8FLA. 0000000in Mone
233 Endmill .. 01563.. 5/32FL.. 0.000000in.  None
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Tool List Filtes

> Select the None button
to disable any previous
tool selection as shown.

Mastercam,

TUTORIAL 3

» Select the Flat Endmill

button in the Tool Types

IiSt. B (i g
» Select the drop-down
arrow in the Tool

Radiue Type
] None iv'| Corner [ Full
Toal Material
f#]Hss [¥] Ceramic
Catbide Usar Def 1
Ti Coated Uset Def 2
[ All ] [ Nong I [ Copy job selup matl ]

raEaEa

Diameter field and select
Equal.

> Enter 0.75 in the Tool Diameter value
box.

» Select the OK button to exit Tool List

Filter.

> Make sure that the tool is selected (highlighted) in the
Tool Selection window.

> Select the OK button to exit Tool Selection. L.

P N i 1
b
“ow TodTipe Do TdNom Gomerat | sk Tpm
[} Fiter Active
ol W32 ey
_ B— [V [7]

"

Contour (2D)

Toolpath p Cortourf
 Mumber| Tool Typs  iameter| Tool Neme | Comerred
: Endmill . 07500,. 3/4FLA.  0.000000%

e
> The Feed rate, Plunge !

rate, Retract rate and
Spindle speed are
based on the tool
definition. Change them
as desired.

» In the Comment field
type a comment for
future reference.

.| Comment

|
| e

Tool name: [ 374 FLAT ENDMILL

Tool &: Lan. offsst: [:I
el | e |
Taol da;_@ ............. .
Comer radius: E]E

Feed rate: 64176 Spindle speed: | 713

] Force tool change [ Rapid retract

Outside contour A

Select kbrary tool... DI Tool fiter ]
[ 7o batzh

It

el

(vI[%1[7]
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> Change the parameters as shown in the following screenshot.

For more info on the Toolpath parameters | Contour p ]
parameters see Tutorial # :
1 —_— [ Clearance... ] §2-0 E
) @ fbsohte O Incremertal
[[J Use clearance only at the
start and end of operation

&6 You can increase the
Depth value if you
want to cut through
without leaving any
burr.

@ ((Beget. ] 02 |
& Mosolite ) Incremental
[Eeedplane...] iﬁ-1 }
) Absclite (&) incremental

[opdfsocc.] 00 |

{® Aosolte O Incremental

([Leph. ] |10 ]

@ Rosolte (O incremental

Compensation |
type:

Compensation |
direction: i Lﬁ

Tip comp Tip
Rolt cutter
infinite look ahead

Linearization
toleran

XY stock
to lzave

Zstock
loleave

> Select the OK button to exit. L8

Max rough step:

# Finish cuts. _ d

Finisi} step. \ |‘[10_0-5—_00
[IKeep todl aown \\\\\\ -
¥ Subpr\ogrﬁam:

Absolhle  ® ncwendd

Depth cut cnder
($) By contour

3 By depth
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» Enable the box in front of the Lead infout button and select a combination of a Line and an

Arc at the beginning and/or end of the contour toolpath for a

the part.

Lead InfOut

= Eréry
Live
(¥ Perpendicular 3

Length: {100 0

Ramp height:

A
Radius:

Swesp;

Helix height:
| [[JUse ertry point
- .
[} Enter on lirst depth cut only
[T Piunge after first mave
[7] Override feed rate ?*

0 Adust stat of contour

Length:

smooth entry/exit while cutting

Oveilap: iU.U
Exit

Ling

3 Perpendicular (& Tangent

Length: [1oo0  ixo7s

Ramp height: a U" “y

A

Radius:

Sweep:

Helix height;

[ 1Use exit point

i sttty
{1 Esit on last depth cut only
[T Retiact before last move

[ Override feed rate

- Adjust end of contour
-

Select the OK button to exit the Lead In/Out dialog box.
» Select the OK button again to exit Contour parameters. L_¥..J
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STEP 15: T a1 _
CHANGING THE STARTING POINT. & h B0k 22

AR vaGd NG

= B Machine Group1

> Select the Geometry. -l Poaes Susio
Select the S i Too st
Geometry Sk e

%22 Toohath Graup-1
Lo <o | - Contoy [0

> Right-mouse click on Chain1, and select the Start Point.

Change side
Rechain all

Select the Dynamic button

> Select the Dynamic button.

> Move the arrow to the desired position and click as shown in the
following picture.

Select the point here

Select the OK button to exit the Chaining dialog box.
» Select the OK button again to exit Chain Manager.
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> Select the Toolpaths Manager to activate it.
> Select the Regenerate all dirty operations icon for the change to be applied.

Toolpaths ESoIids § ) L
% Y A = 901?"?

| wglRegensrate al driy aperations|
L E/Bar:hi'le G{oup‘l 1. JI
Select Regenerate all 1 ‘f*é;";;,’;:*“’mm M
dirty operations - Todtsetigs

&P Stock setup
A Salety zone

i [Jl] Geometry - [1) chain(s)
- i

oalpaths Qsohds At |

%w W % %@GIE’@ ? 2

> Select Toggle toolpath display on selected operations
to remove the toolpath display

STEP 16:

CREATE EXTRA GEOMETRY TO BE ABLE TO OVERLAP THE OPEN
AREAS OF THE TOP OF THE PART.

Xform
» Xform Offset
> Enter the distance value 0.5.
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> [Select the line, arc, spline or curve to offset]: Select Entity A.
> [Indicate the offset direction]: Select a point outside the part.
> Repeat this procedure for Entities B-E.
> Select the OK button”to”exn the
Offset dialog box. Entity B | —~—— Entity C

Entity A

Edit s i

Entity D

Entity E

» Trim/Break
> Trim/Break/Extend

> Select the Trim 2 Entities button. e
> [Select entity to trim/extend]: Select Entlty A
> [Select the entity to trim/extend

to]: Select Entity B.
> [Select the entity to trim/extend]: Select Entity B.
> [Select the entity to trim/extend

Select Entity
/ B here

to]: Select Entity C.

Select Entity
> Select the OK button. &

A here

I{ ™ \
Select Entity C

here
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Create

» Line

» Create Line Endpoint

> [Specify the first endpoint]: Select Endpoint A.

> [Specify the second endpoint]: )
Select Endpoint B. Endpoint C

)

Endpoint D

Endpoint A

Endpoint B

Endpoint H

Endpoint F

Endpoint G

> [Specify the first endpoint]: Select Endpoint C.
> [Specify the second endpoint)]: Select Endpoint D.
> [Specify the first endpoint]: Select Endpoint E.
> [Specify the second endpoint): Select Endpoint F.
> [Specify the first endpoint]: Select Endpoint G.
> [Specify the second endpoint]: Select Endpoint H.

Wy
> Select the OK button to exit the command. B3
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STEP 17:
POCKET THE INSIDE OF THE PART.

Toolpaths

> Pocket Toolpath

> Select the first entity of the pocket chain, as shown.
> Select the rest of the branches in the order shown.

Select the
first entity
here !
Rl
|
Select the
second
Select the branch
fourth :
branch i
Select the third !
branch :

> Select the OK button to exit Chaining. L.¥__|
> Select the 1/2” diameter Flat End Mill usmg Select library tool and Tool Filter as shown in
Step 14. In the Comment field type a comment about the toolpath for future reference.

Pocket (Standard] - Pocket the inside of the part.

Toolpath parameters | Pocketing parameters | Roughing/Fristing ] _
: Number | Tidepsl Ilundu* rwpaagg Comer rad Twm-_| 172 FLAT ENDMILL |
| & 1 Endmar.. 07500

Tool #: .2 Lan. cﬂsat

Headn|ﬂ | Diaoffset: 2 _'

Tooldia: |05
Comerradius: 0.0

i Cormment
— . — " Ipgckelthe naide of the pad. & 1
Fﬁgﬁd@ddm'ophms ' =
!
Select ibrary toal.., | I Yool flter l N

Tool display...| [ Bafpoit . |

..[:: Fanes.. ) (Comned Text.. |
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> Make all the necessary changes as shown to the right and select the Pocket parameters
page.

Pocket (Standard)

[ Roughing/Finishing

@mm_,, ] ;2-0 ! + Machining directicn
@ Absolute {7 Incremental @Cmb ¢ Convertional
[ Use clearance orlly at the T T
start and end of operation I
Roll cutter
[ Seadt. } 10'25 | around comers

© Apsolte (O incremental Linearization
tolsrance

XY stock to leave

Z stock to leave

G [T
@ Absclte £ incremental [T Create addttional finish operation

(o ] [05 ]
& rbsoite ) Incremental

> See Tutorial #1 for ot | ; al

more info. iy Fl Eisent

> Enable the Depth cuts and select the button to set the cuts along the Z-axis. Mastercam
divides the total depth into equal steps baggd on the Max rough step value.

> Select the OK button to exit Depth cuts. |

Depth cuts

Max raugh step .
- ~ (¥1Bypocket (7 Bydepth

# Finish cuts i L

Finish step ; i

[T] Keep tool down [ Tapered walls

{7} Use island depths

"] Subprogram

Abirojubs Incrarrieniial
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Select the Roughing/Finishing parameters tab and make the necessary changes.
> Select the Constant Overlap Spiral as the Cutting method.
» Disable the Finish area. p——

| ;rO.O'Dﬂf&T" e e

auah

Roughing angle

[] Firish

e e ]
Stepover percentage sets the distance between roughing passes in the XY axis as a
percentage of the tool diameter and will automatically update the stepover distance.
Finish area enabled allows the tool to make another cut around the pocket walls to
“contour” the walls. Used when Zig-zag or One way was selected as cutting method, to
remove the scallops left by these cutting methods. It can be also used to finish only the
pocket walls.

» Select the OK button to exit

Pocket parameters.
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STEP 18: TaT
IMPORT FROM LIBRARY 9/16 TAP HOLES. 2 v
i Docfle..
> Right-mouse click in Toolpaths Manager window. B
e —
Batch...
| Display options,
> Setup sheet..
SRR b
> Select Import...
> Select the drop-down arrow in the Source folder and |  Source folder CAMEAMSAMILADPS :
select the Your name. Operations. | You Nane OPERATIONS ) '

. |Mil_lnch.DOPERATIONS
Mill MM.OPERATIONS

B Import Toolpath Operations

Source foldar CAMCAMXAMILLAOPS

» Click on the 9/16-12 Tap group. Four Name DFEFATIONS
&* Make sure that all three operations (spot drilling,
drilling and tapping) are highlighted.

[ Calculate speads and feeds
] Assign currant system tool and constiuction planes
[ import operation's gecrmetiy

= Machine Definiion
@11 Propertiss - Genenc Mill
= sg 91612 Tap
& B 1 - Diil/Counterbore - [WCS: TOP) - [Tplane: TOP] -
@ B 2 - Peck D - [WCS: TOP] - [Tplane: TOP] - Diiling
& G 3-Tap - [WCS: TOP)] - [Tplane: TOP] - Tapping al 9

> Select the OK button. i

> Select the Yes button to import the operation group.

» Select the OK button.

> Close the Import Toolpath Operations parameters. 1

é* Note that all the imported operations have no geometry. We are
going to add the center points and regenerate the toolpaths as shown in the following steps.
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> Select the first drill operation, Geometry.

|3 Parameters ol
! | W . 0.7500 ENDMILLY FL
'l Geometry - (1) chain(s)

Parameters

|- @ #2-02500 ENDMILLY FL. |
|l Goomely: [1)chainls) ||

| !l Toolpath 31,3k il

-8B V161210 '

-3 - Sienpl

Select the ¥ 13-0.7500SPOT DAILL -
L =i
Geometry | || | L B Toobain- 00K P
[ (@9 4 - Peck dill - full retract - [WC
31 Paametess
¥ #4-04844DRILL - 315
5--. Geomelry - (0] Foints Il
B Toolpath- 0.0
- 5- Tapping - leed in. teversa ¢
B Pasameters
LB #5-05625X 1200 TAPF) |
r B Geometry - (0] Points
I.! - Toolpath-0.0

SH

> Select the OK button.

> Right—-mouse click and Select Add points...

> Select the Mask on Arc button in the Drill Point Selection.
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> [Select the arc to match]: Select the 9/16 “ diameter

arc as shown.

> Select a window around the part.

> Hit Enter when finished.

> Select the OK button twice to exit. &

Mastercam.

TUTORIAL 3

Select the 9/16
diameter arc

Select a
window
around the
part

> Select the Regenerate all selected operatlons icon for the change to be applied.

T oolpaths i Sohds

W W | E;‘«Ms"x EPoih @

@ drjegenerate al selected opevaml

> Holding the right-mouse button, drag the new Geometry (2)

Points on top of Peck drill Geometry.

> Release and select Add.

@5 3-Simple - o peck- [WC‘ i
3 Parameters .

Right-mouse
click on
Geometry

¥ #3-07500SPOTDRILL-| ¢
omely - (2) Points| .

. Toolpath - 4.4K
(=8 4 - Peck dill - full retract - [WC ;1
L Parameters %

l #4 - 0.4844 DRILL - 31/6
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> Select the Peck Drill Parameters in the Toolpaths Manager. T g

i~ B #2-0.2500 ENDMILLY FLA

i Geometry - (1) chainfs)

L8 Toolpath - 54 6 - MACHINI
= B 3 - Simple diil - no peck - [WCS:
Parameters
#3-0.7500 SPOT DRILL -
Geomstry - (2] Points
&5 Toolpath - 4 0K - MACHINE

-~ R4-04844 DRILL - 31/64
Select the Parameters | Il Geonety - (2) Points

i B Toolpath - 0.0K - MACHINE,
~|- % 5 - Tapping - feed in, reverse sp
; Parameters
#5-05625X12.00 TAP RI
Geometry - (0) Paints
Toolpath - 0.0K - MACHINE.

» Change the Comment in the Toolpath parameters page to “Drilling all 31/64 diameter
holes.”

> In the second parameter page change the drilling cycle and the Depth as shown in the picture
to the right.

@ fbsohte ) Incremental

[¥] Use clearance only at the
start and end of operation

[ Rotmt. |01 }
(3 Absolute ) incremental
(Zeedsode. 00| -
® Mbsclte ) Incremental ;

[ Degth.. l E_w :EI Dwell
&) Absolts ) Incremental G
[] subprogram

¥ nomanial

o (vilxil2]
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> Select the Tip comp button and change the
breakthrough amount value as shown.
> Select the OK button to exit the Drill tip

Drill tip compensation

compensation window.

' Tiplength
Tip angle 118 E—]

(vI[% ][ 2]

> Select the OK button to exit drilling parameters.
> Copy the geometry in the tapping toolpath following the same steps shown for drilling

geometry.

> Select the Regenerate all dirty operations icon. Tealaths | Soids | -
vk DI S@octlh P

@ = @ %{Regenerabe all dirty operah‘or:s‘

STEP 19:
CREATE A POCKET TOOLPATH FOR THE 1.25 LONG SLOT.

Toolpaths

» Circle Paths

> Slot Mill Toolpath

> Select the chain as shown in the following picture.

Select the
contour
here

> Select the OK button to exit the Chaining dialog box. m
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> Select the 1/2” End mill used in the previous operation.

Slotmill parameters

|
ey ] 1/2 FLAT ENDMILL |

Feed rate: (64176 Spindis spee

Comment
| Stot milling. |

ﬂjgmdld(forodm
Select ibrary tool . O [ Tootfiter ] ‘

i Slotmiil

répids to or from the part.
Retract value S’efsé the
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> Enable the Depth cuts and select the button to set the Digth culs

parameters as shown.
Max. rough step

ﬁ? # Finish cuts
Depth cuts set the cuts along the Z-axis. Mastercam divides
the total depth into equal steps based on the Max rough
step value. -

Keep tool down enabled doesn't allow the tool to retract
between cuts.

Finish step

> Select the OK button to exit the Depth cuts window.
> Select the Rough/Finish parameters page and check if you
have the same settings as _
shown in the next piCture. Slotmill parameters

| Toolpath parameters | Sict parameters | Rough /firish parameters |

o \

Ramp entry sets the tool
to ramp down to the Pungs sro:
cutting depth on the first (7] Outous helees s arcs
pass. The next passes Tole

are performed in the XY
plane based on the
stepover amount. | : :
The Number of - 1 M Gl
Finishing passes and UG T i
the Spacing amount set ol

passes that the tool will
remove last.

ﬁ (¥ Ramp entry

Stepover:

Roughing passes

Number-

Spacing:

> Select the OK button to exit slot parameters
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TOOLPATH VERIFICATION

STEP 20: Toolpaths | Soids |

A HCDT THEN QR TR <l LEESo

> Click on Select all operations in the Toolpaths Manager. <
Tockpaths 15“5" EFIE 1 Tem ]

> Select the Backplot selected operations button. wﬁw’s‘,ﬂs‘x @ 9 61%| ;IF

> Make sure that you have the following buttons turned on (they
will appear pushed down).

> Display tool Display tool

» Select the Isometric View from the view toolbar to see the stock. J e @

> Select Fit button. ‘%5
» Select the Play button.

DR 27

> Display rapid moves

Display rapid moves

> Select the OK button to exit Backplot. i
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STEP 21:
VERIFY

Toolpaths I Solids i
VU DK ERcE P

fil &= &) | w & [Verify selected opera

> Select the Verify selected operations button.

> Make sure that you have the same parameters enabled as shown.
» Check Tutorial #1 for more details.

Moves/step:
Moves/refresh:

.....

 [¥] Update after each toolpath

. Stop cpti

] Stop on tool change
.

i ["1Stap after each operation
3

_Ijv;tboa
e

Toopath:  Sltmiling

\\\\\\\\

Tool #:
Toot label:
Ly ][ % |
> Set the Verify speed by moving the slider bar in the speed control : w5
bar. _@_J [_“_Hy '&'

> Select the Machine button to start simulation. E]
> The finished part should appear as shown in the following picture.

&*Note that the depth of one of the
tapping holes has to be modified as
it is not deep enough. The chamfer
necessary before tapping is not
created.

> Select the FOK button to exit
Verify. 1
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STEP 22 Edgrac:_:eﬁ:::pg\MMMX\CNC
EDIT THE DEPTH IN A DRILLING OPERATION. : !

1% 1 - Contour (2D) - WCS: TOI
i Parameters
¥ #1- 07500 ENDMILLT FL

» Select the Spot drilling toolpath Geometry in the Toolpaths T i ;
Manager. | &% 2-Pocket (Standard) - WCS: ||

Parameters
#2 - 0.2500 ENDMILL1 FL .

i «.mv e

Geometry - (1) chain(s)

Select the \ E E Toolpath - 40.9K
w-alL P

Geometry

3 Parameters i
#3-0.7500 SPOT DRILL !

M Drill Point Managot

> Right-mouse click on Point 2.
> Select Change at point.

@ = Restore opesation sefting

> Enable Depth and enter the value as shown to the rlght(5) ®

= Apply to subsegquent points

I Jump height

> Select the OK button to exit Drill change at point. :
> Select the OK button to exit Drill Point Manager. |

™ Clearance
™ Rebact

¥ Depth

" Feedrate

Taolpaths | Solids |
¥ %Wvﬁ}@fﬁ:ﬂ c1% | P
> Select Verify and check the toolpaths again. B = 3] | Nregenoate ol drty peratons)]

STEP 23:
POST THE FILE.

> Select the Regenerate all dirty operations button.

Toolpaths 1 Solids 3
FAS T
ool amtonh I &

> Make sure that all operations are selected, otherwise
> Select all operations button.

» Select the Post selected operations button from Toolpath Manager.
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> In the Post processing window, make all the necessary Post processing
changes as shown to the right.

[] Output MCX file descriptar

NC file
) Overwiite [~] Edit
@ Ask NC extension:

[[] Send to machine Comeioation:

[T] NC file

» Select the OK button to continue.

A L R .
= e e P

» Select the red X to exit Mastercam Editor.

STEP 24:
SAVE THE UPDATED MCX FILE.

» Select the Save icon.
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REVIEW EXERCISES.

Student practise. Create the Toolpath for Exercise 1-Tutorial 3 as per the instructions below;

& Tips:
Stock size use Bounding box to establish X & Y sizes and
give Z =1.0"
Center Drill all holes using % Center Drill
Drill all holes through using 5/8 Dirill (copy the previous toolpath and get the new tool and the
depth)
Contour the part using 2 “ Flat End Mill
Max rough step =.5" (Depth cuts)
1 roughing passes with spacing =1.5"
1 finish pass .05 (Muti passes)
Offset the ouside contour geometry with .5 distance
Pocket the part using % “ Flat End Mill
Select the ouside contour first and then the 3" diameter.
Use True spiral cutting method
Contour the hexagon using 2 “ Flat End Mill
Backplot and Verify the toolpaths.
Post process the file.
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REVIEW EXERCISE.

Student practise. Create the Toolpath for Exercise 2- Tutorial 3 as per the instructions below;

& Tips:
Stock size use Bounding box to establish X & Y sizes and
give Z =1.0“
Spot Drill the two holes using 3/4 Spot Dirill
Drill all holes through using 1/2 Drill (copy the previous toolpath and get the new tool
and the depth)
Pocket the slot using 1/8 “ Flat End Mill
Use depth cuts
Use Parallel Spiral cutting method
Contour the part using 3/8 “ Flat End Mill
Max rough step = 0.1875 “ (Depth cuts)
1 roughing passes with spacing =0.1¢
1 finish pass .05" (Muti passes)
Break thru amount 0.1
Backplot and Verify the toolpaths.
Post process the file.
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Objectives:

The Student will design a 2-dimensional drawing by:

> Creating a circle knowing the center and the diameter.

> Creating horizontal and vertical lines.

> Creating lines using co-ordinate positioning.

> Creating parallel lines, by defining the offset direction and distance.
> Creating rectangular shape.

> Trimming the existing geometry.

> Creating fillet radii.

> Mirroring existing geometry to complete a part.

> Rotating one shape two times.

The Student will create a 2-dimensional milling toolpath consisting of:

> A 2-dimensional pocket.
> The rest of the pockets created using Transform toolpaths, Rotate and Mirror.

The Student will check the toolpath using Mastercam’s Verify module by:

> Defining a 3-dimensional cylindrical block the size of the workpiece.
> Running the Verify function to machine the part on the screen.
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GEOMETRY CREATION
Setting the toolbar states

To start a new file from Mastercam:

File
> New

Setting the toolbar states

é" Before starting the geometry creation we should customize the toolbars to see the toolpars
required to create the geometry and machine a 2D part. See Getting started page A-5 in

the User Notes.

é* Toolpaths/Solids manager to the left of the screen can be hidden to gain more space in
the graphic area for design. Press Alt + O to remove it.

& Before starting the geometry make sure that the Grid is enabled. It will show you at each
moment where the part origin is. See Getting started page A-5 for details.

STEP 1:

CREATE THE OUTSIDE ARC KNOWING THE CENTER POINT AND

THE RADIUS/DIAMETER.

Create
> Arc
> Create Circle Center Point

©
» Enter the Diameter value ta

6.

> [Enter the center point]: Move the cursor at the
center location of the grid to select the Origin.

> Use the Fit icon to fit the drawing to the screen.

> Select the OK button to exit the command. &

Select the
origin

é* During the geometry creation of this tutorial, if you make a mistake you can undo the last
step using the Undo icon. You can undo as many steps as needed. 2

& If you delete or undo a step by mistake, just use the Redo icon. €*
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STEP 2:

CREATE THE CENTER LINES USING VERTICAL AND HORIZONTAL
LINES.

#*Change the color of the center lines to avoid
confusion.
> Select the Color icon in the Status bar.

3D | | Gview | Planes Z:l 2.0} &]

Select Color here

» Select the color red (No 12). L ?e%led Color —
> Select the OK button to exit the command. ' Colors |G I

Cumert calor: (12 | 16 Colors
Create 2] { J

> Line ANEEREE_REmEEN | |
» Create Line Endpoint

Vertical : "
Select the first /

» Select the Vertical icon.
> [Specify the first endpoint]: Select a point outside

the circle at approximately 90 degrees endpoint here | \
> [Specify the second endpoint]: Select a point [/ w1
outside the circle at approximately 270 degrees as I - 'J
shown to the right. Select the \ )
= second /
> [Enter the X coordinate]: endpoint here ’
> Select the Apply button. Im = = V.
> Select the Horizontal icon. 1
> [Specify the first endpoint]: Select a point
outside the circle at approximately 0 Select the first N / \
degrees_ endpoint here \ Illa" e \
> [Specify the second endpoint]: Select a f ; /,,71'
point outside the circle at approximately i/./ /
180 degrees as shown in the picture to Select the second \, i
the right. endpoint here /,./'
I —

> [Enter the Y coordinate]; .

> Disable the Horizontal button. Horizontal
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STEP 3:
CREATE POLAR LINES KNOWING AN ENDPOINT, THE ANGLE AND
THE LENGTH.

o)
> Enter the line Length 4.0 (Tab).

F
> Enter the Angle in degrees 45 (Enter).
> [Specify the first endpoint]: Select the drop-down arrow and pick Origin as shown.

> Select the Apply button.
> Enter the line Length 4.0 (Tab).

7
> Enter the Angle in degrees 135 (Enter).
> [Specify the first endpoint]: Select the drop-down arrow and pick Origin as shown above.

o
> Select the OK button. f

STEP 4:
CREATE A PARALLEL LINE.

> Select the Color icon in
the Status bar. [ [ Gview [planes | z: | | Level:[1
Select Color here

» Select the color green (No 10).

> Select the OK button to exit the command. | Colors. | Customize | {1
Curert coor: [10 | [l (38Coen_] [ Seeat |

Cre'ate . Selecl{ i » 2 .= IMGVW@W
> Line color green

> Create Line Parallel

> Enter the Distance [E[ 0.75.
> [Select a line]: Select Entity A.

Select
Entity A

> [Select the point to place a parallel line throughl:

Pick a point to the right of the selected line.
> Select the OK button. &
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STEP 5:

CREATE A RECTANGLE IN THE PROPER ORIENTATION, KNOWING
THE WIDTH, THE HEIGHT AND THE BASE POINT.

» Create

> Create Rectangular Shapes

> Select the radio button in front of Base Point.

> Type the Width and the Height as shown in the picture to the
right.

> Select the double arrow to expand the Rectangle
ShapesOptions if needed.

r

Rectangular Shapes Options  [X]

Select the rectangle
shape

» Enter the fillet Radius 0.02.
» Enter 45 degrees for Rotation.

wwwwwww

Select this radio button

> Select the radio button shown, as the Anchor.

> [Select position of base point]: Select the endpoint as shown.

Select the
> Select the OK button to exit the rectangle endpoint
] here
dialog box. 1 o
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STEP 6:

DELETING THE CONSTRUCTION LINES.

» Select the lines as shown in the picture.

> Select the Delete entity icon. »f/

Select
> Select the Repaint button. & these lines

STEP 7:

CREATE PARALLEL LINES FOR THE INSIDE SHAPE.

Create

» Line
> Create Line Parallel Select Entity
> [Select a line]: Select Entity A.

> [Select the point to place a parallel line through]: Pick a point

to the right of the selected line.
> Enter the Distance [F'I 0.35 (Enter).
TN

> Select the Apply button.
> [Select a line]: Select the line that you just created.

> [Select the point to place a parallel line through]: Pick a point to the right of the selected line.

> Enter the Distance [E[ 0.25 (Enter).

> Select the Apply button. L —

> [Select a line]: Select Entity B. Select Entity B
> [Select the point to place a parallel line

through]: Pick a point to the left of the selected line.
» Enter the distance [F[ 0.35 (Enter).
AT I

» Select the Apply button.
> [Select a line]: Select the line that you just created.

> [Select the point to place a parallel line through]: Pick a point to

the left of the selected line.
> Enter the Distance [F[ 0.25 (Enter). Select Entity C

> Select the Apply button. S

> [Select a line]: Select Entity C.

> [Select the point to place a parallel line through): Pick a point
below the selected line.

> Enter the Distance [E[ 0.275 (Enter).
> Select the OK button. &
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> The drawing should look as shown in the picture to the right. e
/ \
/ \
STEP 8: sy @
EXTEND TWO LINES USING TRIM 1 ENTITY | }
COMMAND. /
Edit
> Trim/Break Moo | 5
> Trim/Break/Extend Entity A ~
Entity B ~
> Select Trim 1 Entity. d ™~
> [Select the entity to trim/extend]: Select
Entity A. Entity C ~—
> [Select the entity to trim/extend to): Select
Entity B. b= [
> [Select the entity to trim/extend]: Select Entity C. i
> [Select the entity to trim/extend to]: Select Entity B. | J
> Select the OK button. & 4

STEP 9:
CREATE LINES KNOWING THE TWO ENDPOINT COORDINATES.

Create

» Line

> Create Line Endpoint

é* By moving the cursor exactly on the endpoint of the entity the system will display a small

N _

square and the endpoint symbol. ‘4" For the second endpoint the system will display the
=

intersection symbol.

— | Select Endpoint C

Select Endpoint A *-\ — | Select Endpoint D

Tl
ol

I |

> [Specify the first endpoint]: Select Endpoint A.

> [Specify the second endpoint]: Select Endpoint B.

> [Specify the first endpoint]: Select Endpoint C.
> [Specify the second endpoint]: Select Endpoint D.

» Select the OK button.

Select Endpoint B =
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STEP 10:
TRIM DIVIDE.

Edit
» Trim/Break
> Trim/Break/Extend

> Select the Trim divide icon from the ribbon bar
> [Select the curve to divide]: Select Entity A.

> Select the OK button to exit. ¥

STEP 11: Select Entity
CREATE FILLET.

Create
> Fillet
» Fillet Entities

> Enter the fillet Radius @ 0.3.

> [Select an entity]: Select Entity A.

> [Select another entity]: Select Entity B.

é* Note that a fillet option will be automatically drawn depending on where you move the cursor
around the entities.

L~ |

Select Entity E
here

Select Entity A
here

Select Entity D
here

C L'y ’_]
/ c Select Entity C
| |

here

Select Entity B
here

> [Select an entity]: Select Entity B.
> [Select another entity]: Select Entity C.

> [Select an entity): Select Entity C.
> [Select another entity]: Select Entity D.

> [Select an entity]: Select Entity D.

> [Select another entity]: Select Entity E.
> Select the OK button. &
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STEP 12:
DELETE THE CONSTRUCTION LINES.

> Select the lines as shown to the right.

> Select the Delete entity icon. 4

|
STEP 13: sy
MIRROR THE PART
ABOUT Y- AXIS.
Xform

» Xform Mirror
> [Select entities to mirror J:

> Hold-down the Shift key and select one entity of the profile as ==
shown to the right.

Select this
entity

> Click on the End Selection button.
> Set the parameters in the Mirror dialog box as shown.

The preview should look as shown in the picture below.

> Select the OK button to exit. »
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STEP 14:
ROTATE THE PART ABOUT THE ORIGIN.

Xform
» Xform Rotate
> [Rotate: Select entities to rotate]: Select the All

@ Gy

> Select Xform Result to select the shape resulting after mirroring.

All Entities
Aorm Result [s,

Xform Group .

Group Manager

> Click on the End Selection button. St Selection
> Make sure that you make all the changes as shown in the screenshot.
» Change the number (#) to 2.

> Enter the angle as 90 degrees.

> If the Preview is active you should be able to see the result.

i [

‘H‘“""h-q____ - B

> Select the OK button to exit. L¥_]
Screen
> Clear colors

STEP 15:

SAVE THE GEOMETRY.
File

> Save As

> File Name: “Your Name_4"

» Select the OK button. L.

: Rotate [-i]

y £ Angle between

{ L=

3 Totel sweep

=
-

) Rolate ) Translate

1) |
w|m]

Preview
O

Altnbutes
[ Use New Attrbutes

&)

= e

3 e

Ta FieMergefPattemn,..

|B§ Edit/Open External..,
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TOOLPATH CREATION
STEP 16:

SET UP THE STOCK TO BE MACHINED.

Machine Type BRIl »=1gn Saeen Art

Machine type
> Mill

> Default

> To display the Toolpaths Manager press Alt + O,

sk ¥Ebkel

i Er

e
,
/

e dDe® | BHIAT |

|2 | ovew109 WesToR TicpneTOR

ook pemaiiter, I Geew Paws B 08 m- Leve: |3

> Select the plus in front of Properties to expand the Toolpaths Group Properties

Toolpaths |Soﬁds I| At

wk N ¥ §3Gl'§’-@ ?
AR vahG$ X@

'-—_=E Machine Group-1
{E 11 Propertles Eenenc Mill

Select the plus ~

> Select Stock setup.

Select Stock
setup

= 1L Properties - Generic Mill
@ Files

@ Tool setlings
|- %> Stock setup
L\ Safely zone

f«l:‘llsl 3R
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Change the parameters to match the
screenshot to the right.

(x]

Rk

[ns..mn][_;:;d. i[ B Entties J[Uﬂm&.]

[vIx][2]

> Select the Tool Settings and change the
parameters to match the following
screenshot.

ngm “ | —
Feed Calauistion : Torlpath Corfiguration
& From tool [ Assign too) numbers sequentially
) From matesial [¥7] Wam of duphcate tocl mumbers |
| From defaults ‘ 7] Use tool's step, peck, coolant |
| :
;) User defined ‘ ] Seam"n f:t;ﬁl;‘uym |
. Advanced eptions |
> Select the OK button to exit Toolpath i [Z10veride defads wth moda v
Group Properties. L. ] IES 1 | B L
[ Adjust fesd on arc move A f E@E i . i % i

Minimum arcfeed (7 0

H
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» Select the Isometric View from the view toolbar to see the stock. J @ @ Q®

> Select the Top View from the view toolbar to see the part from the top.

STEP 17:

POCKET ONE OF THE INSIDE SHAPES.

Toolpaths C:AMCAMX2AMILLANCY
» Pocket Toolpath [YOUR NAME_4

Select this
entity

> Select the OK button to exit Chaining.
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» Click on the Select library tool button. Right-click for options

0 (oomer )

Fuis Combo’s (Default (1))

> Select the Filter button in the Tool e
Selection window. =

Mebw TwilTjw Diameter ToddNoms Comertothn AaducTyos
¥ o= Geser 0500 1ZRA. 000NN Now

> In the Tool Types field
select the None button to
disable all tools.

» Select the Flat Endmill
button in the Tool Type

Tool List Filter

Tool Typeg Tool Diamates oo

Radiug Type
list as shown. FINene @ Coner FIFul
» In the Tool Diameter -
field click the pull-down e -
arrow and select Equal. Ss; ﬁ";”
» Enter the Tool Diameter [T Conted (7] User Def 2

value: 0.1875.
» Select the OK button to |

oxit Tool List Fiter .. [ V R

> Make sure that the tool is selected (highlighted) in the Tool Selection window.

> Select the OK button to exit Tool Selection window.
> Make the changes as shown in the screenshot to the right.

Pocket (Standard)

“Tookath ¢ [ Pocketingp |/ RoughingFirishing p |

Tm{ Type | Diameter . ToolMame Comecrad  Tool name: | 316 FLAT ENDMILL ]

.. 01875 . 3/16FL. 0.000000 T [T | tnoma[l |
Head & {Ew_.—------—-w Dia. offset: i MMMMMM g
é* The Feed rate, ST
Plunge rate, Retract PR
rate and Spindle ‘ ; _
speed are basedon | ‘ :
the tool definition. f Punge ate: (6160896 | Reractrate: 6.160856 |
Change them as 3 [Forcetooi change  [] Rapid retract
desired. - _ Comment
——— P.lgl'ﬁ-did{ 50;0;0;: Machining one pocket #

[ To batch . { Home pos... |
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> Select the Pocket parameter page and match the parameters with the following screenshot.

Clearance.. ] |2.E [ Machining direction

s 2 TR @ amb O Convertional

[ Use clearance only at the Tip comp

| start and end of operation
Retrac Roll cutter
[ ] !0'25 i around comers
& Absolte O Incremertal I agization
1 tolerance
[ Eeedplane... ] [0 J
) Absclte () Incremental XY stock to leave
N . Z stock to leave

Topofsiock..] [00 |
@sbsote  Olnoremenial [ Create addtional finish operation
([ Deph.. | (0728 |
& dbsolte ) Incremental

Ay e I | [ e e e —

:7&; = 1 1 | [FFauh Cuttting method:  Constant Ovedap Spiral

l I (] l B & l§
around th_e chket

walls to “contour” the Sepoverpecutage [0 | oy -
walls. Used when Zig- Sepoverdgtance (013125 | 7] ool ide o outaide [t Speed
zag or One way was i)
‘selected as cutting

- method, to remove the
' M.;‘a;&;gps left by these
cutting methods, It can
Hé"élﬁé "u‘sed« to finish

\\\\\\\\\

? |

> Select the Constant Overlap Spiral as the Cutting method.
» Enable Spiral inside to outside to spiral from the center to the pocket wall.
> Disable the Finish area.
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> Select the OK button to exit Pocket parameters. LL]

STEP 18:
MODIFY THE TOOLPATH TO COMPLETE THE REMAINING POCKETS.
18.1 Option 1.

SeIeCt Geometry . Eﬂ 1 - Focket [Standaid) - P/CS: T

] Parameters

§ #1-0.1875 ENDMILL1 FLA

= Geometry - (11 chainls)
L Toolpath - 6.2K - MACHINE;

> Select Geometry in the Toolpaths
Manager.

> Right-mouse click in the Chain Manager.
> Select Add chain.
> Select all remaining pockets.

Select these =l o
chains ~——]

> Select the OK button to exit Chaining. L¥_]
> Select the OK button to exit Chain Manager.

g p ] e

> Select the Toolpaths Manager. % %’J%‘p ggf 7‘ .y
> Select the Regenerate all dirty operations button. (@ 22 (8] | WRegenerate ol drty operatons|
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18.2 Option 2. Using Transform toolpaths.

¢ Transform toolpath allows you to copy and change the orientation of previously created
operations. You can use this function to translate, rotate, or mirror operations. You must
create an operation before using the Transform toolpath. You can also transform a
transformed operation. Transform toolpath is associative.

> Select Geometry in the Toolpaths Manager again. & Chain Manager

> Right-mouse click on Chain 2 in the Chain Manager.

> Select Delete chain.

> Repeat these steps to delete Chain 3 and Chain 4.

> Select the OK button to exit Chain Manager.

Resync all

Sart options...

> Select the Regenerate all dirty operations button.

[% @ ‘1_c9merate al drty operations|

Toolpaths
> Transform Toolpath
> Select Mirror in the transform Type

& BE Machine Group-1 | [ Craate new operations and geometry |
O Transiate -1l Propedies - Generc Mil e s tranafom apsration
Yoileiuna %82 Tooketh Grouwp-1 | | s i e o
& &2 1 - Pocket (Standard) - IWCS: TOP] - [Tplane: 1 Dcmmmm
© Rotata [
Method - | o, Boselide o neremenial
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Select the Mirror tab to set the Y-axis about which the system replicates the toolpath.

Transform Gperation Parameters

| Type and Methods | Translate | Rotate | Mimor |

¢ Mimor soethad s s~ Mimor ponts
O X-axis

@) Y-adis

O Entty

[v][% ][ 2]

> Enable Reverse toolpath for the system to cut the second pocket in the same machining

direction (climbing or conventional).

> Select the OK button to exit Transform Operation Parameters. |

Page 4-19




Mill X?

Mastercam,

TUTORIAL 4

Toolpaths

» Transform Toolpath

» Select Rotate as r
transform Type.

Transform Operation Parameters

[ Type and Methods | Transiste | Fotate | Wiror |

| I
Type Soecpectos
= EE Machine Group-1

@ L Properies - Ganerc Mil

O Translate
s Foad ot = 82 Tocpath Group-1

® Rotate [N~}

i [ 1 - Pocket (Standard) - [WCS: TOP) - {Ty

2 - Trarsfom by Coordinate X
aing =t seleciad
O Miror oy
Mathod & Mwnige T eremerii
. O Tool plane Work cffset numbering
| (®Coordinate @ Of
| o s
+ Group NCJ output by 1
\ | B | ©ynen
Stat
Comment AL
Incrament
& [ Maich enisting cffsets

> Enable Coordinate as the Method to allow the system to rotate the toolpath in the same tool
plane.

> Enable the previous Transform operation in the Source operation field.

> Select the Rotate tab to establish the parameters required to obtain the other two pockets.

r
Transform Uper

{® Ongin Number of steps

O Paint Start angle:

X = } Rotatiort angle

=z _| Rotation view ﬂ
m iSource operations’ teol planes

(v [ %] 2]

> Select the OK button to exit Transform operation parameters. '
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gI\E:T(&OT THE TOOLPATH e

F K Hh % EDo
> Select the Select all operations button. m ¢

> Select the Backplot selected operations button.

> Make sure that you have the following buttons turned on (they
will appear pushed down).

> Display tool Display tool

> Display rapid moves

Display rapid moves

> Select the Isometric View from the view toolbar to see the stock!|
> Select the Play button.

Q:EHW[WI@{E] A

> Select the OK button to exit Backplot. |
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TOOLPATH VERIFICATION

STEP 20:

VERIFY.

[ Tooathe [soids |

@;%;y,_rflg:

> Expand the Toolpaths Manager if necessary by dragging
the right side.

> Select the Verify selected operations button.

Display control .
Moves/step: i
b &

Moves/iefresh: 1 i
&

nnnnnn

I:]Stupnnlonlm
] Stop after each opesation.

i
(0] 1 fu D 1
1 &

Toolpath:  Transform %

Tool Bt
Tool labat

» Set the Verify speed by moving the slider bar in the speed control

raEaEa

bar. L

> Select the Machine button to start simulation. 4
> The finished part should appear as shown in the following picture.

» Select the OK button to exit Verify.
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STEP 21:
POST THE FILE.

» Make sure that all operations are selected.
> Select the Post selected operations button from Toolpath Manager.

Post processing

7 Qutput MCX file descriptor

NE fle
> Overwiite [¥] Edit
) Ask NE estension:

MNC
7] Send ta machine et i
> In the Post processing window, make all the necessary
changes as shown to the right.
> Enable NC file to keep the NC file assigning the same name ; bt
as the MCX file. -  eddive 2 WS
> Enable Edit to automatically launch the default editor.

> Select the OK button to continue. L

] weliile

RE o A%

> Select the Save button to accept
the file name.

> Select the red X at the upper right side to exit.

STEP 22:
SAVE THE UPDATED MCX FILE.

» Select the Save icon.
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REVIEW EXERCISES.

Student practise. Create the Toolpath for Exercise 1-Tutorial 4 as per the instructions below;

& Tips:
Stock size use Bounding box to establish X &Y sizes and give Z = 1“
Contour the part using 1.5" Flat End Mill
Max rough step =0.5" (Depth cuts)
1 roughing passes with spacing =0.5"
1 finish pass 0.05“ (Multi passes)
Pocket the part using % “ Flat End Mill
Use Constant overlap spiral cutting method
Backplot and Verify the toolpaths.
Post process the file.
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Student practise. Create the Toolpath for Exercise 2-Tutorial 4 as per the instructions below;

& Tips:
Stock change to Cylindrical shape; enable
Z-Axis; Height= 0.25" & Diameter = 7.0"

Center Drill & Drill the 1.0“ diameter thru hole.

Pocket the 1.75“diameter using 1“ Flat End Mill
Use True spiral cutting method

Contour the part using the1.0“ Flat End Mill
1 roughing passes with spacing =0.1*
1 finish pass 0.05“ (Multi passes)

Contour remachining the part using 0.375 “ Flat End Mill
Enable Remachining in the Contour Type and set
the parameters as shown in the screenshot.

Backplot and Verify the toolpaths.
Post process the file.

Contour remachining
cmmmam@m-

O All previous operations

{0 The previous oparation

© b ool dameied __

FRoughing tool dismeter ng l ;
Clwm EL 05 |
Remachiing lolerance (50 |% (005 |
[ Diaplay stock -

FAE3 N
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